Xiaomi WiFi Router 3G


#663

Did anyone had any success changing the bootloader so far for this route ?


#664

Unfortunetly "Aditional compiling options: -O3" makes kernel1.bin exceeds 2MB and (for me) lzma error during boot.

And after trying all method I found on net to fix corruption bug - by change to kernel 4.4 only works (up to now). Just copied 5GB of big video files without failure. Hope that they fix 4.14/4.9 soon.


#665

Hi guys! After flashing latest version of openwrt for m3g lost wifi configs, no wifi configs in luci. Please tell me how switch on wifi on my roter? Scrennshot luci - http://prntscr.com/iosnvq


#666

So did you try that manual boot method?


#667

What is manual method?? I was trying to patch Config-4.9 in target/Rampis


#668

Updated build.. latest master GCC 7.3 kernel 4.14 and irq balancing script


#669

Hello,
I need the kernel0.bin file that is on the wiki, but his link is broken.
I'm trying to get back to the original firmware via serial, but I can not.
Could someone provide the kernel0.bin file for me?


#670

kernel0.bin

I have also updated the link in the wiki and in my earlier post.


#671

Dear all, i tested Breed as bootloader for faster switching between Images.
But my Problem is, i'am unable to get a workig LEDE.

Like described earlier i merged kernel and rootfs but after flashing i run into trouble.

root@OpenWrt:~# opkg install luci
Installing luci (git-18.068.60872-bf04031-1) to root...
Collected errors:

  • verify_pkg_installable: Only have 0kb available on filesystem /overlay, pkg luci needs 1
  • opkg_install_cmd: Cannot install package luci.

what i'am doing wrong ?

How can i go back to original Bootloader ?
I have a complete mtd backup from before my first Prometheus test.

Regards

LuFi


#672

You guys, how is the update procedure with the Xiaomi Router. I had a wndr3800 before and with that i saved my config files, wiped the whole thing and flashed the image in failsafe mode with tftp. Copied back the config and done.

Dont know with this one...reading about some bricks makes me worried. Is it save and the same with just using the internal update feature in luci? Is it as clean as the tftp methode or does it even matter?


#673
  1. Flashing stock firmware in Firmware1 and Firmware2 (Breed).

  2. From the stock firmware, flashing kernel1 + rootfs0

    mtd write lede-ramips-mt7621-mir3g-squashfs-kernel1.bin kernel1
    mtd write lede-ramips-mt7621-mir3g-squashfs-rootfs0.bin rootfs0
    nvram set flag_try_sys1_failed=1
    nvram commit
    reboot

Flashing LEDE of Padavan..

for /f %%i in ("openwrt-ramips-mt7621-mir3g-squashfs-kernel1.bin") do ( set /a size = 4194304 - %%~zi >nul )
fsutil file createnew dummy2.bin %size% >nul
copy /y /b openwrt-ramips-mt7621-mir3g-squashfs-kernel1.bin + /b dummy2.bin + /b openwrt-ramips-mt7621-mir3g-squashfs-rootfs0.bin firmware.bin >nul
del dummy2.bin


mtd_write write /tmp/firmware.bin Firmware_Stub
reboot

#675

Thank you!


#676

I have one question:
How can I block certain devices from accessing the internet?
I have a xiaomi gateway and I want to block the internet access for it.

Thank you!


#677

I think it is really straightforward.openWRT/LEDE wiki, i'd use the mac address src.


#678

This System is currently extreme unstable. Tested a lot also including the Stock driver from Nossiac feed.

mt76 driver disconnects clients sporadically, not only ios devices.
mt76 authentication problems for unknown reason (wrong password is shown)
IP connectivity lost also if wifi still is connected.

Stock driver from feed: Hung state while loading 5ghz driver.

Looking forward into future, but currently ...........

Regards

Lufi


#679

And after testing for a while latest commits - usb hdd support is better but not stable. Files c.a. 10 GB or parallel transfer from two hosts (through afp) still generate bugs.


#680

Hey guys did you noticed that the txpower of the 2,4ghz wifi device couldn't be set? It stay always 0 at least that is reported by iwinfo wlan0 info i tried to set manually by iw dev wlan0 set txpower 2000. And nothing has changed (still zero).

Is it solved by this commit? https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=608c84b96ea6b4501b9f64d3f9103a6ec8e7a144


#681

no still same reports 0


#682

Hello,
Do you know if there is any plan to include support of this router to a stable version of LEDE / OpenWRT?


#683

there is no implemented power reporting in opensource mt7603 driver