Xiaomi WiFi Router 3G

Yes, running from 8h without kernel warnings and problems (Only 2.4 GHz RX 40 MHz channel width).
For now it is stable...

1 Like

So, is this commit will be included in tomorrow's snapshot release?

Just joined this club.:grin: (though had been lurking for quite a while)

Would like to add another confirmation that 2.4G 40MHz width not working. 5.8G all widths are ok for me.
Tested with Wifi Analyzer on Xiaomi Redmi Note 3 SD. (r5446-aec1b6b)

Thanks for your feedback at least I'm not alone :wink:

Probably not, the snapshots for this model hasn't built correctly for the last two weeks.

Since 22.11.17. there has not been a sucesfull build.

It gets stuck on RE350 v1

Somebody has to make a bug report at least

Maybe I don't understand something (I just started to learn), but when I build manually from source I get images without any warning.
Or they are faulty? (I did not tried to flash them).
Buildbot doing something different?

Nope, it's because buildbot tries to build snapshots for entire arch/subarch (ramips/mt7612 in our case) and failure in build sequence for one device (RE350 in our case) affects (stops) snapshot generation for entire subarch. Quite annoying but we'll have to wait for devs to figure it out if we want download snapshots instead of building them by ourselves.

EDIT: I'm unsure where to submit buildbot errors (if there is any way to do it)

You can post them in LEDE-dev mailing list.
I will try building for RE350 and see where it fails in order to fix it

Manually building RE350 works without issues.
I dont know on what does buildbot fail then

1 Like

@nbd have fixed snapshot generation with this commit. Yay.


Where can i find a good working sysupgrade.bin that i can flash with luci?
I am confused because here https://lede-project.org/toh/hwdata/xiaomi/xiaomi_miwifi_3g i only find a sysupgrade.tar

Use the sysupgrade.tar to upgrade. It works.

Is there any change to flash lede on this router without needing to do the long manufacturer-process:

  1. learn chinese
  2. register
  3. learn more chinese
  4. get the dev rom and flash
  5. show your chinese skills
  6. download a untrusty app and install on your phone
  7. and so on.....

ok it worked Thanks.
but all settings and scripts are gone... much to do...

This is one of the reasons I compile the image with ImageBuilder, so that all of my settings and additional luci-apps would still intact after upgrade.

ok thank you i will try this.

I used this video (https://www.youtube.com/watch?v=fKlEKfQqC2w&vl=en) to get me through the Chinese menus and it was not easy. Note that it also is not the procedure to flash Lede; but it was helpful when I was following the instructions in the OP when attempting to find where to flash the developer firmware in step 8.

For me 2.4GHz WiFi is very unstable. I don't know what to do.

In Syslog i get this message: "disconnected due to excessive missing ACKs". I tried "disassoc_low_ack" in wireless config and this error is gone from my logs, but WiFi is still unstable. While this I can ping websites, but they are not accesible from any browser. Ethernet is file, 5Ghz band also, just this 2.4Ghz band... Disabling WMM (only for 2.4) solves my problem, but it slows down my internet dramatically. Please tell me what I can do to resolve this issue.

I experienced exactly same problem with 7-years old D-Link router.
For me it happens sometime, when I disable and enable Wi-Fi in LuCI (for example, when changing config).
But reboot always helps.

Also, with same D-Link I experiencing very strange problem - when I enable static IP from my provider my WiFi stops working completely after 5-10 minutes when I connect any Wi-Fi device (disabling and enabling won't help), and then it looks like router CPU is overloaded (it is very unresponsive and network is extremly slow and only reboot helps until next Wi-Fi connect).
But after disabling static IP and receiving dynamic IP all problems disappears.
Don't know, how it even technically possible, but it is.
Maybe there are very rare undiscovered bugs in LEDE/OpenWrt.

Does anyone happen to have experience with both this device and the DIR-860L? I'm wondering whether the newer wifi chips are worth the upgrade. Seeing the complaints about unstable 2.4ghz wifi I'd think not, but if someone has experience with both it would be very appreciated to have a direct comparison :slight_smile: