Xiaomi WiFi Router 3G

Just to let you know, nbd is aware of the issue and is looking for a fix


Change has been reverted https://git.lede-project.org/?p=source.git;a=commit;h=47fa8654a1358aa63f5be0e51a3738f834de8d86 (removing the 140-tweak-TSQ-setting.patch)

1 Like

I got the same problem as yours.

Now is fixed, see previous messagges.

Please advise if selecting MediaTek Ralink MIPS in Target System and MT7621 bases boards in Subtarget is enough to build a firmware?

Does anyone know of a mirror for http://downloads.pandorabox.com.cn? - because something can not be stuck (either died or I do not know - Chinese authorities block?). Possibly bearings for the latest fw pandorabox under mi-r3g.

You have to choose xiaomi mi router 3G in sub target (the one that appears after you choose mt7621) and don't forget to include LUCI

@dissent1 and @hammer
I'm testing latest mt76 and mac80211 commits from @nbd and is stable, no more reboots.
For now I do not even have the kernel warnings

[18551.439869] WARNING: CPU: 3 PID: 6416 at /home/massy/lede/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7621/mt76-2017-11-16-8f1c8abd/mt7603_mac.c:1291 mt7603_mac_work+0x124/0x248 [mt7603e]
[18551.456969] Modules linked in: pppoe ppp_async pppox ppp_mppe ppp_generic nf_conntrack_ipv6 mt76x2e mt7603e mt76 mac80211 iptable_nat ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_tcpmss xt_statistic xt_state xt_recent xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_helper xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_HL xt_DSCP xt_CLASSIFY usblp ums_usbat ums_sddr55 ums_sddr09 ums_karma ums_jumpshot ums_isd200 ums_freecom ums_datafab ums_cypress ums_alauda uas slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_conntrack_ipv4 nf_nat_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache iptable_mangle iptable_filter ipt_ECN ip_tables crc_ccitt compat sch_cake nf_conntrack act_skbedit
[18551.527802]  act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_tbf sch_htb sch_hfsc sch_ingress ledtrig_usbport ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables x_tables ip_gre gre ifb ip_tunnel tun vfat fat ntfs hfsplus nls_utf8 nls_iso8859_1 nls_cp437 sha1_generic ecb usb_storage leds_gpio xhci_mtk xhci_plat_hcd xhci_pci xhci_hcd sd_mod scsi_mod gpio_button_hotplug ext4 jbd2 mbcache exfat usbcore nls_base usb_common crc32c_generic
[18551.570590] CPU: 3 PID: 6416 Comm: kworker/u8:2 Not tainted 4.9.65 #0
[18551.577020] Workqueue: phy0 mt7603_mac_work [mt7603e]
[18551.582047] Stack : 8c992300 804d0000 8046fa44 8ea16a58 00000009 0000050b 8c992318 00000088
[18551.590395]         804d0000 8006b988 8046fa44 00000003 00001910 80533824 8046f9b0 8e6c9d54
[18551.598743]         804d0000 800a83b0 00000001 80530000 804ddec4 804ddec8 80474650 8e6c9d54
[18551.607091]         804d0000 80043334 8c992318 8e6c9d8c 00000401 00000000 00000000 006c9d74
[18551.615436]         8ea156f8 8ff5d400 8ff5d300 30796870 00000000 00000000 00000000 00000000
[18551.623781]         ...
[18551.626220] Call Trace:
[18551.628678] [<8000f884>] show_stack+0x54/0x88
[18551.633025] [<801daefc>] dump_stack+0x8c/0xd0
[18551.637367] [<8002bdd4>] __warn+0xe4/0x118
[18551.641444] [<8002be9c>] warn_slowpath_null+0x1c/0x30
[18551.646480] [<8ea1581c>] mt7603_mac_work+0x124/0x248 [mt7603e]
[18551.652312] [<80041114>] process_one_work+0x200/0x348
[18551.657346] [<80042034>] worker_thread+0x2fc/0x488
[18551.662127] [<80046c10>] kthread+0xe0/0xf4
[18551.666207] [<8000a478>] ret_from_kernel_thread+0x14/0x1c
[18551.671687] ---[ end trace 5a1403c04afe2a3f ]---

I am also now stable with the latest build - however I am still really slow in terms of wireless performance on both 5ghz and 2.4ghz. I am using fixed channels and seeing only 14mbps down on 2.4mhz on a 250mbps connection. I am assuming that others are seeing the same as far as wireless performance?

5 GHz for me is perfect :slight_smile:
My notebook adapter speed is max 433 Mbps for 5GHz

Is it normal that with 2.4 GHz I can not get 40MHz channel width anymore?
The configuration has not been changed, LuCI says that devices are connected with 40 MHz but my Intel AC 3165 (Driver and Honor 6X only gets 20 MHz width.
With previous version (r5433) i have always 40 MHz channel width with 2.4 GHz


I do not have speed issues. I have a 100/60mbps Internet connection and I can max it out on 5GHz. On 2.4Ghz I see lower speeds ~40mbps up/down - but that is as expected.

Also for me 5 GHz are fine.
@hammer do you have 40 MHz channel width with 2.4 GHz?
Please don't see LuCI but your wireless adapter speed.

I'm not using 40Mhz and it probably will not make any sense to try.
I live in an apartment with ~15 neighbor 2.4GHz APs so it's impossible to select any channel that does not overlap others even on 20MHz. So selecting 40Mhz will just auto fallback to 20MHz as pr. design.
Are you sure that you don't overlap other APs on 40MHz. Maybe someone nearby have changed channel or setup a new AP and it's just a coincidence that this happened when you upgraded firmware.

1 Like

There are no others 2.4 GHz nearby networks.
I do not understand why LuCI indicates 40 MHz channel width but all devices, that with previous build was connected with 40 MHz, now are locked to 20 :roll_eyes:

Try the following:
option noscan '1'
option htmode 'HT40'
option ht_coex '1' — doubtful, may be useless.

Unfortunately, OpenWRT strictly follows the standards. If the broadcast is noisy, then 40Mhz is turned off.

Firmware Padawan and Pandorabox do not follow this.

1 Like

Thanks, I tried but it does not work because i already have 40 mhz

I am still slow and I have checked channel overlap, etc. Still getting about 15 - 40 down on both 2.5 and 5ghz. The other wireless A/P that I replaced was getting about 100 down on 2.4 and 190+ on 5ghz so something is up. Here is my config:

config wifi-device 'radio0’
option noscan '1’
option type 'mac80211’
option channel '11’
option hwmode '11g’
option path 'pci0000:00/0000:00:00.0/0000:01:00.0’
option htmode 'HT40’
option ht_coex '1’
option country ‘00’

config wifi-iface 'default_radio0’
option device 'radio0’
option network 'lan’
option mode 'ap’
option ssid 'miwireless’
option encryption 'psk2+ccmp’
option key ‘it is a secret’

config wifi-device 'radio1’
option type 'mac80211’
option channel '36’
option hwmode '11a’
option path 'pci0000:00/0000:00:01.0/0000:02:00.0’
option htmode 'VHT80’
option country ‘00’

config wifi-iface 'default_radio1’
option device 'radio1’
option network 'lan’
option mode 'ap’
option ssid 'miwireless_5G’
option encryption 'psk2+ccmp’
option key ‘it is a secret’

Set tx power to a fixed value, not auto

@hammer @LESHIY_ODESSA @dissent1
I think that the problem for 2.4 GHz is this

All devices ALWAYS connect 20 MHz RX and 40MHz TX
Is definitely a bug, tried also with option noscan 1 but I repeat next to me theren't 2.4 GHz wireless networks.

That's actually proper behavior because you are mislead by RX and TX. Those values are represented router wise, so what's for a router is TX for you and your client device is RX.
So when you are downloading smth routers TX (yours RX) switches to 40mhz, but routers RX (yours TX) stays intact, because you are not uploading smth.

Try to upload smth and watch the behavior.