Xiaomi WiFi Router 3G

I flashed breed using mtd write but now the led doesn't power on and it doesn't reply to 192.168.1.1

Hello! How do I perform sysupgrade, if sysupgrade file has .tar but not .bin extension?

You must use the .tar file

Did you follow the instructions in the first message?

https://github.com/lede-project/source/commit/f2107fc328ff7f9817fe9ca64f84bba9e32abfc6

No, I flashed BREED only so as to have a failsafe bootlaoder for recovery (ironic in hindsight :slight_smile: ) and would flash LEDE after that through BREED. Is it possible to recover without serial now? LED doesn't poweron, only the ethernet link status led (green) blinks when a cable is connected.

If not how do I recover with serial? I wrote breed to the Bootloader mtd partition

mtd write breed.img Bootloader

How does one flash lede using BREED? I've tried to do this a couple of times without success.

deleted is not working

How did you install BREED?

on WEB GUI ?

Interesting :roll_eyes: MT76 precompiled drivers (mediatek wifi is useless in MT7628)

i got my device today and tried @hammer guide, but i cannot get ssh to work

On a PC, visit http://d.miwifi.com/rom/ssh46 and sign-in to you account. You will get to a page that should display your router, the root password and a download button. Hit the button to get miwifi_ssh.bin

i always get this error:
502 Bad Gateway

The proxy server received an invalid response from an upstream server. Sorry for the inconvenience.
Please report this message and include the following information to us.
Thank you very much!

URL: https://d.miwifi.com:4434/rom/ssh?userId=123456789
Server: sgp1-xq-proxy02.awssgp
Date: 2017/11/10 00:54:06
Powered by Tengine

has anyone had the same problems? or is it just temporary downtime?

visit http://d.miwifi.com/rom/ssh46

It is http://d.miwifi.com/rom/ssh (there's no "46" in the address). Also, most of the times (at least for me), xiaomi's server is broken, so you must try another time...

Yes, only temporary downtime.

my device is running fine now.
i got the ssh bin file on my android phone. on normal pc I always get above error!

the xiaomi mi wifi 3g router works great so far!
128MB FLASH! so great, you can install wathever you need/like and still 87% freespace :wink:

i tried vlans today, it did not work for me. has anyone else tried vlans on this device?

Workaround Problem with VLAN tagging on DIR-860L (MT7530)

Did you fill up all vlans from 1 up? They don´t have to be connected (CPU tagged not needed) but they have to exist.

deleted is not working

Just installed latest LEDE build (snapshot r5369-2dc4852) in my brand new Xiaomi 3G router as I wanted to use it as Wifi repeater and being able to set a different IP range for the Xiaomi and unfortunatelly this can't be done with the default firmware.

I have the setup working but Wifi performance for devices connected to the repeated Wifi radio created by the Xiaomi router is very poor. The upload speed is great but the download speed is very low. Connecting to the main router gives me about 50Mb/second but doing the same test with the same device connected to the Xiaomi gives no more of 3 or 4Mb :cold_sweat:

Also for some reason all the devices connected to the Xiaomi wifi lost internet access after a few minutes, wifi is not dropped just no access to internet, no problem when connected to the main router. To access to internet again I must to disconnect from the Xiaomi and connect again, then I have internet again for some minutes or even less than 30 seconds.

If someone can give me some pointers on how to solve this I would thank you a lot.

Update The snapshots are working. For some unknown reason sysupgrading to a newer build was making the router unstable. But after a factory reset the build became fairly stable. Read Xiaomi WiFi Router 3G for details.

Original post below:


Just a little warning as there might me something wrong with the lastest builds for the Xiaomi 3G.

My router was running perfectly for the last 10+ days and tonight i decided to do a new firmware compile as there are some interesting commits like https://git.lede-project.org/?p=source.git;a=commit;h=fa6fd45613d05da96b6733b15f91e51482378bb0
Unfortunately I ended up with a router that was only up and running for a few minutes and then it rebooted. After this happend a few times I decided to sysupgrade (downgrade) to the last build that was running perfectly. I guess the router decided to reboot in the middle of the upgrade procedure which resulted in a router that just went into a constant boot-loop. After a bit of soldering the serial console showed this.

[ 2.577402] # MTK NAND # : Use HW ECC
[ 2.581079] Device not found, ID: c8d1
[ 2.584805] Not Support this Device!

[ 2.588530] chip_mode=00000001
[ 2.591596] Support this Device in MTK table! c8d1

[ 2.596544] [NAND]select ecc bit:4, sparesize :64 spare_per_sector=16
[ 2.603019] nand: device found, Manufacturer ID: 0xc8, Chip ID: 0xd1
[ 2.609339] nand: ESMT NAND 128MiB 3,3V 8-bit
[ 2.613691] nand: 128 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64
[ 2.621254] Scanning device for bad blocks
[ 2.771199] 10 ofpart partitions found on MTD device MT7621-NAND
[ 2.777175] Creating 10 MTD partitions on "MT7621-NAND":
[ 2.782485] 0x000000000000-0x000000080000 : "Bootloader"
[ 2.789219] 0x000000080000-0x0000000c0000 : "Config"
[ 2.795413] 0x0000000c0000-0x000000100000 : "Bdata"
[ 2.801481] 0x000000100000-0x000000140000 : "Factory"
[ 2.807656] 0x000000140000-0x000000180000 : "crash"
[ 2.813968] 0x000000180000-0x0000001c0000 : "crash_syslog"
[ 2.820600] 0x0000001c0000-0x000000200000 : "reserved0"
[ 2.826888] 0x000000200000-0x000000600000 : "kernel_stock"
[ 2.833538] 0x000000600000-0x000000a00000 : "kernel"
[ 2.839547] 0x000000a00000-0x000007f80000 : "ubi"
[ 2.846300] [mtk_nand] probe successfully!
[ 2.851166] Signature matched and data read!
[ 2.855414] load_fact_bbt success 1023
[ 2.859683] libphy: Fixed MDIO Bus: probed
[ 2.933067] libphy: mdio: probed
[ 4.335817] mtk_soc_eth 1e100000.ethernet: loaded mt7530 driver
[ 4.342491] mtk_soc_eth 1e100000.ethernet eth0: mediatek frame engine at 0xbe100000, irq 20
[ 4.352719] NET: Registered protocol family 10
[ 4.358638] NET: Registered protocol family 17
[ 4.363185] 8021q: 802.1Q VLAN Support v1.8
[ 4.370043] UBI: auto-attach mtd9
[ 4.373428] ubi0: attaching mtd9
[ 5.486107] ubi0: scanning is finished
[ 5.505873] ubi0: attached mtd9 (name "ubi", size 117 MiB)
[ 5.511401] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
[ 5.518241] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
[ 5.525012] ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
[ 5.531956] ubi0: good PEBs: 940, bad PEBs: 0, corrupted PEBs: 0
[ 5.537932] ubi0: user volume: 0, internal volumes: 1, max. volumes count: 128
[ 5.545136] ubi0: max/mean erase counter: 4/2, WL threshold: 4096, image sequence number: 719383500
[ 5.554156] ubi0: available PEBs: 916, total reserved PEBs: 24, PEBs reserved for bad PEB handling: 20
[ 5.563454] ubi0: background thread "ubi_bgt0d" started, PID 353
[ 5.563475] hctosys: unable to open rtc device (rtc0)
[ 5.574963] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[ 5.582439] Please append a correct "root=" boot option; here are the available partitions:
[ 5.590800] 1f00 512 mtdblock0 [ 5.594791] (driver?)
[ 5.597143] 1f01 256 mtdblock1 [ 5.601149] (driver?)
[ 5.603503] 1f02 256 mtdblock2 [ 5.607485] (driver?)
[ 5.609834] 1f03 256 mtdblock3 [ 5.613834] (driver?)
[ 5.616187] 1f04 256 mtdblock4 [ 5.620169] (driver?)
[ 5.622542] 1f05 256 mtdblock5 [ 5.626526] (driver?)
[ 5.628876] 1f06 256 mtdblock6 [ 5.632875] (driver?)
[ 5.635228] 1f07 4096 mtdblock7 [ 5.639210] (driver?)
[ 5.641583] 1f08 4096 mtdblock8 [ 5.645568] (driver?)
[ 5.647917] 1f09 120320 mtdblock9 [ 5.651917] (driver?)
[ 5.654269] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[ 5.664701] Rebooting in 1 seconds..

Using uboot console I was able to boot the stock kernel and then flash the stock firmware using the recovery mode of the stock kernel. After this I have installed my last working LEDE build and I'm up and running again.

Yikes! I just received mine tonight and I was going to attempt to load the latest snapshot. I guess I need to hold off?

Edit - and it sounds like the post above is a similar issue to what you are describing.....