Xiaomi WiFi Router 3G

Indeed, router advertise 40Mhz 2.4G connection if I switch country TR and select channel 13 with 40Mhz
I can see it's 40 mhz wide signal when I check it by my phone. But phone just connects with 20Mhz. This might be related with my phone. Check it with your devices.

For 5Ghz band, after little wait, it became active for channels >52. It just takes little longer than <52 channels for activation.

1 Like

This is not a phone, I have the same thing. Use the Padavan firmware.


This is a standard behavior to prevent from violation of the IEEE 802.11-2012 specification.

Please have a look (at) smallnetbuilder.com | Bye Bye 40 MHz Mode in 2.4 GHz

Imagine every user would pimp / modifiy they Routers in such an evironment (for example via tl-wr841nd#dbm_tx_power_hack_v9) :wink:


friends, how should proceed to return to firmware stock having LEDE installed ?

I used this method of installation:
In SSH console
cd /extdisks/sda1 (can be different if you remove and reinsert the usb stick)
mtd write lede-ramips-mt7621-mir3g-squashfs-kernel1.bin kernel1
mtd write lede-ramips-mt7621-mir3g-squashfs-rootfs0.bin rootfs0
nvram set flag_last_success=1
nvram commit

What do I need to get back to stock?

I´m in the same boat. Got LEDE running but want to go back to stock (and then try padavan).
But putting the miwifi.bin on a usb drive and pressing the reset button does only put the router in recovery mode but does not flash the sock firmware.

Anyone got any suggestions?



it would suffice to just change that line on the SSH terminal ?

nvram set flag_last_success=0
nvram commit

and put stock firmware on usb ?

Should be enough if you use a build that is after this commit

thank you for your attention
I'll take the test soon.

I'm testing LEDE SNAPSHOT r5107 and I no longer have the problem with “did not acknowledge authentication response” :smiley:

A great thank you to all for the great work.

I have only a small display bug

Wifi works perfectly and even the LEDs work fine, I set the led status to flash red with wan activity.

Most likely that is due to bumped mt76 driver

Seriously, does it work well? And what about the width of the channel 40Mhz?

You have a screenshot of 61mbit / s. Very funny.

Has anyone tested Samba or USB hard drive performance? According to mediatek 2013 roadmap the MT7621A can do 72MB/sec read and 29MB/sec write to FAT32 over samba but it appears to have a hardware "storage accelerator"

Certainly there are 13 connected android clients far away from router to test the problem.

If use 'option noscan 1' (40 MHz) I can get also 170 Mbps, always away from the router.

I think so...

I do not believe. Show me this.

For me, there is no difference in “did not acknowledge authentication response” with r5117

I updated to r5117-fbde9ac (Oct 20 build) and the "did not acknowledge authentication response" issue still reproducing, but after some reties I'm able to connect to the 2.4GHz.

Sorry now I have only 150 Mbps clients

@MaFL2k @dror
I can not reproduce the problem anymore, tested with:
Samsung Tab A 10.1 2016
Honor 6X (Two devices)
Moto G4
Lenovo ideapad 700-15ISK
Samsung Tab A 7 2016
Samsung J3 2015
Apple iPad 3
Amazon Kindle

Are you using some particular configuration?
This is mine

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '4'
	option htmode 'HT40'
	option country '00'
	option noscan '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'LEDE'
	option encryption 'psk2+ccmp'
	option key 'mypassword'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
	option htmode 'VHT80'
	option country '00'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2+ccmp'
	option key 'mypassword'
	option ssid 'LEDE 5GHz'

Reach with my devices expected values....

in 2.4 GHz Network (N-Draft) ---> *-ac devices accting in 5 GHz Network

Force Option Scan CH06

On Client Side:

2_4 Ghz Connected

Full Stat- Window:

LEDE   Overview   LuCI all