Xiaomi Wifi Router 3G - 18.06.x / Wifi issues 2.4GHz + 5GHz

@lipek let me know in case you get the drivers running, where do you get the sources from? As far as I remember the 5Ghz mtk drivers from nicefile did not work for 5Ghz, only 2.4Ghz was functional...

@thorsten97 I have 5Ghz closed driver running right now. The driver is mt7612-for-mt7621-linux-4.14.93.ko from http://nossiac.com/download/mtk-wifi-ko/ and I am running 4.14.109 kernel (openwrt from one of latest snapshots). if you want more details please visit https://github.com/Nossiac/mtk-openwrt-feeds/issues/104

In addition I have to admit that current open drivers stability (mt7603e and mt76x2e) is very good as you said (so trying to launch closed drivers is for curiosity only right now).

@lipek Thats very interesting, I might give it a shot, but so for I am very happy with the mt76 drivers :smiley:

@thorsten97 Just for reference: I was able to run 2,4GHz (mt7603) and 5GHz (mt7621) closed drivers at the same time. Bandwidth isn't better than using open drivers (210Mbps down).
Because of ease of configuration I am using open drivers right now. I am also going to check padavan to see if I am going to achieve better transfer speeds

1 Like

hey, what is your /etc/config/wireless?
is it like stock?
or do you have any tweaks?

@saxy if you are going to use closed drivers then /etc/config/wireless is irrelevant as those drivers use configs from /etc/wireless/ (for mt7603 the path is /etc/wireless/mt7603/mt7603.dat)
syntax of this config is also totally different - please refer to github issue

I was able to use only 2.4Ghz and not 5Ghz ( topic under mtk-openwrt-feeds issues)
Would love to see dmesg on 5Ghz for mt7612-for-mt7621-linux-4.14.93.ko. No one posted it yet ...
Now I've cooked and use custom mix close source and open source 5Ghz mt76 on 4.14.93 and recent mt76 .

@nicefile you read mine discussion with redhenjs. dmesg output is there (https://github.com/Nossiac/mtk-openwrt-feeds/issues/104#issuecomment-478757496)
please find fresh one here

[571427.554396] register rt2860
[571427.557405] bus=0x2, slot = 0x1, irq=0x17
[571427.569691] === pAd = c5d01000, size = 2108512 ===
[571427.580720] <-- RTMPAllocTxRxRingMemory, Status=0
[571427.586171] <-- RTMPAllocAdapterBlock, Status=0
[571427.590839] pAd->CSRBaseAddress =0xc5c00000, csr_addr=0xc5c00000!
[571427.597004] device_id =0x7662
[571427.600072] ==>rlt_wlan_chip_onoff(): OnOff:1, Reset= 1, pAd->WlanFunCtrl:0x0, Reg-WlanFunCtrl=0x208
[571427.610004] chip_id1=, chip_id2=, pAd->MACVersion=0x76623000
[571427.615893] chip_id1=0x0, chip_id2=0x0, pAd->MACVersion=0x76623000
[571427.622150] get_dev_name_prefix(): dev_idx = 1, dev_name_prefix=rai

I have problems with 2.4GHz not being recognized in the LuCI interface I can only config 5GHz. First, I thought that something went wrong with the installation and I revert back to stock firmware. But in stock firmware both 2.4 and 5GHz worked normal. Then I installed OpenWrt back and the same thing happened. I don't know what could cause this strange behavior.
Do you guys have any solution?

Anyone having issues with speed on the 5GHZ? I noticed that when I do a speedtest using the 5Ghz radio I can’t get downloads in excess of 100Mbps. This is the same for both 18.06.2 and the master branch. When I perform the exact same test using the same settings (down to the channel) on a Hootoo ND-001 (strong 1200 clone which uses the same wireless chipset and SoC) I get the full 200Mbps of my Internet. Additionally when I try this test over wired Ethernet on the Xiaomi it also gives me the full 200Mbps speed. For some reason I’m capped at 100Mbps though over wireless.

I’m trying to use the router as a dumb AP, but it’s useless if I can’t get the full speed. Does anyone else see this problem on theirs?

Do you have the same issue on 18.06.1? I am also seeing poor WiFi performance on 5ghz on 18.06.2 on my Dir-860L (same WiFi chip). Haven't tried master myself.

Well, Driver wifi on Openwrt Trunk May 2019 so terrible. Wifi signal weak, and perfomance is really low and unstable.
Best wifi dirver is Pandorabox Firmware( in only version 12.2018).

my post for WR1200JS and XIAOMI with a recent compilation

I have a big problem after compilation with recent source ( 5 Ghz very bad ) 4.14.115

I have reinstalled an old compilation and no this problem :
OpenWrt SNAPSHOT r8688-26d4cb2ca7 /LuCI Master (git-18.345.59980-6f0bed8)
Version du noyau : 4.14.87

I have also the same problem with a YouHua WR1200JS

WIth a good but old firmware

Same issue for me on a Dir-860L, and same issue on another Dir-860L in a different location with different devices. 18.06.1 was the latest release that had stable 5ghz WiFi for both of them. 18.06.2 is really bad with frequently locking up, big packet losses, and/or slow speeds. Haven't tried master yet myself.

how to download old source? I cant find it on github :frowning: tks

how to download old source? I cant find it on GitHub

i have uploaded my old source

tar cvf - folderToCompress | gzip > compressFileName
zcat compressFileName | tar xvf -

version is 4.14.102 and i have tested with a WR1200JS and XIAMI Router 3G no problem


1 Like

Can you share your build? tks you

tks. i will try to upgrade now :slight_smile:

I can't, sorry. It is too customized.
But you can install latest openwrt snapshot and just download and load closed drivers. (don't forget about config and microcode). Detail on github.