Xiaomi Wifi Router 3G - 18.06.x / Wifi issues 2.4GHz + 5GHz

@nicefile you read mine discussion with redhenjs. dmesg output is there (https://github.com/Nossiac/mtk-openwrt-feeds/issues/104#issuecomment-478757496)
please find fresh one here

[571427.554396] register rt2860
[571427.557405] bus=0x2, slot = 0x1, irq=0x17
[571427.569691] === pAd = c5d01000, size = 2108512 ===
[571427.580720] <-- RTMPAllocTxRxRingMemory, Status=0
[571427.586171] <-- RTMPAllocAdapterBlock, Status=0
[571427.590839] pAd->CSRBaseAddress =0xc5c00000, csr_addr=0xc5c00000!
[571427.597004] device_id =0x7662
[571427.600072] ==>rlt_wlan_chip_onoff(): OnOff:1, Reset= 1, pAd->WlanFunCtrl:0x0, Reg-WlanFunCtrl=0x208
[571427.610004] chip_id1=, chip_id2=, pAd->MACVersion=0x76623000
[571427.615893] chip_id1=0x0, chip_id2=0x0, pAd->MACVersion=0x76623000
[571427.622150] get_dev_name_prefix(): dev_idx = 1, dev_name_prefix=rai

I have problems with 2.4GHz not being recognized in the LuCI interface I can only config 5GHz. First, I thought that something went wrong with the installation and I revert back to stock firmware. But in stock firmware both 2.4 and 5GHz worked normal. Then I installed OpenWrt back and the same thing happened. I don't know what could cause this strange behavior.
Do you guys have any solution?

Anyone having issues with speed on the 5GHZ? I noticed that when I do a speedtest using the 5Ghz radio I can’t get downloads in excess of 100Mbps. This is the same for both 18.06.2 and the master branch. When I perform the exact same test using the same settings (down to the channel) on a Hootoo ND-001 (strong 1200 clone which uses the same wireless chipset and SoC) I get the full 200Mbps of my Internet. Additionally when I try this test over wired Ethernet on the Xiaomi it also gives me the full 200Mbps speed. For some reason I’m capped at 100Mbps though over wireless.

I’m trying to use the router as a dumb AP, but it’s useless if I can’t get the full speed. Does anyone else see this problem on theirs?

Do you have the same issue on 18.06.1? I am also seeing poor WiFi performance on 5ghz on 18.06.2 on my Dir-860L (same WiFi chip). Haven't tried master myself.

Well, Driver wifi on Openwrt Trunk May 2019 so terrible. Wifi signal weak, and perfomance is really low and unstable.
Best wifi dirver is Pandorabox Firmware( in only version 12.2018).

my post for WR1200JS and XIAOMI with a recent compilation

I have a big problem after compilation with recent source ( 5 Ghz very bad ) 4.14.115

I have reinstalled an old compilation and no this problem :
OpenWrt SNAPSHOT r8688-26d4cb2ca7 /LuCI Master (git-18.345.59980-6f0bed8)
Version du noyau : 4.14.87

I have also the same problem with a YouHua WR1200JS

WIth a good but old firmware

Same issue for me on a Dir-860L, and same issue on another Dir-860L in a different location with different devices. 18.06.1 was the latest release that had stable 5ghz WiFi for both of them. 18.06.2 is really bad with frequently locking up, big packet losses, and/or slow speeds. Haven't tried master yet myself.

how to download old source? I cant find it on github :frowning: tks

how to download old source? I cant find it on GitHub

i have uploaded my old source

tar cvf - folderToCompress | gzip > compressFileName
zcat compressFileName | tar xvf -

version is 4.14.102 and i have tested with a WR1200JS and XIAMI Router 3G no problem


1 Like

Can you share your build? tks you

tks. i will try to upgrade now :slight_smile:

I can't, sorry. It is too customized.
But you can install latest openwrt snapshot and just download and load closed drivers. (don't forget about config and microcode). Detail on github.

Hello! If not ask too much, could you explain the process? The part of loading the driver until I understood, but what about that microcode part? How do you configure it?

I'm thinking of getting one of these devices to use as a WAP. I need excellent 5GHz throughput. I can achieve 50MB/s read and write to my NAS using my laptop or phone with my R7000 with dd-wrt. Would I be likely to achieve these speeds on the Xiaomi if it was running a recent snapshot?

I have a Newifi3 D2 and I have posted this topic about it here WiFi Problems (MTK7621A D-Team Newifi D2)
it is a really good cheap router that I think would be capable of at least 50MB/s read and write as it has USB 3.0 and fast MiMo WiFi which does work quite well so far using Padavan
or 18.06.1 OpenWRT. It is quite cheap on Ebay https://www.ebay.com/itm/401401806725

1 Like

Thanks. What exactly are Padavan and Pandorabox? I imagine that the Newifi3 would perform very similarly to the Mi3G. For me to import them, the prices are similar and the Mi3G looks sexier, so I'll probably go with that. :wink:

Padavan as far as I can tell is a fork of the AsusWRT firmware.
Pandorabox I am not sure of but I think has some relation to OpenWRT
Looks are not important for me usually but if the price is the same the sexier option sounds better :slight_smile:
Pandorabox looks like it was/is the chinese fork of OpenWRT for international devices
the url Openwrt.org.cn/ is found in some places but no longer working.


@lipek can you post the link to the github details you are referring too please?

just scroll up few posts