Xiaomi Wifi Router 3G - 18.06.X / feedback and help

I would wait for 18.06.2. Current 18.06.1 still has bugs.

1 Like

Can you provide link to PandoraBox for Xiaomi Wifi Router 3G and instruction how to flash from OpenWrt to PandoraBox?

Make mistake and buy Xiaomi router 4. Playing around. Boot initramfs from 3G version with looks ok, eth ports mistmatched. Mtd write kernel1 and rootfs0 finished without errors, but trying boot after fails on checksum mismatch from uboot. setenv verify=no, has no effect. Should i replace uboot with custom uboot build ?
Can provide boot log from original firmware, or from initramfs 3G if interested and hardware photos.

Hi guys, I installed Openwrt version 18.06.1, I own an internet fiber of 200 / 30mb. Direct on the fiber converter, via cable, I get the maximum band of 200/30. But when passing through my Mi3G, I get at most 140/30, with no plugin installed (qos, sqm ... etc) either via cable when on 5ghz. Anyone with internet speed up, can you reach the maximum speed higher than that? Did you make any further adjustments to that?

I can easily reach 250/15 (my connection limits) on wired.. Can reach this with or without flow offloading. I cannot reach 250 with QOS on though, if i enable i get around 140mb so you probably have qos enabled. either

Disable QOS
Enable qos only on up direction (set down speed to 0 in qos)
Enable Software and Hardware flow offloading from firewall tab - is use this

How do I remove the breed bootloader from my mi router 3g? I'm using padavan, I want to use the stock bootloader again.

1 Like

A post was merged into an existing topic: Xiaomi Wifi Router 3G - 18.06.x / Wifi issues 2.4GHz + 5GHz

Any Idea on how I can flash breed boatload from within OpenWrt? If I try so the system tells me that the mtd Bootloader is locked ... ?!
Do I have to go back to stock first and than flash breed as bootloader?

Anny tips are highly appreciated!!!


A post was merged into an existing topic: Xiaomi Wifi Router 3G - 18.06.x / Wifi issues 2.4GHz + 5GHz

Hey guys, seems like external USB HDD support is broken, on both 18.06.01 and snapshots.

The HDD is recognized and listed on USB devices, however, I'm unable to mount. /dev/sda simply doesn't exist, no partitions are visible.

Seems to be related with UASP external enclosures, and kmod-usb-storage-uas is completely broken, only returns errors after install.

Is there any way to build the firmware correcting this? The russian firmware available over at 4pda seems to work just fine, and kmod-usb-storage-uas is not even installed...

1 Like

A post was merged into an existing topic: Xiaomi Wifi Router 3G - 18.06.x / Wifi issues 2.4GHz + 5GHz

i need help ok debricking my r3g, i'm following this steps:

To debrick

  1. Access serial console (use 3.3v adapter) and terminal emulator such as putty
  2. Flash the kernel0.bin file using option 2 flash using TFTP option in the U-Boot menu
  3. Connect usb stick press reset button and router will flash itself with stock firmware
  4. You can re-install openwrt as per original procedure

Need more info about step 2,got the TFTP server running on and u-boot founds It, but doesn't get kernel0.bin

stays like this .

If they can make this router work well with openwrt / LEDE, honestly, it will be the biggest feat ever seen. Ever wonder ? A Cpu 880 mhz (2 cpu / 2thread), 256 mb ram ddr3, 128mb flash, 2.4 / 5 wifi with good range. All major companies would go bankrupt, asus, netgear, etc., which make routers expensive and without decent SQM function.

This router work very well with openwrt

As well ? I see several people complaining about the wireless.

A post was merged into an existing topic: Xiaomi Wifi Router 3G - 18.06.x / Wifi issues 2.4GHz + 5GHz

Hey there,

I recently flashed the breed bootloader on my 3g to use it with the pandora box firmware. It works very well but I want to give the newest OpenWrt a try to see how it performs in comparison.
Unfortunately the openwrt-sysupgrade-bins can't be flashed directly from breed (breed always tells me that the image file is not compatible). So I am wondering how I can achieve to get openwrt on my box. Do I need to tweak the sysupgrade file, or deinstall breed first, or flash it differently??
Any help would be very appreciated.

Here is the mtd layout of m router:

[ root @ PandoraBox_46C1 : /root ]#cat /proc/mtd

dev: size erasesize name

mtd0: 00080000 00020000 "Bootloader"

mtd1: 00040000 00020000 "Config"

mtd2: 00040000 00020000 "Bdata"

mtd3: 00040000 00020000 "Factory"

mtd4: 00040000 00020000 "crash"

mtd5: 00040000 00020000 "crash_syslog"

mtd6: 00040000 00020000 "reserved0"

mtd7: 07e00000 00020000 "firmware"

mtd8: 00200000 00020000 "kernel"

mtd9: 07bc0000 00020000 "ubi"

mtd10: 00040000 00020000 "panic_oops"

mtd11: 00080000 00020000 "factory_bbt


if somebody has the same problem, It was something wrong with the tftp server, finally i didn't do It on Linux, used another pc with w10 and installed pumpkin to create the TFTP server and It worked like a charm.

now a week later, got openwrt installed and was working great until today, started to lose connection, wlan and eth was ok, but the pages wont load, got a txt with the log, for if It helps.

now, i don't eaven have access to Luci, not by SSH, but devices got internet, a real slow internet, strange, but i don't know where to start from, since i don't have access to router.

I have tried to flash openwrt 18.06.01 by ssh, but got bootloop immediately after rebooting.
How am I supposed to make it work?

While I don't have this device myself, quite a lot of OpenWrt users do - so I'd be surprised if this would be a common issue with the release images. This leaves two option to look at first, a bad flash (I'm not familiar about what the mir3g has to offer in this regard, at worst you might have to attach a serial console for debugging and/ or tftp based recovery) or a configuration creating havoc in 18.06, the later you can tackle by attempting a factory reset.