Xiaomi Wifi Router 3 - Brick

I flashed custom openwrt
after the reboot the routers goes in kernel panic and reboots in a loop
can't use the boatload menu it automatically goes to option 3
If any one have been gone through similar problem or have any good advice.
Please help.
Here is the log:

Ralink UBoot Version: 4.2.S.1
ASIC 7620_MP (Port5<->None)
DRAM_CONF_FROM: Auto-detection 
DRAM component: 1024 Mbits
DRAM bus: 16 bit
Total memory: 128 MBytes
Flash component: NAND Flash
Date:Apr 15 2016  Time:17:46:32
icache: sets:512, ways:4, linesz:32 ,total:65536
dcache: sets:256, ways:4, linesz:32 ,total:32768 

 ##### The CPU freq = 580 MHZ #### 
 estimate memory size =128 Mbytes

Please choose the operation: 
   1: Load system code to SDRAM via TFTP. 
   2: Load system code then write to Flash via TFTP. 
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   9: Load Boot Loader code then write to Flash via TFTP. 

3: System Boot system code via Flash.
Booting System 2
..ranand_erase_write: offs:40000, count:20000
## Booting image at bc600000 ...
   Image Name:   MIPS OpenWrt Linux-4.14.89
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1596367 Bytes =  1.5 MB
   Load Address: 80000000
   Entry Point:  80000000
.........................   Verifying Checksum ... OK
   Uncompressing Kernel Image ...

Reset button don't work too.

In serial console keep the key (number) for the desired boot mode pressed and power on the device.
For me it's only working from a cold boot and not from a warm boot (reset).

Tried many times, but no luck

Then try another serial adapter...
My device runs the same bootloader version.
I've tried also more than one serial adapter, lastly a arduino nano with pulled down reset worked fine.

Use bootmode 1 and load a initram openwrt image from tftp. From there you can flash easily a sysupgrade image / tar file.

i have used prolific and arduino uno and i was writing to serial via bash script but unfortunately it didn't help.

same quetion, is it solved?