Xiaomi Redmi Router AC2100 - Breed bootloader - Configure OpenWrt or at least back to stock

Hi there. I had tried to install OpenWrt with Breed (MIR3G version) and I did it. But then I decided to go back to stock because my Russian PPPoE connection stopped working after flashing OpenWrt. There was something like "Timeout waiting for PADO packets" in logs. The provider told me that there was a wrong credentials problem but it's impossible (Ctrl+C and Ctrl+V on right credentials give the same result). So I tried flashing the stock firmware...
I don't have any working stock or OpenWrt backups. No matter what I try to flash to any partition with any env variable set I only get bootloop right after auto-rebooting at most, if Breed agrees to flash the image. I looked up for the full dump and I've tried to flash it but it didn't work as well. It seems like there is no sense in uncovering and soldering something as far as Breed boots. Although I just have no idea what should I try next.
Thanks in advance.