Xiaomi r4a gigabit loosing internet connection

Installed 21.02.1 firmware. 5ghz radio operating as a client wwan on neighbors wifi, no wired isp connection, 2,4 ghz in master mode creates my home network. 52 days system worked flawlessly.
Now 1-2 times per day loosing internet connection until rebooted. System log with error erases after reboot, not all log, only that minutes where error occurred. (Is that normal?) When internet connection lost in luci i can see that router is connected to neighbors wifi, having ip and dns ip, after reboot, ip and dns does not change, but connection is online.
I am not advanced user, and i really dont understand what is written in system log.
Need suggestions what could be wrong, what i should check or try?

Today I manadged to get an system log when connection was lost:

Tue Feb  8 20:27:11 2022 kern.info kernel: [204302.227502] mt76x2e 0000:01:00.0: Firmware Version: 0.0.00
Tue Feb  8 20:27:11 2022 kern.info kernel: [204302.233096] mt76x2e 0000:01:00.0: Build: 1
Tue Feb  8 20:27:11 2022 kern.info kernel: [204302.237327] mt76x2e 0000:01:00.0: Build Time: 201507311614____
Tue Feb  8 20:27:11 2022 kern.info kernel: [204302.258331] mt76x2e 0000:01:00.0: Firmware running!
Tue Feb  8 20:27:11 2022 kern.info kernel: [204302.266469] ieee80211 phy1: Hardware restart was requested

Tue Feb  8 20:33:13 2022 daemon.notice wpa_supplicant[1519]: wlan1: WPA: Group rekeying completed with 74:85:2a:c9:2c:e0 [GTK=TKIP]

What does that mean? Do I have problems with hardware or software?

fwiw, if you are unable to get an answer, the only other option would be to replace the R4AG with an identical unit, to determine whether it is a hardware fault or software..

Other thoughts:

  • What happens to your R4AG when your neighbour reboots their wifi router? ie. does it automatically reconnect?
  • Can you use 2.4 GHz instead of 5 GHz client mode?

Unfortunately i don't have identical router to check.
When internet connection is lost in luci i can see that wifi is connected to neighbors router and has ip and dns. So I believe that router reconnects automatically.
And i can not use 2,4 ghz as a client because connection speed is too low. On 5 ghz i get 20-25 Mbits download and 5 Mbits upload.

Can you ask your neighbour to momentarily turn their router off and on, to see if it is related to the issue ?

ie. could their wifi going off and on be the 'trigger' event that is suddenly causing this issue for you?

fwiw, I think there are some custom builds for the R4ag in the thread within the Developers forum, to address known issues with the R4ag.

Tried to reboot the other router, reconnected automatically without problems.

Right now trying your suggestion to use 2,4ghz as a client. Strange is that it worked 52 days before, without problems or rebooting. And one more question: can i use 2,4ghz as a client and master simultaneously? To get internet from the other router and get access point with my name and password.

It should work in theory. As for practise.....

You may have to configure the wifi channel manually and to be the 'same' for both 'client' and 'Master' (access point) on your OpenWrt box. eg. channel 36. 'auto' setting may not work. Obviously, if your neighbour's wifi suddenly change channel number, you won't be able to reconnect.

Transpires it is a known problem.

The link below may not jump to correct post. See message 2125

Post dated 7 Feb 2022 suggests newer MT76 driver as of 31 Jan 2022 may resolve the problem.

May have to wait for next release of OpenWrt to get the newer driver if it is not already in use in daily snapshots.

hello, Is this fix applied to 21.02.2?

I could be mistaken, but latest MT76 patches are no later than December 2021


so the answer is probably No.

Ok, at first i was thinking of waiting of next release, but it would take a lot of time. How can i fix the problem? Can i install or update this mt76 driver? Or i should reinstall the whole system?

latest daily snapshot seems to have latest MT76 driver

Snapshots do not include LuCI.

Luci can be installed somehow via ssh?

Ok, Thank You bill888
Installed snapshot from your message.
Left the old configuration, ssh to the router, opkg update, opkg install luci.
Seems working right now, dont know is there any errors occurred because of configuration from previous release. :slight_smile:

I'm having a problem setting up my VLANS in 21.02.1 and 21.02.2 sometimes it can detect my dumb ap but sometimes it can by doing a restart but in the latest Snapshot I don't have any problems setting up my Vlans tagging or untagging

Could it be related to this patch?

1 Like

yeah I think that's the reason, I forgot to watch the logs though

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.