Xiaomi r3p - Cant Connect over Uart serial

My routes was bricked, so i tried to connect over serial using UART device, but it doesn't work. Only the RX led blinks (so, im trying to send some package but im not receiving anyone) The documentation is unclear anyone could help me please?

as mentioned before

need to connect

gnd ---> gnd
rx   ----> tx
tx   ----> rx

use some UART adapter, you have to have drivers for that device, install client.
on windows you can use putty

.\putty.exe -serial COM4 -sercfg "115200,8,n,1,"

COM4 change to real device

I saw some answer about it, i tried to do what that say but didn't worked.

so i decide to create a new post. Connecting via UART the device should be recognized as kind of store device to send the files to the device or i should transfer it over serial commands?

you have to connect UART adapter to system, setup all drivers, then connect uart wires to router.
execute connect command by serial client like screen putty minicom. (example for putty: .\putty.exe -serial COM4 -sercfg "115200,8,n,1,")
you will see black screen.

then powerup the router, you should see logs. wait about 2-5 sec till something like that:

 ##### The CPU freq = 880 MHZ ####
 estimate memory size =256 Mbytes

Please choose the operation:
   1: Load system code to SDRAM via TFTP.
   2: Load system code then write to Flash via TFTP.
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   7: Load Boot Loader code then write to Flash via Serial.
   9: Load Boot Loader code then write to Flash via TFTP. 

press #2, you have to be able to connect to your TFTP server and load kernel through network.

I found a link, but it is in Russian. Maybe it could help https://github.com/ITMO-lab/OpenWRT-Xiaomi-WiFi-R3P-FreeRADIUS

1 Like

This link helped alot, but i cannot connect to the router yet, The router light blinks each 10 seconds (yellow one). I think that my problem is more serious. ='(

Edit: If i plug the UART the lights doesn't turn on.

Connect only ground and the adapters RX line (data to the PC). You should see startup messages when power is first turned on. If you don't see anything change to the other data line on the router but again don't hook up the TX line while you're trying to identify which signal is which.

And never hook up the 3.3 or 5v power wire.

It Works man! My UART was broken, luckly i had another one to test.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.