Xiaomi MiWifi router unresponsive after applying previous config

I have a MiWifi router that I was using as an access point, running on an older version of OpenWrt, and decided to upgrade it to 18.06.2 last night. The upgrade worked, and I was able to log into the web interface with the default IP address. Rather than redoing the config from scratch, I re-applied the previously backed up config, but since then I have been unable to connect to it. The wireless radio does not appear to be running as I am not seeing the device on my wifi analyzer, and I cant ping it on any of the IP's that I suspect it should be on (, 11.5 (the original IP address) , 31.1). I tried holding the reset pin in while powering on the device, but I didn't have any luck there either. Would that reset the settings on the current OpenWRT or the Original firmware?

Any assistance would be appreciated (that is before I have to revert to the Factory firmware and start from scratch...)

Try IPv6 link-local address.

1 Like

When upgrading from old versions it is highly recommended not to keep the settings and rather than restoring them from backup, to manually edit the files one by one in order to avoid mistakes from changes in the configuration files.

That being said, your only options here are to restore factory defaults and start from scratch.
Since you didn't specify the exact model, read the device wiki and try the recovery methods. It would help to have a serial cable.

1 Like