Xiaomi Mi3 is in Yellow LED after installing OpenWrt

On Xiaomi MI3 I was trying to install openWRT first time by replacing Chinese firmware.

I followed the method mentioned in the below url.

However, till last, it went fine, once I hit reboot my router is going into orange color nothing is happening. I am not able to access the router anymore. Pls help. I really like MI3 and want to functional again.

Your urgent help/ expert advise to recover my router.
Pls note am not much linux expert but able to handle some stuff.

Which step in the description did you complete last ? Are you currently at 4.6 ?

4.6. Power off the router (disconnect the power cable) and then hold the reset button then power up the router, release the reset button after 2/3 seconds after powering up. You will see breath style yellow led will glow

Hi Stefan,
Thanks for replying, yes I was at step 4.6

I followed that step nothing happen. I followed the step 2-3 times but nothing happened. LED always glows yellow (not breathing).

Have you used a lan cable to connect to a lan port ? What happens ? Maybe you have to give the computer a fixed ip address 192.168.1.2.
Can you ping 192.168.1.1 ?
You are quite short with information. Does not work is not much. What did you try ?

Hi Stefan,
yes, I tried that process too. While installing OpenWRT I used lan cable everything went well till step 4.6. Once reboot router always glows yellow so tried hard reset multiple times. Over lan, updated laptop IP4 192.168.1.2 and tried to ping 192.168.1.1 nothing happened. Watched videos & read multiple blogs couldn't found the answer.

My bad

Actually, I skip the PandoraBox steps. Tried to install X-wrt & followed steps 4.12 thru 4.14.
Seems this went wrong, and the router not going into bootloader. With the yellow led light seems the router is not booting.

How do I recover now. By rolling back the original Xiaomi firmware and then install OpenWRT.

Pls help.

How do I revert back original firmware?

Google told me this:

You can try to use Google translate and try your best...

Also this seems a quite good description:

I do not understand what the current state of your router is, but probably on a mi 3 forum you will find more help, as your problems are not openwrt related...

Thanks for the links Stefan

Actually, my problem statement is
After OpenWrt installation step, when the router reboot no response from the router, led always constant yellow even after reset (holding pin pressed).

Tried below options

  1. Did 30-30-30 sec Power cycle
  2. By connecting ethernet cable gave static IP (192.168.1.1 or 192.168.31.1) & tried to ping, no response either of the ip's. Here am not getting return response.
  3. Installed SolarWinds TFTP or TFTPD64, even those were not responded to (as per methods available on the blogs)
  4. Hard reset as per Xiaomi manual (copying miwifi.bin on USB drive & press reset button)
  5. Am not getting connected to putty.
  6. the Only option left with failsafe or soldering - that am not sure & don't want to take a risk.

There is NO response from the router at all in all the above options. Router led always in YELLOW color.