Xiaomi mi wifi 3 support


#745

I use my builds at:https://openwrt.cmru.info/targets/ramips/mt7620/ (link dead since office PC got reformatted)

openwrt-ramips-mt7620-xiaomi_miwifi-r3-squashfs-sysupgrade.tar

when i try to use sysupgrade package in the luci page, the page responds with:
The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.


#746

ya, it won't work. if u add additional base pkg file / kmod packages, the sysupgrade compitatibility won't work, unfortunately u have to go back to stock dev firmware then do the flashing again. @bjdag1234


#747

been doing that. anyway.. forcing sysupgrade in command line in shell works. adding -F to sysupgrade lets me upgrade. I'll try adding more base packages. Thanks for your help.


#748

Hey bjdag1234.
Is your router still working? I temp bricked mine when I tried to go away from PandoraBox oder Padavan. I was only able to go back to PandoraBox or Padavan. I need a clear install of openwrt, using the wpad package, because I need a working 802.11r construct between two R3.

So am I right, that you were on PandoraBox and just flashed your nearly clean openwrt build through the shell and it didn't brick you device? So now you are using the PandoraBox Bootrom and your own OpenWrt version? Perhaps I will try that later too, if you are happy with your constellation.


#749

I always went back to stock developer firmware and flashed openwrt from there.
Also used @bakemono's instructions for reverting to stock since I have a RS232 serial adapter lying around.

Now i don't need to go back to stock when upgrading openwrt since its the same building, i just mtd write the kernel again and force sysupgrade whenever i reconfigure my image.

I'm not using PandoraBox anymore since the openwrt builds from @bakemono's repository works fine for me.


#750

i can't access 192.168.1.1 trough browser.

is there any process to gain access?

in putty which port and method should i use.
@bakemono


#751

u can try some serial recovery but if the bootloader is corrupted then it's gone @MHRaaj


#752

What is the default password for @Eddiecz firmware?
I reset to defaults my router and cannot login now.


#753

Good day. Is this commit: https://bitbucket.org/shibajee/openwrt/commits/6102e30aa85aaf76e0c5e4989a9d7021365d5fa7
enough to run on Router 3?


#754

yes, it is @r0ck3r


#755

Thank you!
Is there any chance to see this in upstream?


#756

probably not, they r not accepting new device on openwrt-18.06 branch and on master branch the driver will not work after next kernel mainline. @r0ck3r


#757

Do you recommend the Shibajee Commit of Openwrt or the PandoraBox? Which one do you use? I configurated a good working combination of two R3 in a two floor apartment. I used bjdag1234 for the first and Mydarkthawts version of openwrt for the second router and managed to configure a working 802.11r roaming between the 2.4ghz network and between the 5ghz network.

But anyway: The working distance is not that good. Several TP-Link router are working much better. Is it because of the driver in the OpenWrt builds, so it would be recommended to use PandoraBox and their secret version of the wifi drivers? Just wondering..


#758

Yes same question davidair !
It could be interesting to get wifi feedbacks about wifi performances and stability with openwrt and Pandorabox.

I successfully flash my mi wifi 3 with the openwrt firmware which was on bakemono repo here (not here anymore).

I would like to make an IPsec VPN tunnel, openWRT is able to make it but it require the package "strongswan" which is not compatible with this firmware (not compiled for the same version).

So my question is : is there a version of openwrt compiled with a stable main version to be able to use all the packages ?

bakemono : are you going to give new versions ?
Anyway hanks for the great work on it :slight_smile:


#759

I have not verified yet, however, it appears I am getting a high request rate for the following domains from PandoraBox:

qq.com
baidu.com
taobao.com

Can anyone else confirm this?


#760

It there a way to install relayd and luci-proto-relay on Pandorabox? I need to make client from my router but this package is not available on pandorabox website


#761

Install package with opkg command
for example: opkg install https://downloads.openwrt.org/releases/18.06.1/packages/.....where-to-compatible-ipk-file...../relayd.ipk


#762

hello, i'd like to know what kind of performances you get out of your lede/openwrt images on 2.4GHz wifi (couldn't test 5GHz or AC).

i had an old miwifi 3 box sitting here and decided to use it, so i immediately flashed some openwrt image, i chose the one listed on 4pda by NitroOxid "nitrooxid-1.0.8-ramips-mt7620nand-xiaomi_miwifi-r3-squashfs".

Already done some "mini" flashes so no big surprises with the dev/STOK/ssh flash process, and so got my openwrt running apparently fine.

Then i tested wifi performance and was somehow surprised by how slow it was : 14Mbps down / 8 Mbps up (using ookla on my gigabit fibre link and 96/92Mbps from the ethernet ports)..

after trying various things (removing vlans, bridging all ports and disabling firewall stuff) that didn't improve performance much, so i decided to rollback to the latest Xiaomi stock firmware (chinese version).

After setting it up as an access point, i tested 2.4G wifi with the same devices and got around 45/45Mbps up/down speeds.. which is more like what i was expecting.

I haven't got much time to spend testing all various openwrt images, so hopefully you can tell me if your image performs better.. (please try include your image download/info links)

I would also be interested in getting some performance feedback on the 3C model running openwrt (officially supported i believe), as i'll be getting some of those very soon.

thx


#763

need help here i flasherd my xiaomi with there at web interface trying toget hold of natcap
natcap-4.0-b201810082342-ramips-mt7620-xiaomi_miwifi-r3-squashfs-sysupgrade.tar

but my router keeps on rebooting...reset not working flashed trhu reset still not working plss helpmeeeeeeee


#764

help me please

anyone