Xiaomi mi wifi 3 support


#705

care to share the script ?


#706

Was this just an example or actual repos that can be used with the mi3? I get the following error when updating opkg:

Collected errors:
 * opkg_conf_parse_file: /etc/opkg/distfeeds.conf:9: Ignoring invalid line: `src-git packages https://git.openwrt.org/feed/packages.git;openwrt-18.06'
 * opkg_conf_parse_file: /etc/opkg/distfeeds.conf:10: Ignoring invalid line: `src-git luci https://git.openwrt.org/project/luci.git;openwrt-18.06'
 * opkg_conf_parse_file: /etc/opkg/distfeeds.conf:11: Ignoring invalid line: `src-git routing https://git.openwrt.org/feed/routing.git;openwrt-18.06'
 * opkg_conf_parse_file: /etc/opkg/distfeeds.conf:12: Ignoring invalid line: `src-git telephony https://git.openwrt.org/feed/telephony.git;openwrt-18.06'

I am specifically looking for the zerotier package.


#707

I bricked my router by going from Padavan to PandoraBox over stock firmware to the version of MyDarkThawts. What happend?
I wanted to try PandoraBox but the ethernet ports didn't work (rebooting ethernet interface all the time). I reverted to the stock firmware liked discribed and then I followed MyDarkThawts description to use his openwrt firmware. They are the following:

root@XiaoQiang:/extdisks/sda1# cp kernel1.bin /tmp
root@XiaoQiang:/extdisks/sda1# cp rootfs0.bin /tmp
root@XiaoQiang:/extdisks/sda1# cd /tmp
root@XiaoQiang:/tmp# nvram set flag_last_success=1
root@XiaoQiang:/tmp# nvram set boot_wait=on
root@XiaoQiang:/tmp# nvram set uart_en=1
root@XiaoQiang:/tmp# nvram commit
root@XiaoQiang:/tmp# mtd write kernel1.bin kernel1
Unlocking kernel1 ...

Writing from kernel1.bin to kernel1 ...     
root@XiaoQiang:/tmp# mtd write rootfs0.bin rootfs0
Unlocking rootfs0 ...

Writing from rootfs0.bin to rootfs0 ...     
root@XiaoQiang:/tmp# reboot

After the reboot, the router is stuck in a bootloop (orange LED on while booting, then shortly off, then on again while rebooting). Does anyone have a clue what I did wrong? Was it necessary to remove/empty the kernel0?

Is it bricked for ever or can I get a CP2102 usb to serial converter and bring it back to life? The recovery mode is not starting so nothing happens when booting the router with pressed RESET button and having a USB miwifi file plugged in. :frowning:


#708

it's 100% recoverable, just get a cp2102/pl2303 usb to ttl and do the tftp recovery..there r post about instruction above @davidair


#709

sure...use this instead of my script. https://gist.github.com/Cybso/bf9b69c6a638ffd68281 it works good


#710

I managed to recover the device. Uploaded netcap kernel1 by @ptpt52 through option 2 in the boot menu. Then the router started again, but it was mixed with the firmware from @mydarkthawts.
There was no possibility to upload a sysupgrade or any other firmware, so the only way was to upload the PandoraBox Bootloader again through option 9 in the original bootloader. Afterwards I was able to go back to stock BUT (!) even from the stock firmware it is not possible to install ptpt's firmware or mydarkthats firmware. Always bootloop. I don't know what PandaoraBox is doing but afterwards I can't install a clean openwrt/lede version. Installing Padavan from Stock firmware worked out but even after going back to stock from padavan it was not possible to install openwrt again.


#711

ok, I'm giving u my vanilla compiled openwrt files, try this https://mega.nz/#F!WY0FiTIS!Cl_Dzm4yhzrQZFazYG3i8Q @davidair


#712

I have a mi router 3 that seems dead. Only LAN leds turns on when powered on and then every led is off. Console seem not writing anything...

Any idea?


#713

Does it have SQM/cake?


#714

where can I check if there are firmware updates?


#715

look at my original post, the first address..it looks like we have a update https://downloads.pangubox.com/pandorabox/18.08/targets/ralink/mt7620/ @notthesun


#716

looks good. can i upload it through gui?


#717

yap, it's sysupgrade compatible, u can upgrade it through luci @notthesun


#718

sorry if i m posting this in a wrong thread.

but i m not being able to activate SSH on this router

whenever i tried to visit https://d.miwifi.com/rom/ssh

after login to my account it says image

what should i do? i can't access this site. i have waited a week or so but every time the same thing.

please let me know is there any alternative way. and i m not good at hardware. so i can't manually start serial port.


#719

to get the ssh access u have to flash the developer firmware, dl link and ssh activation is explained here https://wiki.openwrt.org/toh/xiaomi/mir3 on ** To get SSH/dropbear access** section @MHRaaj


#720

You must add https:// manually, the website often switch from HTTPS to HTTP, which caused the error.

Like this: https://d.miwifi.com/rom/ssh


#721

Hello, I have a Xiaomi Mi WiFi 3 router and I'm really inclined into switching to a pure OpenWRT firmware. From what I read in several places, the procedure is enabling SSH access (either through Mi Account or by downgrading the stock firmware to use the code injection method) then flashing the kernel and filesystem of the newer firmware to the respective partitions, finishing with the perform of a sysupgrade of the new firmware. But I have some questions...

  1. What exactly is the difference between PandoraBox and vanilla OpenWRT? What is the language of the PandoraBox build, english or chinese?

  2. Has anyone tried the vanilla OpenWRT build that @bakemono posted above? I would like to stick to it as I never really tried PandoraBox builds before.

  3. Some places mention a modified U-Boot bootloader. Do I really need to install it or can I stick to the stock bootloader? I would like to stick to the stock U-Boot so I can recover the stock firmware through an USB Flash Drive if something goes wrong...


#722

Hi guys,

I have effectively bricked my r3 - flashed it with r3g firmware and it doesn't boot anymore; bootloader loades kernel, jumps to address, prints "Starting kernel ..." and that.s all.

Before flashing I've enabled serial console, but didn't enabled wait_boot -

instructions in the wiki for r3 to enable serial console only mention
"nvram set uart_en=1
nvram commit"

but as far as I've read these commands should be also executed:

"nvram set flag_last_success=1
nvram set boot_wait=on"

Right now I have several questions:

  1. is it possible to unbrick the device causing the bootloader to wait anyway or at least take external command before choosing booting from NAND?
  2. if it will be not possible to force mi r3 to enter tftp boot does anybody here have dump of SPI flash for mi wifi r3 mini to be able to boot the router from SPI chip? I can only find openwrt sysupgrade firmware files for mi wifi mini and it is not sufficient - what is required to do the SPI boot is a real dump of 128mbit spi chip and I cannot find it.
  3. In the PDF for mt7620 I find description of chip_mode mode 8 - USB mode ( boot from ROM). Somebody tried to find out what does it mean? Does the chip mode 8 trigger booting from external storage ? If it would be possible to boot directly from USB using mt7620 rom bootloader in a known way it could save all the bricked mi r3 routers doesn't matter what would be screwed - pins SPI_MOSI, SPI_CLK, TXD2 and GPIO0 are AFAIK all accessible and with a bit of soldering the unbricking / installing openwrt would be pretty easy for anybody with a soldering station.

#723

IIRC, there's mentions above that people at 4PDA uses SPI flash to unbrick mi wifi r3, you need to remove some resistor to enable booting from the SPI flash.


#724

yes, I've read that it is possible to boot from SPI flash, therefore I'm looking for a memory dump of such SPI flash chip. Without dump it can be a bit tedious - prepare the image with docs in hand and starting with u-boot compile for the hardware, maybe add some magic numbers in particular locations - I don't know how the mtd is prepared for mt7620 linux and maybe I don't need to learn it - etc...