Xiaomi mi wifi 3 support


#644

pastebin link ? https://pastebin.com/

Also, how did you get the logs? I wish to see them from my device


#645

You can paste bin it or blockquote it.


#646

I ment https://www.pastefs.com/


#647

ok, linked here: Mi3-kernel-system-logs


#648

alright. I'm about to start tutoring some students so I will look at that link when i'm done. I appreciate it.


#649

logs here:
syslogs


#650

Interesting. So far I've read that it mounted root as read only. Still going through it before I start my class.


#651

I did change this line from your instructions, don't know if it makes a difference:
http://192.168.31.1/cgi-bin/luci/;stok=/api/xqsystem/set_name_password?oldPwd=OLD_PASSWORD&newPwd=NEW_PASSWORD
so i set OLD_PASSWORD to actual my actual 'old password' (e.g. xzyk) and changed NEW_PASSWORD to actual 'new password' (e.g. kyzk).
Perhaps pabloveliz can confirm if he did the same.


#652

When I do it, I just use "password" for both. Didn't seen to bother anything as far as I'm concerned.


#653

yes, I did use a different password on new password... but that is for the miwifi image (xiaomi developer) not for the actual openwrt.
And also use the same old and new password in previous build without any issue


#654

For some reason a few things failed to load and the root was mounted as read only so nothing can be saved properly or applied... It's looking like you may be stuck so far unless you can use the solder pins or gain ssh to mount root as rw...

I haven't had to use the alternative measures to fix a router yet.. I'm still working on reproducing the issue on my end.

Does anyone know the quality of the nand? How many flashes can it handle before it degrades? I have a sticky note on all my routers I tally for each flash lol


#655

This from https://openwrt.org/toh/xiaomi/mir3 may be worth a try:

Recovering from Softbrick
If your MIR3 is soft bricked, but you have write access to the serial console, you may be able to recover.

Save kernel0.bin from here to a TFTP server
Place the 2.11.20 firmware .bin on a FAT32 formatted flash drive and connect it to the router
Boot the router and select option 1 “Load system code to SDRAM via TFTP.”
Set an IP for the router and enter the IP of the TFTP server
Enter the name of the file (kernel0.bin)
Wait for it to reboot
It will print something like the following - press and hold reset unitl the LED flashes orange and it will revert back to stock:
[ 4.550000] Check for USB recovery...
[ 4.580000] Both systems are corrupted... Entering recovery mode
starting pid 81, tty '': '/etc/rcS'
Press reset button to enter USB recovery

I may also try Padavan through Prometheus if all else fails.


#656

Hopefully this works to fix the problems.

I've pulled the recent build and am building a plain flat out image with the basic system for those to flash and do their own thing. I'll of course flash it multiple ways for testing before uploading.


#657

same here, my log is the same, only difference is the usb disk size, and that my eth0 cable was disconnected the moment of the boot... other than that, is the same log (kernel, system)
And also have
VFS: Mounted root (squashfs filesystem) readonly on device 254:0.


#658

I have no serial console cable :frowning_face:

is there a way to copy a script into the usb disk, and execute that script from lucy? that way I can "fw_setenv flag_last_success 0" and install the xiaomi developer image.

PD: I exceeded the 19 daily messages limit imposed by the forum


#659

I didn't know they had a message limit :open_mouth:

Okay.. So, I just tested my newly freshly compiled from a fresh git clone firmware on 5 routers. I did various tests from using my original firmware release, then upgrading with saved files. It worked fine.
I did an upgrade from my old firmware to this new one and did not save settings. It worked.
I did a flash back to stock then redid a flash using the other firmware bin's. It worked fine.

All of them worked EXACTLY as they should have except for 1 router that bricked. During an install from stock. No idea why but I'll have to do the serial route and see if that works out.

I'm hoping the upload was not corrupted. I downloaded the uploaded file to google drive and tested it as well and can not repeat the issues so I doubt they are corrupted.

I'm sorry guys. I'm trying between my tutor lessons I offer here.

I'll upload the new firmware to the same link just in case anyone wants to try.


#660

I've got the serial interface up and running but the tftp recovery does not work because when you select option 1 “Load system code to SDRAM via TFTP.” there is not target ip because it is not fully booted yet. I tried playing around with set_env setting and printenv but although they seem to work i cannot get them to stick. If i can set the ipaddr of the router from the serial console we may be able to bring it back.
Any suggestion are welcome.


#661

put some more detail for you here: boot-seq


#662

Thank you for this.
This is troubling as I usually recommend

mount -o remount,rw /

but that requires root... I'm not sure if that will work...

I'm not so sure on the tftp part as I will be attempting this route soon for 1 of my newly bricked routers. Sorry I am of no help currently.
I'm working on this, though.


#663

It's really trial and error, but I would try to go back to stock/developer firmware if it's possible and then try to get access through the Prometheus/Padavan installation process.. Perhaps in the installation workspace you can find a solution.

I reverted from Padavan to Stock/Developer to the first version mydarkthawts uploaded. Everything worked out fine but the start script settings weren't right/changed at all. Every package was loaded so the load was like 8 and you couldn't do anything! I was able to connect to luci but it was crazy slow. In luci I was able to deactivate all the additional plugins and software things and now it works just fine. So perhaps you can have a look at the startup scripts what's happening there?! Ah and another thing: the feed of the opkg software was not right comparing to the one mydarkthawts uploaded some posts ahead. I changed it to the one from his screenshot.

Just the 2.4Ghz quality is quite bad... @mydarkthawts do you know anything about it? is it because of the drivers? 5ghz quality is very good.