Xiaomi mi wifi 3 support


#624

Here is what my sources list looks like for a reference point. I added red arrows to the mentioned spots.
Screenshot%20at%202018-06-25%2015-30-33


#625

Hi. The bottleneck is USB 2.0. This means at least 30MB/s as we know it from an old PC. Officialy USB 2.0 is 480 MBit/s. So 1,2MB/s is far away...

I mean with the limited 100Mbit port it should be at least around 10 MB/s.


#626

BAD News...
I did a full reinstall. I went back to developer stock, then from miwifi.bin to this last image, no problem there.
But it doesn't save the root password, and doesn't enable ssh... so, I'm not able to login to go back to stock or reinstall old image.

What can I do?

In some loading screen I was able to see "Unknow error, password not changed"

combined


#627

tried to flash old image through web interface... "Flash new firmware image"

Then choose "openwrt-ramips-mt7620nand-xiaomi_miwifi-r3-squashfs-sysupgrade.tar" from previous build

But, no use, I got message "The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform."

41


#628

Correct. I get 10Gbit speeds here so it's fairly easy to notice the slow speeds where I'm at lol.


#629

Interesting. I'm not sure what could have gone wrong as I upgraded from the previous build to the new build by just using the .sysupgrade.tar and it flashed over successfully.
Also was able to do it again without saving settings and that worked. Both times I had ssh access and root password.

Is the kernel log or system log showing anything useful on your end?


#630

I just finished flashing from stock as well to test your issue and I was not able to reproduce the problem. Is there anything else you may have forgotten to tell me?


#631

I followed instructions according to INSTRUCTIONS.txt and was able to reach "reboot" command, just like last time.
and when trying to setup root password had the problem... now that I see more, seems like it doesn't have enough space... is that possible?

combined


#632

I even check the commands that I sent, and they're correct...

24


#633

From your snapshot, you have plenty of space available. Swap is another story and nothing to worry about at the moment.

I'm not sure what went wrong. Can you go back to stock at all and try the dropbear access again?


#634

that the problem, I tried and not be able to do it. Because I'm not abke to ssh, so I'm not able to fw_setenv flag_last_success 0
or there is another way?


#635

oh boy... are you able to install another ssh server from the software packages and try that?


#636

I got exactly the same problem as pabloveliz. Followed all instructions in instructions.txt got the luci up and running but no ssh. Also it doesn't appear to be saving anything. For example, if i make a change and then select 'save & apply' I get the pop up that config is being saved but then still have the red 'unsaved changes X' in the top right corner.
Telnet doesn't work either, so pretty much stuck. I'll wait to see if someone else can come up with a workaround otherwise look on the openwrt boards for recovery.


#637

What the heck man. I upgraded to the same one and have none of these issues.

Let me flash a few more boards. I'm trying to replicate the issue but can't.

I'm going to pull the files until I can figure it out, I'll put the old ones back up.


#638

let me know if you need any logs. I can talk via luci but that's about it. I tried sysupgrade also and got the same as pabloveliz, i.e.it did not work. Even synching time to browser appears to work but the time stays the same, feels like either commit is not working or something is ro that should be wr; maybe !


#639

All the logs in the world will help me right now, not sure if it will point to the issue but any info will help at the moment.

Right now I'm just going to put the last working ones back in the folder..

I'm going to do a fresh git clone and start from scratch. Then test that. Hopefully something works.
I'd hate for you guys to have to use the solder points. :frowning:


#640

ok, let me grab them from a reboot until luci is up, then i will try to change and save password and after that grab the kernel and syslogs and send them on. hang on..


#641

VERY much appreciated. Thank you.


#642

how do you get the logs?

I was suspecting from disk space because in a screenshot from previous build it showed space in green, and from current build shows red and zero

29


#643

having a hell of a time to upload a text file, system won't allow it. Any idea how to upload a text file without doing an entire cut and paste ?
error-upload