Xiaomi mi wifi 3 support


#602

Hey, thanks for sharing your build above. Does ist fit for the MiRouter 3? There are different versions and I don't wanna mess it up. I read the nice packages. Is it possible to use it as an NFS-server too? I guess it has to be recompiled with an NFS-kernel unfortunately... Do you think you could add this still?

Thanks a lot for your work!


#603

after ive flashed ledexxxx update .,.....whats the admin password


#604

image
after upgrading to ledexxxxsysupgrade...password protected and i donw know the password can u share the password sir?


#607

Weird. I'm running the same and my load is still running the same. No stutter, no lag. I am going to make some changes to page load wait times and timeout settings so page turns are faster.

I'm not sure why people are experiencing high loads. Check your startup tab. Are ALL the services running? They shouldn't be. I made it to where only essentials were running and the rest disabled until you needed them. Maybe I need to tweak it a little more.


#608

I only have the Xiaomi Mi Wifi Router 3 and only compile for that currently. I couldn't speak on other models.
Sorry about that.


#609

It should not be slower. When I tried Padavan it was around the same response time as my build. I'll have to reflash one of my routers and see what is happening. All my others are running the exact same and working fine.
Sorry it is taking me time to get back to you guys, been busy here lately with clients and the farm.


#610

pls can someone help me..after upgrading with the firmware @Eddiecz it was password protected


#611

user pass for ssh why can i use wscp


#612

Try: https://openwrt.org/docs/guide-user/troubleshooting/root_password_reset


#613

Last I checked, if you read through this entire thread, you would have seen someone having the same issue but immediately resolved it by reading Eddie's site..
I'm pretty sure Eddie supplies the password and username and such for it. Another user was able to do the same. I don't use his firmware so I can't be too sure. Haven't even gone to his site.


#614

Hi all,
Please help me with this error. I tried to sysupgrade -F firmware and I got this /lib/upgrade/platform.sh line 333: syntax error: unexpected redirection (expecting ")") now I can't upgrade to any new firmware.May be someone can send me the platform.sh file so I can try.

for some reasons I cant go back to stock neither despite trying all methods I can google. it seems to me the uboot is modified by using Eddie'r firmware in the past. Please help!


#615

I had this problem.. reaching a load average above 6.
It was so irresponsive that I had to access through ssh, run the top command, sort by CPU usage and there I saw that culprit, was: tor and gnunet-service-
I disabled tor from the console and killed gnunet.


#616

Thank you. Tor and gnunet should be auto disabled. At least it was when I flashed this firmware over. Interesting. Let me fiddle with it a bit more and recompile.

How is your load average now?


#617

I am recompiling without tor and gnunet to make this easier for others. Thank you @Vermillion for the feedback.


#618

Alright!
I've recompiled it without Tor and Gnunet, leaving it to those to manually download it if needed(I use both).

The files can be found here(same link and location as before for those that already bookmarked it): https://drive.google.com/drive/folders/1hrdSu96NzGc5Gz1_gN9Xjbr-9fnrfgaI?usp=sharing

Please give me your feedback on it.

I've made no other modifications other than removing Tor and Gnunet, I also updated some of the feeds and sources quickly to make it as recent as possible to make a quick fix to the issues. README.txt has been updated to reflect the removed packages.

I'll work on making the services not auto enable in the build process but include the tools later when I have more time to test the images.

Thanks again, everyone!


#619

Hi @mydarkthawts , thanks for your hard work and stunning description to get lede on the device without opening and soldering pins on the board! It worked for me and I also used already a tunnel to mullvad with wireguard on the weekend. Unfortunately the device was very slow within the tests and the wifi broke often. So I don't know exaktly if it has something with the gnu-net or tor plugin to do... can we easily flash your new image over and can we still contine to keep this possibilities for gnu-net, tor and my NFS-Server request for the image?

Update: I also tested Samba-Server and added a new user first. With an USB3.0-Stick with Fat32 formated it just reached around 1,2 Megabyte/second via Ethernet-Cable. So I don't know what's using the brakes on this devices...

But so far it worked pretty well! Just a few sources are not working, but maybe I can update the repositories with an updated list.

Thanks really a lot for your big support to this project!


#620

Hey! Thanks so much for your response and information. It helps me greatly. You are welcome, I couldn't have done it without the help of others on this forum, that howto really does go a long ways.

Yes, the new image can be easily updated with the sysupgrade package on my link and you can do it from the backup/restore section on the LEDE firmware. It's fast and simple =D

I've removed the Tor and Gnunet because a user found that it was a culprit impacting performance so hopefully that improves your performance. The upgrade image works as I've used it and it DOES flash over the update, you can also choose to keep and save settings and it also carries over.

For the break in Wifi, I have YET to experience that issue on ANY of my routers so I can't pin point the issues on it unless someone else can and I'll work on a fix with their info.

The sources list is an easy fix, I'll have to add that to the readme, I keep forgetting to do that.

What you do, is go to the configuration tab in the software area, navigate to the Distribution feeds section, then find the ptpt52 line, erase it completely.
Next, find the one that says mt7620nand and remove "nand" from that line so it only says mt7620. It should be the first line but sometimes can be the second. Click submit and then you will not have that sources issue anymore.
I believe you will have to redo that for an upgrade but that's nothing you can't handle =D


#621

Wow.. thanks, will try that tonight... also, where can I donwload the relayd package for this image ?


#622

perhaps the brakes are the USB 2.0 port that have the MiRouter-3 , the one that have USB3 is MiRouter-3G


#623

Yes. It's a slow port, and the fact that the ethernet bus is only 100Mbps further limits the speeds on the router for network side actions.. The more devices you have using a hardwire ethernet, the more congested it gets. Wireless on the other hand is excellent.

Your network speed bottleneck will always be the ethernet ports and for sharing the usb port is maxed out at usb 2.0 speeds.

I searched for relayd and this is what shows up after you update the package lists and make the changes to the configuration section I mentioned previously.
Screenshot%20at%202018-06-25%2015-25-53