Xiaomi mi wifi 3 support

@dgiese @dissent1 I have finally caught some time to try and make LEDE work.
4.4 kernel loads via TFT without issues and I have configured switch this time properly,unfortunately now my partition table is changed so It would be helpfull to return to stock and then test if images work.

Thankfully I had all partition dumps so I flashed kernel0 back to restore using USB

Unfortunately still the same issue.
But this time it just bootloops,I cant even select option to load from tftp.

I have now really exhausted my knowledge.
It could easily be NAND driver issue since I triple checked my partition layout which shows up completely fine in initframs image.
Also sysupgrade still outputs:

Invalid image type.
Image check 'platform_check_image' failed.

can you give the url to your current firmware? will try it out tomorrow...

btw: flashing back the orignal kernel sets at some point the uart_en=0 flag, if i remember correctly

Sure, here it is:

You have kernel 4.4 and 4.9 builds from today.
Yes I know about uart_en=0 flag, thats why after immediatelly after stock was booted I set it to 1 and saved it.
Its not like I cant write to console but instead it auto reboots and goes straight to loading from flash instead of having 5 seconds to chose method.

You tried to keep the corresponding number pressed while boot? Or press "c" or "s" while boot (unplug router, replug it again)

Yes,tried holding number.
C or S also makes no difference, it auto jumps to load from flash.
I cant believe that it is stuck in this loop, any idea to recover?

@dgiese Still giving me the same error.
I really dont understand why is boot menu selection time of 5 secunds just skipped altough boot menu is displayed.
No buttons pressed really help.
I am out of ideas to recover

My R3 is still bricked so I have no way of testing, but I added @dissent1 uboot mod to enable preserving kernel0 for future recovery.
If someone wants to test here it is:
Instructions are here:

Can somebody who has stock firmware installed check if kmod-softdog is used in stock?


I'd like to help getting lede on this router.
I've gotten ssh on it, it's running the stock firmware.

I will be able to check for the kmod-softdog kernel module in 16 hours. - Can I check it simply using lsmod?

I dont know since mine is currently bricked.

there you go lsmod from mine running stock development version:

root@XiaoQiang:~# version
Uboot Version: 4.2.S.1
Linux Kernel Version: 2.6.36ralink
XiaoQiang APP Version: '2.13.75'

root@XiaoQiang:~# lsmod
Module                  Size  Used by    Tainted: P
xqfastpath             24842  2
http_url               13533  0
http_content_type_mark     5456  0
http_identify           3855  0
nf_tcp_proxy           29176  3 http_url,http_content_type_mark,http_identify
nf_conn_ext_http        1982  3 http_url,http_identify,nf_tcp_proxy
hw_nat                 28275  0
mt76x2e              1388110  1
mt7620               1673718  1
dstack                   944  0
ip_account             16058  0
xt_set                  4688  2
ip_set_list_set         7472  0
ip_set_hash_netport    22048  0
ip_set_hash_netiface    22608  0
ip_set_hash_net        20384  1
ip_set_hash_ipportnet    23456  0
ip_set_hash_ipportip    18368  0
ip_set_bitmap_port      6128  0
ip_set_bitmap_ipmac     6736  0
ip_set_bitmap_ip        6896  0
ip_set_hash_ipport     17504  0
ip_set_hash_ip         16656  0
ip_set                 22372 12 xt_set,ip_set_list_set,ip_set_hash_netport,ip_set_hash_netiface,ip_set_hash_net,ip_set_hash_ipportnet,ip_set_hash_ipportip,ip_set_bitmap_port,ip_set_bitmap_ipmac,ip_set_bitmap_ip,ip_set_hash_ipport,ip_set_hash_ip
xt_IP4MARK               560  2
xt_flowMARK            10693  1
xt_cgroup_MARK           576  1
nf_nat_irc               912  0
nf_conntrack_irc        2672  1 nf_nat_irc
compat_xtables          1980  0
ipt_NETMAP               688  0
ipt_REDIRECT             672  1
xt_conntrack            1824 12
xt_NOTRACK               624  0
iptable_raw              656  1
libphy                 15225  0
ipt_REJECT              1808  2
xt_mac                   608  0
xt_limit                1120  0
iptable_mangle           960  1
iptable_filter           736  1
ip_gre                 12768  0
act_connmark            1312  0
sch_teql                4816  0
sch_red                 3760  0
sch_gred                6608  0
sch_dsmark              3776  0
em_nbyte                 688  0
em_meta                 4624  0
em_cmp                   768  0
cls_basic               3920  0
sch_hfsc               14832  0
sch_fq_codel            6544  0
em_u32                   560  0
cls_tcindex             4272  0
cls_route               5808  0
cls_flow                7360  0
act_mirred              3248  0
tun                    14255  0
ppp_async               7808  0
tfat                  187179  0
tntfs                 470779  0
crc_itu_t               1003  0
crc_ccitt               1003  1 ppp_async
aes_generic            29753  0

It looks like it has hw watchdog.
Thanks, all my work is suspended due to not being able to unbrick my R3

so as i was searching to try out pandorabox due to slow 2.4ghz speeds on openwrt and lede with my xiaomi mi wifi mini

i stumbled on a device firmware recently integrated named xiaomi-r3.

since i own both mini and mi3 i thought maybe some development has taken place.
any thoughts?
here are the links


Pandora box for R3 exists for a while now.
The issue is that they are no sources and used drivers are Mediatek proprietary closed source drivers which LEDE cannot distribute.

yes im aware of that, i didnt know until now it has support of pandorabox.
so that means the r3 can run pandorabox?

how is the flashing process? can anyone shed some light since i want to avoid bricking.

i remember back when i tried pandorabox on my mini that is and switched to lede i did the upgrade through the webui for convenience and it worked.

is this reccomended?

furthermore im currently running padavan on my R3 and the partition layout therefore is different
does this mean if i wanted to try out pandorabox on the R3 i must revert to stock unlock SSH again from start and then flash it through SSH?

i have quite some experience but by no means as advanced as you guys so i could use this information to prevent bricking if anyone could be so kind

i used the recovery option on a virtual machine with prometheus followed by inserting a USB stick and holding reset.
my goal was to go back to stock and apparently i read this method worked on forums.

however now my r3 has a yellow light for a couple of seconds when booting and a red blinking led after.

it isnt recognized anymore nor does boot
update: tried another fw version and it worked

i cant make sense out of the chinese tutorial:

pb-boot-spi-recovery-xiaomi3.bin ΣΓΣΪΠ΅ΓΧΒ·ΣΙΖχ3µΔSPIΖτ¶―,ΣΓΣΪΠήΈ΄NANDΠήΈ΄

pb-boot-nand-xiaomi-r3.bin ΣΓΣΪΠ΅ΓΧΒ·ΣΙΖχ3µΔpb-boot,nandΖτ¶―.


If you stumble upon sources of Padavan for R3 or PandoraBox please contact me.
Maybe there is something usefull

i hesitate i will, especially since i dont speak chinese
does anyone know how to flash pandorabox on the r3 though?
what i got out of the tutorial using google translations :slight_smile:
In fact, really simple, router R3 brush version of the firmware and then open the SSH, use WinSCP upload PB BOOT, putty go brush PB BOOT. My router last brush the old hair firmware. Padavan Brush PB BOOT Command: mtd_write write /tmp/boot.bin Bootloader
in this file there is a boot file for spi and a boot file for nand and the firmware... there is not a whole lot of usable information on flashing especially after translations of google

i flashed the above rootfs0 and kernel1. however my router now constantly disconnects from the lan cable and reconnects rapid. the led is orange and flashes goes back to steady and blinking all over

uploaded through winscp on /tmp
ls /tmp
mtd write ...kernel1.bin kernel1
mtd write ...rootfs0.bin rootfs0
and the following steps and rebooted

since i didnt understand is the sysupgrade through uart? since im a bit confused..
didnt flash kernel0 as suggested as well for the recovery function

cant recover official firmware through usb anymore either

1 Like