Xiaomi mi wifi 3 support

Buy Xiaomi Mi 3G, not Mi 3. Mi 3G costs almost the same, supports gigabit ethernet, USB3, and is also supported by OpenWrt.

This doesn't help him and a lot of others. There were the same situation like now before I bought this MI3 device. People recommended this because it was the most promising development ongoing. Now it suddenly stopped somehow and even when it was announced as officially supported it stucks still in a very low development level if you follow this treat.

It's really annoying slowly since it seems there is no real good choice for a low cost supported device. Everyone just recommends the >200€ Linksys AC3200 device which is maybe with good support atm, but nobody knows if it's still the same in 3 months.

I think slowly this has to be shut down to a good overview and some key supported devices or a better support than "buy a new device". Besides the traders nobody is happy with that.

Besides fundamental features it should now always wireguard already been implemented I'm every image. That's a minimum requirement in my eyes and the only reason why to switch from good working original images.

1 Like

WR1200JS is fine low price easy for install openwrt

is there any sysupgrade with this one got plenty of error install php and using it

is it safe if i had an openwrt convert to padora

I tried to install new firmware by using sysupgrade -F through ssh.
It worked but wifi was not working.
Then I flashed back stock firmware, and tried doing the clean flash as in the instruction.
That makes the router went into bootloop, after loading kernel.

I restored it using TFTP and serial console.

Does anyone tried last build (from December 2018) downloaded from mega.nz?
Is it working on your routers?

Do I need to do anything special to avoid bootloop?

Now I flashed success some previous build from July 2018 which I had on router before.
It works OK, but sometimes 2.4GHz WiFi hangs.

The wifi hangs probably because of this error (you can look it up on your system log):
ieee80211 phy1: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2

This is supposedly fixed in the latest mt76 driver, but it is not. I was also facing this problem, later my device bricks after installing bakemono's clean openwrt without having UART access (it bootloops), so I revived it by converting it to mi wifi mini and install pandorabox. So, I reckon PandoraBox will also fix that for you.

Relevant bug report: https://bugs.openwrt.org/index.php?do=details&task_id=896

Yes thats the error what I have when there is a lot of 2.4G traffic.
I thought it was fixed in current HEAD.

I use 802.11r roaming between access points. Does it work in Pandora?

Could you give me a hint for converting to mini version?
Did you just soldered spi flash and changed the resistors?

How did you flashed the spi, and what binary have you used.


802.11r is not working in Pandora as far as I know.

Yes, I bought a flash chip, flashed it with CH341A SPI flasher with the provided file from 4PDA, solder it on the board along with the resistor and jumper cable (also removed one resistor on the board), and that's it.

Ok sounds simple.

I looked at 4pda but link to full dump is not working. Can you send me some link to instructions or at least full dump.

I wonder if it is working correctly on current openwrt for mini.

Many thanks.

Your error is a long standing bug in the rt2x00 family of drivers, while there should have been recent (master, not 18.06.x) improvements in regard, it's not quite clear if the problems have really been fixed. mt76 is a new driver for newer Mediatek chipsets, these should not be affected by the bug you mention - but they don't apply to your device (xiaomi mir3), only the newer mt7621/ mt7628 based SOCs (xiaomi mir3g) and their wlan chipsets.

At least one person is working on it https://github.com/sgruszka
His last statement:

Hi, I plan to mask "Dropping frame due to full tx queue" error as printing it can cause troubles by itself.

Have also some pending patches and further improvements . Will provide to test in my repo as soon I test then by myself and assure they do not cause crashes.

All my work should finally lend in master.

1 Like

Hi, i have seen your compiled image on mega for Mi3 , can you please tell me does it work? , and are you using it on your device?
Thank you for support

Tried image from mega and it works but you can't install packages (since it's based on master)

1 Like

I tried installing openwrt today. But after the reboot command, my router restarted and got stuck on the orange light. What do I do?

If you've installed Pandora bootloader reset it with button and flash Pandora or Openwrt version from this thread

Thanks for the quick response, but I can’t reset it... when I push the reset button the light just stays orange


Any idea how to install DNSCrypt on Mi Router 3 with PandoraBox?
I switched from OpenWRT because of the low WiFi speeds.

I tried

opkg install --force-depends http://archive.openwrt.org/chaos_calmer/15.05.1/ramips/mt7620/packages/packages/dnscrypt-proxy_1.4.3-1_ramips_24kec.ipk

But it resulted in

Unknown package 'dnscrypt-proxy'. 
Collected errors: 
* pkg_hash_fetch_best_installation_candidate: Packages for dnscrypt-proxy found, but incompatible with the architectures configured 
* opkg_install_cmd: Cannot install package dnscrypt-proxy.


i hate padorabox....mu wan keeps on disconnecting

Hi. I would like to ask some help from you guys. So recently I got pandora box to work (I used the one from the mega link) then when I tried to go back to the stock firmware it got stuck with the orange light after flashing the stock bootloader also from the mega link. Now my router is stuck on the orange light. Reset button doesn't work. I can connect through the serial port though I can not select the "Load system code to SDRAM via TFTP" because it defaults to option 3 which is "boot system via Flash". even if I press 1 as fast as I can, it still boots with option 3. I hope someone can help me. I have also attached a screenshot as reference.