Xiaomi Mi Router 4C OpenWrt install help

Hello everyone,

Can someone help me with teamviewer on how to install openwrt in xiaomi router 4C

My telegram is: https://t.me/Jasmin822

Thanks in advance

did you read https://openwrt.org/toh/xiaomi/xiaomi_mi_router_4c ?

yes,i downloaded all those staff but I getting some errors which I don't understand.
if someone can access with teamviewer it would be nice.

yes it would be, but isn't very likely to happen ...

post the python errors, even though they aren't really openwrt related ...

try win snipping tool, next time :wink:

I downloaded from 4pda this tool but it gives me this error

Chcp exists in Win10, perhaps it doesn't in Win7 ?
Have you checked ?

Why did you DL something from 4pda, the wiki link points you towards the source for OpenWRTInvasion ?

chcp is the command, try running it in cmd (w/o any params), just as the window in your screen shot attempts to.

as you said not exist in win 7.
I will try to instal win 10 and perform this script again

problem solved .... kind of :wink:

If you want to avoid Win10, boot from a flash drive based live Linux dist, and perform the
OpenWRTInvasion there, but there's obviously a steep learning curve involved, unless
you're already familiar with Linux.

tried that already with ubuntu latest.
There gives me another error something like refusing connection in telnet as I remember.

i put the command: telnet and it says something like telnet refuses connection.
I followed this link : https://www.youtube.com/watch?v=VxzEvdDWU_s&ab_channel=HoddysGuides

It is not very simple to share screen, because it is initial router configuration. Do you have Windows?

Nice, just try to run following commands in cmd.exe:


See also: https://stackoverflow.com/questions/8142058/chcp-is-not-recognized-as-an-internal-or-external-command-operable-program-or

BTW OpenWRT is VERY unstable on this router, use Padavan instead.

It is intrinsic command in Windows 7 also, there is problem with PATH environment variable.

Ok, I installed win 10 ,chcp and tracert are working now,will see how it goes with script.
Will tell you shortly.

Finnaly got it. The trick was only to install win 10.

1 Like

OK, you have problems with PATH in Windows 7, I used Windows 7 successfully.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.