Xiaomi Mi Router 4A Gigabit Edition (R4AG/R4A Gigabit) -- fully supported and flashable with OpenWRTInvasion

ok, so, last thing, if I install the stable I don't have to install luci and I'm done, I have just to reboot the router and connect wired to configure, correct?

1 Like

yes exactly, you don't need to install luci manually in stable releases i think...

1 Like

Everything works now!!!

I had to manually download the firmware locally and then copy via FTP to the router because downloading with curl gave me a file of 185B while the fw is 4.0MB, then I renamed it to firmware.bin and did the mtd command.

Thanks again to @Zorro and @hoddy !!!


You need to click the link in a browser then right click on the "download now" (or whatever) and select copy link location to get a download link. Links will be temporary and may also only be for your IP.

Doesn't work this way.In idm shows 404 file doesn't exist.If you can extract this file:Here's the link-https://4pda.ru/forum/dl/post/19482777/MI-R3Gv2_3.4.3.9L-100.trx.zip
Upload it somewhere else and share the link please.

1 Like

Hey Guys.
is there any build available for 4A Giga Version which have shadowsocksR vpn package installed on it?

1 Like

NO, but you can try to install that package with this build...

1 Like

Thank you.
But, as you can see, i have literally no internet connection. Network is connected but connection drops every 3-4 seconds.
Any idea?

Perform a factory reset , most likely the issue is with your isp.

I don’t think so! With stock firmware and even padawan everything works great. Somethings wrong with these builds.

Nothing is wrong with that build tested by me and other great people .Sorry i can't help regarding your issue..

2020-05-21 02_09_16-Window


hi Zorro, so i have been using (testing) some of the build you upload and i have to inform that this build ethernet switch not work at gigabit speed only 100mbps

OpenWrt 19.07.2 r10947-65030d81f3 / LuCI openwrt-19.07 branch git-20.057.55219-13dd17f
SHA 256 748F869488498607AF7C6236EA1918DF0F58A2CE81CB1D7964E406A3ABAEBE0B

meanwhile back to snapshot build (kernel 5) with wireguard installed, the gigabit is works

1 Like

Hey there,

Firstly, thank you all for your efforts.

I've been following this thread from the beggining and i decided to flash my Xiaomi router with OpenWrt last weekend.

I wanted to use @Zorro's 3rd firmware. Tried to flash it with the scripts he shared before. I successfly got through the process but couldn't see the Luci interface when i type I don't remember exactly right now but i got some kind of denial error from the router (Not an SSL error). I had internet service over ethernet connection by default but Luci login screen do not show up (Tried different browsers etc.)

Then i tried to flash another firmware that @Zorro shared (OpenWrt SNAPSHOT r13062-ef5d37ba5e / LuCI Master git-20.116.42735-f44ba48). I can successfully reach the Luci login screen. I'm using this build for 5 days but i have unstable internet service with Wi-Fi. Wireless connection is not dropping but i lost the internet service on wireless connections 1-2 times a day (Using static leases. All of them are infinite.) While i'm watching something on Netflix via Amazon Firestick on my TV for example, the wireless connection still persists with the device but i lost internet service in the middle of the movie. I have to reboot the router to make it work again. I have no problems with my Ethernet connection.

I know that the snapshot build can be unstable in this router right now. So i want to make the @Zorro's 3rd firmware with kernel 4.14.167 work. Do you have any idea why i cannot reach the Luci login screen with this build?

1 Like

Which wifi you have problems with...2.4ghz or 5ghz?
Maybe it's somehow related to this issue?

From the issue ticket:
Empirically, I found out that the loss of the Internet occurs even with clients connected via LAN. 4 clients were connected to the 2.4 network, 5 one was connected to the network, a laptop was connected via wire, which downloaded a 14 gigabyte file and periodically either the laptop or the rest of the clients lost the connection. Moreover, the clients were not next to the router.

1 Like

I'm using 2.4ghz right now. I keep 5ghz disabled.

In that ticket he says that he's experiencing the same problem with 19.07 too (That's bad). And if i get it right; He has the same problem over the ethernet connection also (Which I don't.)

I don't have any wifi disconnections either. What i experience is only internet service loss via wifi.

I want to try the 3rd build (19.07) that @Zorro shared as i said before. But i couldn't get to the login page with that build.

1 Like

Hmm ok. I wonder if the internet loss issue is directly related to the mt7603 wifi driver for 2.4ghz.
Would be interesting if the same occurs for you in the 5ghz band too.
Sadly i don't have any knowledge about how all the components of the firmware work together.
But if it only happens on the 2.4ghz band we could probably use the proprietary mediatek 2.4ghz driver on 19.07 and keep the open source one for the 5ghz band. This way we wont loose roaming(802.11r) in the 5ghz band
It could be that the range is also improved with the stock driver since some users wrote that wifi range went down when moving from stock to openwrt.

1 Like

I found this when i check my logs just now. I'm not an expert but i think it's not about the driver, right?

I found this as a solution but i don't know how to implement it;


1 Like


Try disabling inactivity polling and dissociate on Low ack, I've found wifi to be very stable with these settings.


Thank you. Let's see if it solves the problem.

1 Like