Xiaomi Mi Router 4A Gigabit Edition (R4AG/R4A Gigabit) -- fully supported and flashable with OpenWRTInvasion

thanks for the reply
is pptp and l2tp included in vpn client list
are they really functional and tested
can you upload some image from pptp and l2tp and ovpn setting
i appreciate it

thanks for your helpful video but as i told i'm not familiar with linux
can you upload a video doing that in windows it would be helpful for those like me
i really appreciate your effort

1 Like

Sorry @emer62304 I'm probably not going to get a chance to do that for a while, however I'd really tat this opportunity to learn a little Linux, what you learn will definitely help you in the future when you're running OpenWrt. Download Virtual Box and grab a Ubuntu image and give it a go. As for your ovpn question, I think you should find the information you need here: https://openwrt.org/docs/guide-user/services/vpn/openvpn/client-luci

1 Like

Hi all

Is the Xiaomi Mi 4A (R4AC) non Gigabit flashable with OpenWrt?

Is this the correct firmware ?

Thanks!

@hoddy
I had switch the mode of the router to Access point.
Now I have resetted it to factory and I just done the basic installation.
The exploit "works" on 192.168.31.1 but it is refusing the telnet connection.
I tried to change the DNS, same result.
Any idea?

About Zorro's scripts, on my windows 10 64Bit, there is an error about UTF-8 (french version). No idea how to improve or solve that.

Yes,
I have 2 of these devices (100m) and installed them using the OpenWrtInvasion exploit using the link you shared as the openwrt image

3 Likes

Not exactly sure what to suggest, might be worth using the debrick method (at the end of my video) to make sure you're on a firmware we know is exploitable. Also, check you dont have any firewall rules on your pi stopping telnet (or anything else needed for the exploit (probably ftp)), could also try telneting from your window PC in command line the comand is the same "telnet 192.168.31.1"

I'm looking at the OpenWRT Invasion on GitHub
What is stok? Is the one found as a comment in the remote_command_execution_vulnerability.py file?

And after I get telnet access what should I do?

Thanks!

Hi Friends
I have this problem, try to return to the Fw Stock but my router was left with only the white led and I cannot access the BOOTP / DHCP mode, help please

@woody4165 Watch my video is should answer all your questions:


@horacio21 watch the end of my video, about debrick it shows a very simple method (thanks zorro)

1 Like

thanks but when I press the reset button for 10 seconds the orange led does not blink, it only stays on the white led

Did you use the OpenWrtInvasion Method or did you try reporgraming with the CH341? I had simular problems when i did the CH341 and had to reflash the unmodified original image back to the chip before it would work again. Does the second light come on when you plug a live ethernet cable into the wan port?

OpenWRTInvasion

yes, exactly when I connect ethernet cable, the second blue LED lights up

1 Like

Thats very odd, so with both lights on that seems like normal behaviour with a working router, second light is always off if no wan connection. Not being able to get it to go into recovery seems really odd and i assume you get nothing on IP's 192.168.31.1 and 192.168.1.1?

no response on IPs, only remains on the white led on

how did you get back to the original firmware

Thanks @hoddy

I'm on version 2.18.215

Is this version ok for OpenWRT Invasion?

For me i had to reflash the original chip data back with the CH341, ive never had that issue with the OpenWRTInvasion method and not been able to gey it into recovery, its possible that because you tried to use the stock firmware for the 4A it could have caused you in issue im guessing?

Exactly I went back to stock by means of a backup, which I publicly zorro, using scrips

As far as I'm aware all versions are currently exploitable, I don't think we've seen a version that isn't yet.

To be honest with you I'm struggling hopefully others have suggestions. Is the router providing you DHCP? So with your IP on your PC set to automatic and in command prompt typing "ipconfig" does it show you have an IP and/or gateway?