Xiaomi Mi Router 4A Gigabit Edition (R4AG/R4A Gigabit) -- fully supported and flashable with OpenWRTInvasion

no you didn't . just follow the unbrick method it should be fine .

[ 0.000000] OF: fdt: No valid device tree found, continuing without

Seems this is the main problem on OpenWrt master...

Has anybody repoted this issue?

2 Likes

@Zorro did: https://bugs.openwrt.org/index.php?do=details&task_id=3007

Please everybody that can, login to the issue tracker and start watching the bug report, so it shows under the "Most wanted tasks" section:

Thanks!

2 Likes

@981213 @adrianschmutzler Since you started making changes on the mt6721 target around the 4th of April (https://github.com/openwrt/openwrt/commits/master?before=a5a90a94cee96667b217fbaeb563c1fc4f4b7dba+175), the openWrt snapshot does not work for the router Xiaomi 4a Gigabit.

The issue is reported here (also contains some logs): https://bugs.openwrt.org/index.php?do=details&task_id=3007

Could you give us some insight on what is the current status?

Thanks :slight_smile:

3 Likes

http://radek.piastlan.net/openwrt/openvpn-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade.bin

Found on 4pda. It has openvpn and wireguard installed (but no wireguard luci app).

The ancient mediatek u-boot 1.1.3 is known to corrupt extracted kernel image when it becomes too big. I proposed a fix in this patch:
https://patchwork.ozlabs.org/project/openwrt/patch/20200414064438.1172618-1-gch981213@gmail.com/
and it needs more testing. Could someone help testing this patch on top of current OpenWrt master and see if the problem is fixed?

7 Likes

Thats normal, double click it and set an IP for it. A few seconds later when it next requests you should see another "ping" in the history but this time the IP address should show the one you inputed.

2 Likes

Hello hoddy,

So the version based on git-20 is having troubles on our device? (even buids from february?)

I'm having problems with squashfs, now i'm triyng to crosscompile a "new build" based on git-19 with some adjusts (add softether and wireguard as openvpn is not working as expected).

Thanks

I'm currently running git-20.064.26720-acef567 posted by zorro which seems stable on my device. Im not using wireguard but it is showing in luci though the page is blank, probably needs configuring. I've been able to install some of the additional packages for wireguard via opkg and will have a play a bit late about seing if I can get it setup but i can't see any immediate issues. Can you explain more what issues youre having with git-20?

Hi hoddy,

Thanks for the informations.
I posted the bootlogs on Post #309 and Post #484.

I've tried many builds but seems that are not working, anyway I will check again the version posted by zorro that you mention.

Thanks

Edit

the version posted by rusek666 boots correctly, still not understanding why other versions are not booting.

Thanks! I got it up and running again.

1 Like

I will say I used a different method to you, I used the Invasion method to upload the firmware, not sure if this could effect the installation method?

Maybe it is, from the instructions, I see that the firmware is flashed into OS1, that i can't see on openwrt running firmware and the command fails.

Eventually i'll check.

thanks

1 Like

Thanks for answering :slight_smile: I cant test at the moment, but I think there should be some people here eager to try.

EDIT: as currently the firmware is broken, why not apply the path on master? This way it will be easier to test, because people could use the next snapshot build (compiling openwrt is not trivial IMHO)

2 Likes

I just finished building and flashing master with your patch included-- I had to reset then reconfigure the router as the RJ45 ports weren't working (including WAN) when I upgraded with configurations intact.

All I can say is "so far so good", it works:

Here's my build of it (SHA256: 26a34f1db3a84e9122f326813f3fb8cae54b4411483f01230bf34d5427451e8c), though again, while it works for me I'm not exactly sure that I'm doing everything right. I tested Wireguard on this and it does work except for IPv6, though I'm not sure if that's a problem on my end or not.

7 Likes

Can someone make changes to src? Our device have 3 LED instead of 2. They are blue status, orange status and blue+orange, let's say purple. And there are 2 LEDs that we don't have. Let's say in summary: add blue+orange led and delete unused mt76-phy leds

There is no support for leds with mixed colors like rgb or there like.
So it is not possible to add this!

1 Like

Fixed in: https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=ad19751edc21ae713bd95df6b93be64bd1e0c612

The patch I proposed for testing enables loader for all mt7621 devices and it turns out to break some other routers unaffected by this problem. That's why I want some testing before pushing it to master and now I've abandoned that patch.

7 Likes

So, there is no options to add led with 2 gpios?

booting normally with this build,, , run opkg update, opkg install luci-app-mwan3 but got satisfy_dependency_for error (different kernel).. . add --force-depends and the router can't boot.. . any solutions to install luci-app-mwan3 on non-latest snapshots? edited opkg sources but got same satisfy_x_x error.. .thanks a lot..