Xiaomi Mi Router 4A Gigabit Edition (R4AG/R4A Gigabit) -- fully supported and flashable with OpenWRTInvasion

I didnt get the part 1. What should I do after I download the OpenWRTInvasion? Sorry, Im beginner.

1 Like

Is there any way to find the snapshot 12 days ago? I had installed it and it worked very stable and the wifi was veeery fast

1 Like

i have this :
https://anonfile.com/LbueT2n8o4/openwrt-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade_bin
sha256sum:9df26ebca11efa5e2424c24106a891a5b868bfcd9267d8395a4444f6d0054f4b
kernel version:4.14.172
OpenWrt SNAPSHOT r12576-f2d976f06e / LuCI Master git-20.075.60520-5d7dc39
#####################################################################
package included:
luci with material theme
sqm qos
adblock
DNSCrypt-Proxy

1 Like

Hey,
could you please anyone make a full dump of stock firmware for Mi Router 4AC 100m EU?
You can erase your "Factory" data from your dump.

I have the same problem. Yesterday I unbricked the router with no problem, but today there's no way to do it. The IP is set with no problem but the tftp servers doesn't receive anything.

The .bin I used yesterday to unbrick the router was: miwifi_r4a_firmware_72d65_2.28.62.bin

Any ideas? Thanks!

Done the same:

Official .132
Lan cable - 935Mbps/935Mbps
2G - 30Mbps/44Mbps
5G - 445Mbps/320Mbps

Openwrt:
Lan cable - 935Mbps/935Mbps
2G (40mhz force) - 85Mbps/120Mbps
5G 320Mbps/360Mbps

2 Likes

I think to unbricked using linux method much easy and no tffp servers problem.

Seeing how many people is not reading this forum, installing the latests snapshot and bricking their device, I have added a note to the issue in the readme, and pointed to the binary firmwares provided by @Zorro. Find the updated readme here: https://github.com/acecilia/OpenWRTInvasion

Thanks all :rocket:

5 Likes

Nothing happens when I enter the second command. Can anybody help me?

Windows PowerShell
Copyright (C) Microsoft Corporation. All rights reserved.

Try the new cross-platform PowerShell https://aka.ms/pscore6

PS C:\Windows\system32> cd d:/1
PS D:\1> pip3 install -r requirements.txt # Install requirements
Requirement already satisfied: pycrypto in c:\program files\python39\lib\site-packages\pycrypto-2.6.1-py3.9-win-amd64.egg (from -r requirements.txt (line 1)) (2.6.1)
PS D:\1> python3 remote_command_execution_vulnerability.py # Run the script
PS D:\1>
1 Like

I've used the latest exploit version under Ubuntu running in VM - so try that way. All went well - i was on Chinese firmware.

2 Likes

Can you tell plz me which firmware you loaded? From the official openwrt snapshots ?

https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/openwrt-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade.bin --output firmware.bin ? Or something custom ?

1 Like

The one provided by @Zorro:
http://www.mediafire.com/file/0qetz7rm8n9hr04/openwrt-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade.bin/file

I've made a backup of that file:
http://radek.piastlan.net/openwrt/openwrt-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade.bin

1 Like

Ok thanks :cowboy_hat_face:

2 Likes

What version is it?

I was having issues debricking with BOOTP-DHCP so moved to dhcpserver.de version, if you add the firmware to the wwwroot directory (named test.bin) and use the wiz to enable webserver and TFTP all worked perfectly for me, remember to wait for blue flashing light before rebooting. Also, don't use original openwrt image use the version from zorro or you will brick the device. I had to use wget (instead of curl) on the mediafire link, if you keep the --output firmware.bin all other commands work as before.
e.g wget http://download1863.mediafire.com/c9g50nkv0psg/0qetz7rm8n9hr04/openwrt-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade.bin --output firmware.bin

5 Likes

Hello everyone

Hope you all are safe in this craziness

right of the bat im letting you know Im an amateur in this area. so i wanted to buy the 4a gigabit version to and use openwrt(some one recomended it) to be able to use openvpn and wireguard on router. is it possible ? will you recommend it ? can i install it myself or i need extra hardware ? ive read that it may brick your router will it be ok later ?

Thanks Alot

Hi
it's not that straight forward

yes this is a router with good hardware and decent price that can do most of what you want with openwrt but at the moment there is a problem with the snapshot builds so you're going to have to use older builds that don't have openvpn built in and you won't be able to install it

as your second question it's not hard at all and you don't need to get into hardware but you do need some basic understanding of command lines and network setting

2 Likes

yes , you can install openwrt by using dear @acecilia method . thanks to him alot. you don't need any extra hardware.but latest openwrt snapshot will brick your router it is under development by openwrt team and has a new kernel.

for more information please go to below link :

2 Likes

Thanks alot. both of you for replying back.

Im assuming snap shot is the build you have to use on the routher right ?

So if the latest build brick the device , will it gonna be fixed anytime soon or its gonna stay the same ? how much often they update the build ? like every week ? month ?

and most important question does WireGuard and openvpn both works smoothly on it ?

between 4a and RB941-2nd-tc HAP Lite which one do you recommend ? my only need is sharing those 2 protocol vpn

DID somebody manage to install any VPN solution(in particular OpenVPN package) ? i get an error with cannot install due to wrong kernel version

1 Like