Xiaomi Mi Router 4A Gigabit Edition (R4AG/R4A Gigabit) -- fully supported and flashable with OpenWRTInvasion

About 11 days ago I managed to successfully install openwrt on the specific router with the expoit.

Today I wanted to download the last snapshot to upgrade. The router unfortunately became bricked but fortunately thanks to this post https://www.arednmesh.org/content/​how-unbrick-tp-link-node I managed to pass the original firmware in Chinese. Then I did the same procedure again, but while it shows that exploit is acceptable on the router, the router never starts. It stays stable with the orange light permanently on.

Any help is welcome

Hi, latest snapshots aren't usable. See previous posts. Try using an older version (someone posted a link to a valid image). From the changelogs, I see that Openwrt team is migrating mediatek platforms to kernel 5.4 so don't expect much stability from latest stuff at this time unfortunately :frowning:

My advice is to give them some time and meanwhile flash older images that others have tested as usable.

2 Likes

I think your method should use *.bin that more stable than Openwrt snapshot build. last snapshot may break router from reboot ,To do that you should upload *.bin to somewhere and curl -O *.bin to that source. Because its more safe for your method. User can update Openwrt later.

Guys, @acecilia has updated his exploit. We can now access file system dir using ftp. Just upload whatever bin we want to flash directly.

3 Likes

For us who returned to the Chinese rom (2,28,62) , nothing happens if we don't turn to 2.28.132. I try it 100 times.
I've searched everywhere to find it without result

E D I T

I finally succeeded by replacing the curl -O https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/openwrt-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade.bin with curl -O http: //medload16 .com / ucqhcldw0vag / 0qetz7rm8n9hr04 / openwrt-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade.bin

1 Like

I have compare Wifi speed of OpenWrt vs Official ROM.
on Lan speed at 500/400
on Official ROM 500/300 (Dual-Band Mode)
on OpenWrt 220/300 (5G,2G same SSID)

Why download just half of official rom?
Did I forget some settings?

no you're not.
Official firmware has optimized proprietary wireless driver different from opensource version.

Hi i'm trying to unbrick my device after the last update to snpashots

i'm doing everything in @Albertcp 's tutorial and considered Zorro and @Arianismmm 's suggestion it's not working
the modem light is blinking , i get a DHCP request on the btp server and i set the ip as per the tutorial but i'm not getting any log on the tftp server

any help is greatly appreciated

But the original one is based on OpenWRT too. Can't we extract the proprietary drivers?

Does anyone have a version of the OpenWRT firmware with VPN services included, working for this Router - Xiaomi Gigabit R4A ? thx!

try to go ahead with the image upload. (change the name of the Chinese image name to test.bin chose the folder where resides see if it make any diff) it might help to tell what color flashes on the device orange / blue ?
blinking orange i think is in bootstrap mode waiting to upload an image on device

It's Blinking Orange
i tried that but it didn't work

i'm trying to watch what's happening using wireshark and it seems like it's not asking for anything there is no tftp request at all and it's constantly sending arp requests for 0.0.0.0

I have no idea about using stock driver on current OpenWrt build,
different kernel version, hidden/undocumented low level access to hardware etc...

maybe you can try it?

If it's still sending arp requests, then it doesn't get enough information to tftp the file correctly.
Looks like your setup is wrong.
Have you checked that the mac address in the arp request is matching the address in your config?

thanks
i don't know what i changed but it worked

In my case the mac address changed serveral times.
Maybe it was the same for you.
So after enough tries, it will be 00:aa:bb:cc:... again.

Hello, I recently bought Mi Router 4A Gigabit Edition Global version and firmware is 2.28.132. I want to install OpenWrt but I have a couple of questions.

1- If I dont like the OpenWrt can I easily go back to original firmware? Should I backup my device?

2- OpenWrt's Wifi performance will be better than original?

3- Is there a guide for noobs?

Thank you!

turn off your windows firewall and try again.

Anyone test the latest snapshot? Or is anyone working on fix yet?

A few scrolls up, you will find the answers.