Xiaomi Mi Router 4A Gigabit Edition (R4AG/R4A Gigabit) -- fully supported and flashable with OpenWRTInvasion

When you mention of "drop connection and reconnect" what are you referring to this issue?

[17965.105187] mt7530 mdio-bus:1f wan: Link is Down
[17968.177242] mt7530 mdio-bus:1f wan: Link is Up - 100Mbps/Full - flow control off

I am having a similar issue on another hardware model, I described it in the following post:


Yes i was referring to this issue , i had it on all the builds i tried(even on 19.07) except for @db260179 builds so i guess he knows more about this switch issue.

RC4 is officially annonced.

Most likely the eee mode (energy saving mode) is triggering a port shutdown. The mt7621 has a few hardware bugs, if someone just looks at my v19.07 patches and mimics the similar feature turn offs, should help the issue.


Thank you for this information @db260179, can you point out to which patches exactly?
I am willing to dig deeper into this and find out if it's a software issue or not.

Seems like this patch fixed the issue (at least for me)

I ordered a refurbished Router 4A Gigabit Edition at Amazon and did not notice, that they delivered the wrong model (4A 100M, not Gigabit).
So I flashed the wrong firmware with OpenWRTInvasion and bricked it.

I can unbrick it via TFTP with 2.18.28 or 2.18.58, but those are both chinese.
Flashing OpenWrt via OpenWRTInvasion (now the version for non Gigabit Edition) is working as well.

But i would like to send it back and get a real Gigabit Edition.
I there any chance to get it back to the international Xiaomi firmware?
Flashing the 3.0.5_INT does not work, get's bricked again. Anyway I think that one is for 4A Gigabit, not for 4A 100M

Thanks for your help.

have you tried any of these?

or @hoddy 's guide https://youtu.be/VxzEvdDWU_s?t=268


Yes, i got the information for debricking from hoody's guide. But that way I only get back to chinese UI. And sending it back to Amazon with chinese UI or with OpenWRT is probably not okay.
So I am looking for a way to get it back to the english UI, but the only international firmware (3.0.5_INT) i found does not work on the 4A 100M.

I tried using 15 meters lan cable for good but in RC4 it's kinda weird after rebooting my router my internet connection is losing even though my 2nd LED is blinking,in my other snapshot build this isn't happening....is that a bug or something? or is it because of the VLAN configuration thing?

1 Like

Hello all,
Does anyone have the schematic of this router? Where should the legs of the spi flash be connected?

I accidentally damaged some spi pads on pcb while desolering the spi flash. I want to fix damaged traces/pads with enamel jumper wire. But I'm having trouble tracking the copper traces on the matte black colored PCB. My eyes aren't doing their job as well as I'd like :slight_smile:
Thanks in advance.


Hi all.

Currently, I use a vm on my server which hosts a wireguard server so I can acces it from anywhere. Sometimes, the VM would hang itself up.

That's why I consider having wireguard on my openwrt xiaomi 4a. Is it something to consider

The openwrt router acts as a Dumb AP in the home network.


Seems someone has up streamed a patched to turn these features on or off.

1 Like

A patch for 21.02?

This is some very useful info! Unfortunately I cant find any documentation on how i am supposed to turn this feature on/off.
Edit: Seems like you disable it by

ethtool --set-eee eth0 eee off

If i understood correctly. (Someone please correct me if i am wrong)

Hi, need help I hv Samsung A8 2018 & A51, my phone can't detect 5Ghz wifi coz the channel not at the list.
my phone only detach 149, 151, 153, 155, 159, 161 channel
how to change it, max channel only 144.


Yes, i believe thats the way to turn it off.

Might get backported as 21.02 is not fully out yet.

1 Like

hello do you think all the bugs in will be gone in the official release? I'm currently using 15 meters lan cable now to connect my mir4ag to the internet because the WiFi bridge has a bug on wifi speeds it drops like hell and the packet loss is always there...

@db260179 updated to 19.07.8

Thank you.