Xiaomi MI R3G - Bootloop / Switch dead, no usb recovery

Hello noob here, anyone is having trouble with this?
Router stopped working suddenly led turned orange also ethernet led ports, cant access openwrt anymore.
Went to the debrick guide https://openwrt.org/toh/xiaomi/mir3g but no luck.

Ethernet / Lan ports are dead, so no tftp possible also tested different cables not working. This is TTL serial output the error what seem the cause but didn't find to much , I also try install BREED Bootloader but didn't help.
I have acces to Bootloader via serial usb cable.

[  148.290000] Status: 1100fc03 KERNEL EXL IE
[  148.290000] Cause : 50808400
[  148.290000] PrId  : 0001992f (MIPS 1004Kc)
[  148.290000] epc not accessible
[  148.290000] CPU: 0 PID: 589 Comm: ifconfig Not tainted 3.10.14 #1

I tried with debricking guide already also USB method but no change same output.

Here is all the log from TTL https://pastebin.com/KJJdajYt

Any help would be very much appreciated, I'm completely lost for ideas.

does the serial port respond to commands, or is it read only ?

It could be hardware failure. Have you tried a different power supply?

Yes serial port respond to commands but i cant do too much without LAN ports, cant upload kernel.

I can access BREED bootloader and also if I hold a pin in the reset button before BREED loads, it recognize USB and flash miwifi.bin from USB, but at next restart its the same result, I don't know why recovery method does not work.

Also yes I tried different supply of 2.0A and 2.5A 12V both and Ethernet port flash a few times but can't establish LAN connection, I tried different Ethernet cables, Linux, Windows router but doesn't work either.

Thanks so much for the help.

Also do anyone know how to restore stock bootloader (U-Boot) from BREED or serial usb?

To clarify I can acces BREED bootloader command console and introduce built-in commands, but im lost there.

Maybe this can work, but I don't know where kernel addres in memory might be.


BREED Manual Eng

In breed, do an env list, try net start and netstat ....

The miwifi.bin, did it contain the Xiaomi image, or OpenWRT ?

env list does not return anything

and net start and netstat works but still no ethernet works no leds also blinks,

breed> netstat
Protocol Local Address Foreign Address State

The miwifi.bin contains Xiaomi developer images, I tried different version no result
Should I change miwifi.bin for OpenWrt image? Wich one?

Thanks for help much appreciated

Well, there's something listening on, did you try to access it ?

Try an sysupgrade image, on the same or higher release than you already had installed.

Have tried sysupgrade of version 19.07.4 and 19.07.03 and 19.07.0 same result all

Invalid image block
/mnt/sda1/miwifi.bin is not a valid MiWiFi image
[ 16.780000] Restarting system.

How do I can access TCP without the switch?
Is anyway to use serial UART to access?

Well, it might not be dead (even though it probably is), just because the LEDs don't light up.

Leds flashes when powered up and when entering BREED shell so there is something,
the thing is in pc Ethernet adapter never gets online or recognize anything,
I had tried changing Ethernet cables, various OS, router in middle of pc and MIR3G, nothing seems work.

Thanks so much anyway