Xiaomi mi ac2100 - unable to install OpenWrt


bought a Xiaomi mi ac2100 router (black cylinder) but I'm unable to install openwrt (tried both in macOS and in Linux).
I have followed this script: https://github.com/impulse/ac2100-openwrt-guide and used the files in the repo.

Already tried 6 or 7 times, checked that the cables where attached and in the correct positions (WAN and LAN1 bridged and a
second cable from LAN2 to my laptop). Also, I've followed all the steps in the script (changed the interface in both py files
as well as the MAC address in pppd-cve.py).

All goes according to the script up until the point where I run the script "python3 pppd-cve.py". This sript runs normaly
and sends 1 packet (to the correct MAC address of my ethernet NIC) but netcat never receives a connection and I am unable
to move forward from this point.

Remark: I run all the scripts as sudo but still no luck.

The Xiaomi firmware version that came with the router is 2.0.376 (also tried to downgrade to version 2.0.23 with the file from
https://openwrt.org/inbox/toh/xiaomi/xiaomi_mi_router_ac2100 but was unsucessfull - msg:"File verification failed").

Sorry to be starting a new topic but I couldn't find a solution to this issue in the forum.
Can anyone please help ?


Hi guys,

Found out this morning that the reason it wasn't working was because of a copy-paste mistake I made (basically copied the mac from my Ethernet nic instead of the router). Sorry and thanks!

This topic was automatically closed after 10 days. New replies are no longer allowed.