Xiaomi Gigabit 4a, slow 2.4ghz speeds

I recently picked up Xiaomi 4a router Gigabit edition and flashed OpenWrt 21.02.3 on it. I have 90mbps plan (90 up and down). On 5g band, I get full speed but however 2.4ghz its maxes out at around 40-45mbps. I have tried different channel combinations, forced 40mhz bandwidth, software & hardware flow offloading. Still not much improvement. Speeds are like 30-40mbps most of the times even when i'm very near to the router.

To further test it out, I disabled 2.4g band on Xiaomi router and connected my older tenda router via LAN to it. It can easily provide speeds of 70-80 mbps on 2.4ghz.

Is it just me, or its the usual speed on 2.4ghz for this router?

1 Like

fwiw, open source wifi drivers freely provided for use in OpenWrt are not going to perform as well as closed source licensed wifi drivers used by device manufacturers.

Have you tried OpenWrt 22.03.0-rc4 or snapshots to see if it makes any difference?

The open source MT76 drivers are subject to continual improvement though.

For best wifi performance and wifi device compatibility with OpenWrt, use a separate access point running stock firmware as you have already discovered.

1 Like

yes, I am kind of aware wireless performance may not be best on openwrt..so that's why just wondering if its same for all users of this particular router or just me.

It seems to be very popular model and comes with customized openwrt in stock, so expected better performance.

Was kinda hisistant with installing rc release since its my main router. Will try once its finalized

fwiw, a very quick test using iperf3.

Xiaomi 4A Gigabit router:
Windows PC running iperf3 server on WAN side

Windows laptop with Intel AC7260 2x2 wireless card.
command for multi-thread transfer, executed at client (LAN side):
iperf3 -c serverIP -t 10 P 10 -R

WAN to Wireless speeds

OpenWrt 21.02.3
2.4 GHz 20 MHz     78.5 Mbits/sec
2.4 GHz 40 MHz     77.4 Mbits/sec
5 GHz 40 MHz     149 Mbits/sec
5 GHz 80 MHz     182 Mbits/sec
OpenWrt 22.03.0-rc4
2.4 GHz 20 MHz     73.6 Mbits/sec
2.4 GHz 40 MHz     75.5 Mbits/sec
5 GHz 40 MHz     132 Mbits/sec
5 GHz 80 MHz      152 Mbits/sec

A 1x1 client will return lower figures.

For OpenWrt 22.03.0-rc4, when 40 MHz bandwidth is selected for 2.4 GHz radio in wireless interface setup page within LuCI,


The RX/TX rate reporting in Status Overview for the laptop is only connecting at 20 MHz.

Seems like 40 MHz mode is not working/enabled in 2.4 GHz during my brief test.

Personally, I never use 40 MHz mode on 2.4 GHz band as it is bad practise especially in a wifi congested neighbourhood.


Thanks a lot for doing the test, you seem to get good speed on 2.4ghz. Guess have to upgrade to openwrt v22 RC now.
Regarding 40mhz bandwidth, you have to force 40mhz mode. It comes under Advance settings under wireless settings. But yeah you are right, there is no speed improvement with 40mhz and packet loss becomes really high.

1 Like

The Intel wireless driver for Windows only offers 'Auto' and '20 MHz' manual settings.

I used InSSIDer to reveal the 4A wireless is only showing 20 MHz (not 40 MHz) bandwidth on 2.4 GHz.

I temporarily reconfigured my Linksys AP running OEM firmware to 40 MHz on 2.4 GHz SSID, and InSSIDer reported 40 MHz bandwidth on the SSID. When I ran an internet speed test, the results were much higher than for 20 MHz.

It suggests OpenWrt on 4A is not switching to 40 MHz mode in 2.4 GHz.

I meant set 40mhz in your router's openwrt setting. After doing this, I get 40mhz band, when i test through my phone using wifi analyser app.

1 Like

Used the 'Force 40MHz mode' in the 4A on 2.4 GHz.

The iperf3 results were inconsistent between each run. Varied from 56 to 90 Mbps. Possibly due to wifi interference from neighbours?

I changed it back to 20 MHz, and iperf3 was returning numbers around 78 Mbps.

1 Like