Xiaomi ax6000 switch config

I have subj router. It has wifi6 and 4 ports: 1 wan 2.5gbps and 3 lan 1gbps. It has some modified version of openwrt. Ive got root access. Also i have fiber internet working by pppoe protocol. So my provider request vlan tagging. Its not possible to set by default webui.
So i changed it in /etc/config/network to

config
config device
        option macaddr '11:11:11:11:11:11'
        option name 'eth1'

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config switch 'switch0'
        option name 'switch0'
        option max_frame_size '1518'

config switch 'switch1'
        option name 'switch1'
        option enable_vlan '0'

config interface 'lan'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option multicast_querier '0'
        option igmp_snooping '0'
        option macaddr '22:22:22:22:22:22'
        option ipaddr '192.168.10.1'
        option ifname 'eth0'

config interface 'eth0'
        option ifname 'eth0'

config interface 'wan'
        option proto 'pppoe'
        list dns '192.168.10.3'
        list dns '192.168.10.1'
        option peerdns '0'
        option username 'login'
        option special '0'
        option mru '1480'
        option macaddr '11:11:11:11:11:11'
        option password 'pass'
        option ipv6 '0'
        option ifname 'eth1.848'

config interface 'eth0_2'
        option ifname 'eth0'
        option keepup '1'

config interface 'eth1'
        option ifname 'eth1.848'
        option keepup '1'

But i wanted to connect 2.5wan port to NAS and use 1gbps for internet.
So i used new

config2
config device
        option macaddr '11:11:11:11:11:11'
        option name 'eth0.2'

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config switch 'switch0'
        option name 'switch0'
        option max_frame_size '1522'

config switch 'switch1'
        option name 'switch1'
        option enable_vlan '1'

config interface 'lan'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option multicast_querier '0'
        option igmp_snooping '0'
        option macaddr '22:22:22:22:22:22'
        option ipaddr '192.168.10.1'
        option ip6assign '64'
        option ifname 'eth0.1 eth1'

config interface 'eth0'
        option ifname 'eth0'

config interface 'wan'
        option proto 'pppoe'
        list dns '192.168.10.3'
        list dns '192.168.10.1'
        option peerdns '0'
        option username 'login'
        option special '0'
        option mru '1480'
        option macaddr '11:11:11:11:11:11'
        option password 'pass'
        option ipv6 'auto'
        option ifname 'eth0.848'

config switch_vlan	
        option device 'switch1'
        option vlan '1'
        option ports '2 3 4t'

config switch_vlan
        option device 'switch1'
        option vlan '2'
        option ports '1t 4t'
        option vid '848'

config interface 'eth0_2'
        option ifname 'eth0.848'
        option keepup '1'
        
config device
        option name 'eth1'
        option macaddr '22:22:22:22:22:22'

All works fine, but sites connection works slower using 1gpbe port (config2) than first one. Any ideas why? Look at
config switch_vlan
option device 'switch1'
option ports '1t 4t'

I think tagging shouldnt take so much resources. Or am i configurated it wrong? Thx in advance

could you please share with me the step-by-step you have used to install openwrt in this router?

thank you

It already has modified version of openwrt. Read up carefully

oh..

sorry, my bad

thank you