Xiaomi AX3600 - unable to upgrade from one snapshot to another

Hello, I've run into a weird issue. I'm currently running OpenWrt SNAPSHOT r22170-5e48c534f7 on Xiaomi AX3600, to which support was added recently. However, I tried to update to a new version, but sysupgrade command keeps...failing? I have no idea how to describe it, since command runs, router reboots, but the snapshot version and packages remain unchanged. I even tried forcing it, to no avail. I've looked into flashing the update via mtd, but this router doesn't seem to have a device "firmware" according to printout from cat /proc/mtd:

dev:    size   erasesize  name
mtd0: 00100000 00020000 "0:sbl1"
mtd1: 00100000 00020000 "0:mibib"
mtd2: 00300000 00020000 "0:qsee"
mtd3: 00080000 00020000 "0:devcfg"
mtd4: 00080000 00020000 "0:rpm"
mtd5: 00080000 00020000 "0:cdt"
mtd6: 00080000 00020000 "0:appsblenv"
mtd7: 00100000 00020000 "0:appsbl"
mtd8: 00080000 00020000 "0:art"
mtd9: 00080000 00020000 "bdata"
mtd10: 00100000 00020000 "pstore"
mtd11: 023c0000 00020000 "ubi_kernel"
mtd12: 0d240000 00020000 "rootfs"

How do I go about updating this? System log doesn't provide anything that signifies a failure.

Stop/kill wpad before upgrading, it's a know issue.

1 Like

Thanks a lot! That solved it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.