Xiaomi ax3600 some AC devices intermittent connection

Hi experts,

I'm using 23.05 stable for ipq807x. I have 3 AC with using AC freedom app for management.

2 of them have an intermittent connection, successfully added to the app then they go to offline after few hours...but 1 has been working fine (2 are the same model but 1 does not)

I have tried change the f/w to version 2rc and also SNAPSHOT...but no luck for me.

I have tried many things that I can search on the forum but no luck...

here my configuration:
wireless:

root@OpenWrt-ax3600-1:~# uci export wireless
package wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/20000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '1'
        option band '2g'
        option cell_density '0'
        option txpower '20'
        option ldpc '0'
        option disabled '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/c000000.wifi'
        option band '5g'
        option htmode 'HE80'
        option cell_density '0'
        option country 'TH'
        option beacon_int '139'
        option channel '104'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'nt-nw5'
        option encryption 'psk2'
        option ifname 'wlan5'
        option key '****'
        option ieee80211r '1'
        option mobility_domain 'abcd'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option disassoc_low_ack '0'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/c000000.wifi+1'
        option channel '11'
        option band '2g'
        option cell_density '0'
        option country 'TH'
        option log_level '0'
        option legacy_rates '1'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'nt-nw'
        option encryption 'psk2'
        option key '****'
        option ifname 'wlan2'
        option disassoc_low_ack '0'
        option short_preamble '0'
        option macfilter 'deny'
        list maclist '78:0F:77:24:9B:CE'
        option max_inactivity '86400'
        option dtim_period '1'
        option hidden '1'
        option wpa_group_rekey '86400'
        option wmm '0'

network:

root@OpenWrt-ax3600-1:~# uci export network
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.31.1'
        option netmask '255.255.255.0'
        option delegate '0'

config interface 'wan'
        option device 'wan'
        option proto 'pppoe'
        option username ******'
        option password '******'
        option ipv6 'auto'

config interface 'VPNusage'
        option proto 'static'
        option ipaddr '192.168.10.1'
        option netmask '255.255.255.0'
        option delegate '0'

dhcp:
root@OpenWrt-ax3600-1:~# uci export dhcp
package dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        option confdir '/tmp/dnsmasq.d'
        option enable_tftp '1'
        option tftp_root '/tmp/tftp'

config dhcp 'lan'
        option interface 'lan'
        option start '50'
        option limit '150'
        option leasetime '1h'
        option dhcpv4 'server'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option name 'HikVision'
        option dns '1'
        option mac 'B4:A3:82:B3:1B:12'
        option ip '192.168.31.30'
        option leasetime 'infinite'

config host
        option name 'AC-livingRoom'
        option dns '1'
        option mac '78:0F:77:24:53:24'
        option ip '192.168.31.101'
        option leasetime 'infinite'

config host
        option name 'AC-officeRoom'
        option dns '1'
        option mac '78:0F:77:25:89:72'
        option ip '192.168.31.102'
        option leasetime 'infinite'

config host
        option name 'AC-bedRoom'
        option dns '1'
        option mac '78:0F:77:24:9B:CE'
        option ip '192.168.31.103'
        option leasetime 'infinite'

I found the solution by adding a periodic ping to the devices.

pls close the thread.