Xiaomi AX3600 INT firmware

Team, is there a way to change router region thru ssh? UI does not allow that after initial config.

Yes !

For example :

nvram set CountryCode=CN
nvram commit
1 Like

The weird thing is when I turn on QoS function, I can see port open (Can see my server in local) but can not connect! When I use the redmi AX5 (AX1800) router, I have the same problem but I can solve this by turn on QoS, it’s very weird

Port forwarding is working on my router. I think, there wasn't problem, it was mistake my part on not correctly configuring the router to which AX3600 is connecting.
What problem are you having with port forwarding?

1 Like

When I put my AX3600 as router (ISP modem dial PPPOE -> AX3600 broadcast wifi) I can forward port normally. But when I put my AX3600 as modem (ISP modem in bridge mode -> AX3600 dial PPPOE), I can't forward port any more

1 Like

Finally I solved this problem by set br-lan interface to promiscuous mode.
SSH into router add this line in etc/rc.local (before the line exit 0)

ifconfig br-lan promisc


Anyone know how to change guest wifi name on chinese firmware

I still cannot figure out how to get the Mi Wifi app working with the AX3600. I also tried adding it to the Mi Home app, and I can add the router but I cannot access any information or settings.
I use Version: 3.0.22, and the country is set to CN for better performance, I also have SSH access and such with the help from this thread.

I have tried using the Mi Wifi app with country set to Mainland China, and my real country with the same result. As soon as I try to change a setting or check information about the router in the app it cannot access it. Anyone else have this issue?

Some Xiaomi service

Hi there
I'm trying to enable ssh on downgraded firmware, but keep getting {"msg":"Parameter error","code":1523} errors (google translated). Have xiaomi patched firmware on their site quietly or I'm missing something?
Here's the last URL I've tried:;stok=074fbfb27d30410800a386e6b98bf0ad/api/misystem/set_config_iotdev?bssid=gallifrey&user_id=doctor&ssid=-h nvram%20set%20ssh_en%3D1


Pretty much confirmed: I flashed someone's private firmware backup, and exploit worked


What is needed to root/flash openwrt to this ax3600 if the ssh access is prevented with latest firmwares?

Read the device page and this thread (and Adding OpenWrt support for Xiaomi AX3600), it's all in there.

1 Like

As slh said: Look at the device page. Here it is:

The guide is spot on.

There is one caveat:
In the section "Installation/Installing OpenWrt/SSH Access" before step 1 (flash older version) I would do the basic setup in the OEM firmware. The password is the only thing you really need for later.

The 1.0.17 version is Chinese only, and unless you read Mandarin it might be difficult to understand what data you need to put in each box.

After that DO NOT select the reset data option when you flash the old firmware. This way, the password you've set on the first setup will be preserved and after entering the password on the Mandarin interface (which even I could manage) you can use the same password and the new STOK value from the URL for the following steps (2+) in the instruction.

I've flashed two devices this way, it takes about 15min if you've done it before. The "Debricking/TFTP recovery" section in the guide also works, as I can tell from the experience of having messed up twice on the first device.
Side note: You can also flash back to the European OEM version this way. And no, AFAIK the TFTP flash doesn't take an OpenWRT (...factory.ubi or ...sysupgrade.bin) flash directly. And YES, I,ve tried.

1 Like

Thank you! I managed to enable both SSH and telnet on 1.0.17 (CN). Thank you for the tip to NOT reset/clear my working 3.0.22 (EN) config when downgrading (Manual updating) to 1.0.17 (CN).

Question to anyone: how do I now update to 3.0.22 (EN) (the latest EN firmware) WITHOUT losing SSH/telnet?

I'm not certain updating to OEM 3.0.22 without losing SSH (and telnet) is possible. Maybe somebody else can help you with this.

To be honest, seriously consider flashing OpenWRT. Its interface isn't as designer pretty as the OEM, but OpenWRT is much more powerful. It supports bridging, VLANs, QoS, multiple DHCP address ranges, firewalling is extremely sophisticated, and there's almost anything you could want from a networking perspective available and it's all pretty easy. If you don't need all this, the simple presets will do fine, the only thing to do is set a password.

The section "Flashing OpenWRT" in the guide works precisely as advertised, and it's here (deeplink):

At the time of writing, the most current image you need for flashing OpenWRT to the AX3600 is here:

Don't be discouraged by the massive amount of information available on OpenWRT. If you need the expert stuff you can read up on it. If you don't, it's just plug and play (after flashing, obviously) and you don't need to give it a second thought.

Once you've got the SSH running it's only
scp downloads/openwrt-ipq807x-generic-xiaomi_ax3600-squashfs-nand-factory.ubi root@
(obviously add you own path to the image and the router's current IP address or use WinSCP if you're on a Windows machine)
Then follow the instructions in the link provided above.

After rebooting OpenWRT's default IP address will be and all you need to do is set up a password and for good measure flash the fallback partition as outlined in step 6. SSH is enabled by default.

It's really this simple!


Wow thank you. The showstopper to me going OpenWRT was the apparent need to compile the firmware/image myself. With this provided I'll continue with the guide and your outlined steps.

BTW, this is to EVERYONE: Don't go bothering the providers of the image I linked with every little problem that crops up. It's an ALPHA that really happens to work well.

If you do (bother them), they might remove it from public faster than you can blink.

Wait for the official release to complain.

For now, there's one problem I'm aware of: Memory leak on wireless (ath11k) driver.

My current workaround is to reboot every 8 hours. That takes ~15 seconds. I reboot at 4, 12, and 20 hours locally, I'm asleep at 04:00, at lunch at 12:00 and at dinner at 20:00.

If you have high bandwidth wireless traffic occurring naturally, you probably won't need this, because high bandwidth traffic on a wireless interface seems to clean up the memory, about 100MB worth.

This is the second option I'm aware of: Keep "iperf3 --server" running on the router and do "iperf3 --client YourRoutersIp --time 10" on a WIRELESS client every couple of hours. It won't do anything on a wired client.

By the time the official release is published I'm sure this will be handled. Right now, this is my solution.

1 Like

Bye bye stock firmware, OpenWrt lives! I followed the steps in the device page (and applied common sense) and it all went well. Thanks again.

I'm also pretty sure I'm not the only one who hates setting (and updating) static DHCP leases :angry:

1 Like