Xiaomi AX3600 INT firmware

unfortunatelly, it did not work, even when both are set to same region or one is configured as a main router and the secondary still has the welcome page, where you select the region. Not working...

Same issue for me :frowning:

Update: managed set it up.

  • With Romania selected on main router, and then probably other countries, mesh did not work, even with the script.
  • With Singapore selected, did not managed to even connect to the main router
  • It did work by selecting Germany on main router:
    -> set it up as a router without any extra special settings (did select the 3 options at initial setup: update, enable mimo, and another one, can't remember what was the third), added the router in MiWifi
    -> the second router (ax3600) immediately after factory reset, in close vecinity
    -> ran the script: https://github.com/ShotokanZH/MiWiFi_Mesh_Node_Adder (thank you again ShotokanZH)
    -> the first difference that i did observe was an actual reboot, previously it never did a reboot -> after a couple of minutes i could see the node added in the mesh, after that moved it away

(i have ax3600 global version. tx power is 20 dbm, i have changed country cn in bdata, and now 30 dbm.

but i have 2 questions,

1)how can i change back to original bdata for 20 dbm(i wanna set country code=eu), i have tried same way but it doesnt effect, still 30 dbm

2)may i set tx power 25dbm or 23 dbm or any number? 27 dbm high for me, but 20 dbm is low.

can someone help me?")

Hi i also search for an option to set a tx power but for now i cant find a script.

hi,i have ax3600 with cable bridge mode, normal wifi is bad 6.98mb/s, 5g is 88.53mb/s, with company router is 16.5mb/s and 5g 310mb/s, tested with my celular, this is normal?

Hi, anyone can confirm if UDP is working or not?
I'm going nut, using the router connected VIA CABLE to a modem in bridge, firewall off , upnp off and if I open the ports and if I check using nmap or canyouseeme, it is closed, (and so my vpn on port 51820 is not accessible from outside).
Tried also with DMZ and no dice.
is there anything that can be done? I understood a custom openwrt is not stil available ?
PS I have a Chinese version, with latest international fw

Go to the Advanced page in the router page and check if you have bandwidth limit set to lower values. Increase them to the maximum that your internet plan says and do the speed test again. Tell us your results.

i dont have bandwidht limit, with bridge mode or no bridge mode, wifi is poor, my old router tenda is more faster than xiaomi in wifi mode, but testing with my computer,normal wifi 70mb/s, 5g is 72mb/s, i have global firmware with bd data cn.

1 Like

Hi my router has bricked, i tried miwifirepair, but only flashing blue light, i waited 15 minutes, after than unplug and plug, but again red light, what can i do

I've followed the advice from 4pda forums. By simply re-positioning the router to face in an opposite direction, Wi-Fi connection has finally managed to be on par with the rest of the industry.

Unfortunately, the built-in steering algorithm doesn't switch between 2.4 and 5GHz in the most optimal way. With my densely populated 2.4GHz range, my only option to stream video remains 5GHz.

1 Like

I'm not talking about Smart QOS bandwidth limit. It is on the same page and either you have to do speed test in the router page itself (as with chinese stock firmware) or you have to manually give those values. If you feed wrong values (lower values) than what your internet provider is giving, that the router speed will be throttle to those value.

I bought the ax3600 from European distribution. Due to the relatively poor range, I want to change CoutryCode to CN or SG and stay with the Global software. As per the forum instructions, I downgraded to 1.0.17 to access SSH and changed CountryCode using the command:

nvram set CountryCode = XX
nvram commit

As a result, the transmission power increased to 30 dBm. Then I installed the Global software in the latest version. Poor coverage returned with the update. However, the CN / SG region was still in the settings. I also tried resetting the router to factory settings and setting the country via the GUI.

After reinstalling1.0.17 and checking in SSH with the command below

nvram get CountryCode

CountryCode was showing EU.

Could you plese give me a step by step instruction on how change CountryCode in bdata to CN / SG permanently? So I would be able to use Global software and keep the 30dBm.

1 Like

There are a lot of instructions around, but basically they are just few, but posted on different sources. Use search, Google etc :wink: I guess there was link to in this thread. And follow instructions very strictly and carefully!!! Otherwise you will run back and wiii... why it doesn't work or even will brick your router.

I bought the ax3600 as well. I'm sorry that I spam a little bit a thread, but I tried to use Uncle Google (as Aivarss suggested), however I couldn't find any guide steps by step regarding CN or SG region code. Have you found any useful link with a step by step guide? Thanks in advance.

I actually tried every available instruction that you can find via Google. Like this one:

Non of them worked. CountryCode was switching back to EU every time I was installing Global firmware. I tried a few times - no luck. I guess there is now way to change region to SG, use Global and Mi WiFi app. I'll try to gain permanent SSH and change CountryCode in Global, but I guess this gonna crash Mi WiFi app. The best way is to buy a chinese one.

On this forum as well :-/

Thank you, but the guide which you linked is a step-by-step instruction on how to gain SSH access and change CountryCode in early Chinese firmware. Definitely, it's not an instruction we are looking for.

1 Like

Here are very active thread, but in Russian. Use Google :wink: If there was any tweak or hack around for AX3600, it is discussed there. But all of that are mentioned on this forum as well.
mjuter, as I said, looks like you do something wrong. People around got all permanent, even after reset.

I managed to change EU to CN using @odedlaz tutorial:


It's clear and describes everything step-by-step. It's finally working as it should, taking into account that I'm not the "Terminal" guy. Now I'm able to use Global firmware and get use of AX3600 full performance.

If you are on macOS, remember to add python3 before executing any script. Wasted a lot of time on this - I need to read the log carefully next time. To get telnet access you will need Homebrew app, since macOS no longer supports this protocol.

I found ax3600_tool fairly straightfoward and easy to use. From security point of view, it's better to review the original code and compile it, rather than trust unverified crash partition downloads. AX3600 is already sending a lot of stuff back to China.

Once mt9 partition is unlocked, CountryCode can be changed from the command line:

bdata set CountryCode=CN
bdata commit

Don't forget to lock mt9 partition aftewards and reboot, otherwise Wi-Fi will disappear. When this happens, the only way to access the router will be the Ethernet port at the back.

1 Like