Xiaomi AX3600 INT firmware

update the country code to US/CA. i dont see that option in the drop down

As a wild guess, you could try to patch bdata again to change CountryCode=CN to CountryCode=US, then reset. I've seen this change in the repo that holds the python script to derive root password: https://github.com/odedlaz/ax3600-files/blob/ebd4781e0775c645a5008d6443aad84edf1ada43/scripts/header.py#L62
P.S. You could also use this code to create patched bdata instead of doing it manually
P.P.S. Don't use it: it's buggy. Maybe will send a PR with a fix later
P.P.P.S See https://github.com/odedlaz/ax3600-files/pull/2 for a fix:

$ python header.py modify
usage: header.py modify [-h] [--test] SRC DST [COUNTRY]
header.py modify: error: the following arguments are required: SRC, DST

If I recall correctly changing it to EU will reduce max output power. Might be closer to US regulations.
Plus iw reg set US in /etc/rc.local.

i did this setting also pathched bdata to US from CN like @alllexx88 mentioned. It was still not showing US. I followed @Double-G guide on what he did for DE.

Now, im not getting lot of frequencies but all code points to US though. Not even 160 for 5G


This is what im seeing but in UI im not seeing lot of frequencies

root@XiaoQiang:~# iwinfo wl0 txpowerlist
   0 dBm (   1 mW)
   6 dBm (   3 mW)
  10 dBm (  10 mW)
  14 dBm (  25 mW)
  18 dBm (  63 mW)
  22 dBm ( 158 mW)
  26 dBm ( 398 mW)
* 30 dBm (1000 mW)
root@XiaoQiang:~# iwinfo w10 freqlist
No such wireless device: w10
root@XiaoQiang:~# iwinfo wl0 freqlist
  5.180 GHz (Channel 36)
  5.200 GHz (Channel 40)
* 5.220 GHz (Channel 44)
  5.240 GHz (Channel 48)
  5.260 GHz (Channel 52)
  5.280 GHz (Channel 56)
  5.300 GHz (Channel 60)
  5.320 GHz (Channel 64)
  5.500 GHz (Channel 100)
  5.520 GHz (Channel 104)
  5.540 GHz (Channel 108)
  5.560 GHz (Channel 112)
  5.580 GHz (Channel 116)
  5.600 GHz (Channel 120)
  5.620 GHz (Channel 124)
  5.640 GHz (Channel 128)
  5.660 GHz (Channel 132)
  5.680 GHz (Channel 136)
  5.700 GHz (Channel 140)
  5.720 GHz (Channel 144)
  5.745 GHz (Channel 149)
  5.765 GHz (Channel 153)
  5.785 GHz (Channel 157)
  5.805 GHz (Channel 161)
  5.825 GHz (Channel 165)

Can someone tell me what is the wan port? the one near the power port or the last one?

farther / last from the power port.

1 Like

@alllexx88 @Double-G @perceival I tried multiple things for reg code.

bdata with US / EU is same but it is behaving differently with CN.

Reg frequency can be easily controlled with approach mentioned by @Double-G. I tried CA and US and no different between bdata variants and official frequencies.

But, power is different between CN and EU bdata


root@XiaoQiang:~# iwinfo wl0 txpowerlist
   0 dBm (   1 mW)
   4 dBm (   2 mW)
   6 dBm (   3 mW)
   8 dBm (   6 mW)
  10 dBm (  10 mW)
  12 dBm (  15 mW)
  14 dBm (  25 mW)
* 16 dBm (  39 mW)


root@XiaoQiang:~# iwinfo wl0 txpowerlimit
   0 dBm (   1 mW)
   6 dBm (   3 mW)
   9 dBm (   7 mW)
  12 dBm (  15 mW)
  15 dBm (  31 mW)
  18 dBm (  63 mW)
  21 dBm ( 125 mW)
* 24 dBm ( 251 mW)

Edit: lol you guys found this 13 days ago.


Anyone with ssh access can tell me if hostapd_cli is in INT firmware or not?
I need it to do a WPS pairing with my wifi tv decoder for my provider.
I bought ax3600 to bypass bad wifi performance, but i loose my tv decoder.

$ ubireader_extract_images -w miwifi_r3600_all_6510e_3.0.22_INT.bin

$ cd ubifs-root/miwifi_r3600_all_6510e_3.0.22_INT.bin/

$ unsquashfs img-1135711824_vol-ubi_rootfs.ubifs 
Parallel unsquashfs: Using 8 processors
4305 inodes (4469 blocks) to write

create_inode: could not create character device squashfs-root/dev/console, because you're not superuser!
[=================================================================================/ ] 4468/4469  99%

created 3847 files
created 251 directories
created 457 symlinks
created 0 devices
created 0 fifos

$ find squashfs-root/ -name hostapd_cli

1 Like

Ho... Didn't think to unsquash to look by myself.
Thanks you.
I will try (after folowing how to gain ssh on 1.0.67 and flash back 3.0.22 with ssh enabled) to initiate pairing with this command.

Hello as a person who does not understand much about routers, can anyone tell me what I need to do to increase the range of the router. Looking at the comments, I saw that changing the country increases the power, but my global version of the AX3600 does not have China in the initial setup. What are the options I use the router in Bulgaria and definitely as a range is much weaker compared to Tp link.

You must NOT play with the country settings. Tampering with it leads to a violation of local regulations and can lead to severe problems (weather or Airport Radar failing, your neighbors WiFi disturbed) and will be fined. In Germany they are driving around with Vans loaded with antennas and Equipment and hunt you down. Even If there is no complaint from anyone they check your area every few years as they must measure mobilephone operators and their emissions anyway.

Do NOT switch to a different country than the one you are living in. There is no benefit, as the Client sticks to your local regulatory domain too and cannot reply/send with excessive power even when it hears a (too strong) sender.

1 Like

What if someone has bought the Chinese version and wants to reduce power to their country?

You can (and should) install the international firmware to your Chinese device.

But according to what is written above, the reg code will not change and the power will remain the same.

Оk is there a way to check how much power i am currently transmitting at 2.4ghz without rooting the router with chinese firmware? Тhe router has a global version 3.0.22.

i think if you do factory reset it will change

you need to download logs and check there

Is there an easy way of resetting the web interface password over SSH?

/edit: nvm, did a factory reset, downgraded/rooted and all is fine again.

Have you found if port forwarding works better/is improved with this version? On my Chinese firmware, port forwarding doesn't actually seem to work correctly - not all rules are being followed. It's very frustrating.

check this Xiaomi ax3600 ssh guide