Xiaomi AX3600: (Client) Intel AX210NGW does not connect to radio1 (IPQ8074 802.11acaxn)

Good point. in regards to the short preamble, this should really only be used if you have a perfectly clear enviornment, otherwise clients may have a hard time syncing. Otherwise, short preamble can slightly reduce sync times and therefore latency.

The ieee80211w option set to 1 means Protected Management frames are optional, so shouldn't be an issue.

These options might be the culprit:

option wpa_disable_eapol_key_retries '1'
option disassoc_low_ack '1'

Would kick off devices if the signal is weak or if there's multi authentication retries. Try removing those?


Thank you two for the feedback... :slight_smile: I'll try your suggested config improvements and then report back :slightly_smiling_face:. Indeed, I'm living far outside town so there are no other wifi access points competing in range.

If you are using a recent master snapshot, then following issue is of relevance: Transmit Power incorrect in snapshot #11902 . Caused by problems in iwinfo. Fixed by http://patchwork.ozlabs.org/project/openwrt/patch/20230130185757.9512-1-a.heider@gmail.com/, but the fix has not reached master snapshots yet. Snapshots up to the date 2023-01-20 should work fine.

Edit: Btw. you are doing a great job with your syncthing fork @Catfriend1 :wink: I use it regularly :slight_smile:

1 Like

I've removed the two settings from my wireless config and now see if it helps :-).

Same problem here: Problem "Connected without internet" on AX mode (Totolink X5000R)

Sorry, no. The problem reoccurs:


The client does not receive anything after connecting to the AP.

Do you know if the fix landed in the meantime? I'm on snapshot 2023-02-05.

What about the short preamble 0 and turning off PMF? Do I need to also test this because in (client) AC mode devices connect fine and stay reliably connected. It's just the problem in AX mode (for the wifi 6 capable devices).

The fix has been merged. Only concern that remains:

dhewg commented Feb 4, 2023

I can reproduce even with my latest not-yet-merged patch. But not on the two ipq radios, just the mt76 one.
But I can also reproduce with iwinfo 00aab871, so none of our patches.
So I guess your reporter tested also with the mt76 radio? Can he/she/them report with recent mt76 bump reverted?

The weird thing is that iw scans just fine. And sometimes iwinfo does too, but on the next run it doesn't. And iw always does. With iwinfo it also always works on the ipq radios.

I can poke it some more tomorrow, but this may be a mt76 regression and iwinfo doing something stupid >(but we didn't touch the stupid part with our patches).

Source: https://github.com/openwrt/openwrt/issues/11902#issuecomment-1416870934.

I personally upgraded to the mastersnapshot from yesterday with my mt7621 + mt7915 + mt7975 device, which uses the mt76 driver (D-Link DAP x1860) and connect to it with my Intel AX200 Windows 10 client and it works fine so far (I wonder for how long :D). I do not experience the issues you describe with the Xiaomi AX3600.

When you are about to download a master-snapshot, have a look at the buildbots and check if your target has already been built with latest commit(s): https://buildbot.openwrt.org/master/images/#/grid

1 Like

Interesting, updated to the latest snapshot today, and ax connection seems to work fine now on two clients I've used. I'll see if it stays like this :).

I'll now put the removed options back in config. The update solved the problem.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.