Xiaomi AX3600: (Client) Intel AX210NGW does not connect to radio1 (IPQ8074 802.11acaxn)

It's strange - I had those "0 bytes received" appearance on multiple notebooks with an AX210NGW adapter the last days. When it occurs, it doesn't go away by itself.

I've now rebooted my two AX3600 units and it started working after setting mode=AX in Windows device manager for the wifi card.


I'll report when it stops working again.

I'll be on the lookout what my be the root cause here... currently I suspect the mesh SSID running in parallel to the SSID where the AX210 clients connect to. This is my config:


config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi'
	option channel '100'
	option band '5g'
	option htmode 'HE160'
	option txpower '23'
	option cell_density '0'
	option country 'DE'
	option disabled '0'


config wifi-iface 'wifinet0'
	option device 'radio1'
	option disabled '0'
	option short_preamble '0'
	option mode 'mesh'
	option network 'nwi_mesh0'
	option mesh_id 'MESH-SSID'
	option encryption 'sae'
	option key 'PSK'
	option disassoc_low_ack '1'
	option dtim_period '1'
	option short_preamble '1'
	option mesh_fwding '0'
	option mesh_rssi_threshold '0'

config wifi-iface 'wifinet1'
	option device 'radio1'
	option disabled '0'
	option mode 'ap'
	option network 'VL177'
	option ssid 'SSID'
	option encryption 'psk2+ccmp'
	option key 'PSK'
	option ieee80211w '1'
	option wpa_disable_eapol_key_retries '1'
	option disassoc_low_ack '1'
	option dtim_period '1'
	option short_preamble '1'

When I played with 160MHz, on the WAX206 (MT chipset using openwrt beta fw) the radio wouldn't even come up if I selected a non-160 channel.


On Xiaomi AX3600, radio1 tries to DFS scan and then throws errors in the end.

Can you show these?

They are here: Xiaomi AX3600: 160 MHz not possible on ch36, radio1 (IPQ8074 802.11acaxn)

  • I don't see errors - I see scans though.
  • Perhaps you should use one thread for your issue.
  • Are you asking for your device to ignore DFS?
  • Are you asking about 20/40/80/160 MHz bandwidth?
  • I see an error about country and you mentioned changing it - please verify you've set the country to the correct/legal setting for your locale

The only legal way I know for you to ignore DFS - is to move to another country that doesn't require DFS scans. Perhaps I'm missing something.

It's not about ignoring DFS. This thread is about wifi clients not able to connect via AX but only AC. This occured again some minutes ago and I don't understand why. It happens with HE80 or HE160 mode.

I have 5 SSIDs + 1 802.11s network all on one radio on my 301w with no issues connecting any clients, so I don't think your mesh net is an issue.

IIRC, 160MHz will always need a DFS channel to work (not sure about 80+80) as there is not anywhere on the spectrum 8 contiguous 20MHz channels outside DFS.


Thanks for sharing your experience :). So it's wrong to suspect the mesh. Came to this as a radio restart with unconnected mesh partner allowed to connect via AX. I'm currently totally compliant with dfs rules and using the correct country code so it's also not the client with a mismatched country.

I must have been unclear - or there's a misunderstanding on how it's related to DFS.

So - can you provide your current config (or just link to the post that contains them).

I see.

Do not scan for overlapping BSSs in HT40+/- mode.
:!: Turning this on will violate regulatory requirements!

From: https://openwrt.org/docs/guide-user/network/wifi/basic

Are you following all regulations?

I believe this will work...but why?

All devices support this?


Good point. in regards to the short preamble, this should really only be used if you have a perfectly clear enviornment, otherwise clients may have a hard time syncing. Otherwise, short preamble can slightly reduce sync times and therefore latency.

The ieee80211w option set to 1 means Protected Management frames are optional, so shouldn't be an issue.

These options might be the culprit:

option wpa_disable_eapol_key_retries '1'
option disassoc_low_ack '1'

Would kick off devices if the signal is weak or if there's multi authentication retries. Try removing those?


Thank you two for the feedback... :slight_smile: I'll try your suggested config improvements and then report back :slightly_smiling_face:. Indeed, I'm living far outside town so there are no other wifi access points competing in range.

If you are using a recent master snapshot, then following issue is of relevance: Transmit Power incorrect in snapshot #11902 . Caused by problems in iwinfo. Fixed by http://patchwork.ozlabs.org/project/openwrt/patch/20230130185757.9512-1-a.heider@gmail.com/, but the fix has not reached master snapshots yet. Snapshots up to the date 2023-01-20 should work fine.

Edit: Btw. you are doing a great job with your syncthing fork @Catfriend1 :wink: I use it regularly :slight_smile:

1 Like

I've removed the two settings from my wireless config and now see if it helps :-).

Same problem here: Problem "Connected without internet" on AX mode (Totolink X5000R)

Sorry, no. The problem reoccurs:


The client does not receive anything after connecting to the AP.

Do you know if the fix landed in the meantime? I'm on snapshot 2023-02-05.

What about the short preamble 0 and turning off PMF? Do I need to also test this because in (client) AC mode devices connect fine and stay reliably connected. It's just the problem in AX mode (for the wifi 6 capable devices).

The fix has been merged. Only concern that remains:

dhewg commented Feb 4, 2023

I can reproduce even with my latest not-yet-merged patch. But not on the two ipq radios, just the mt76 one.
But I can also reproduce with iwinfo 00aab871, so none of our patches.
So I guess your reporter tested also with the mt76 radio? Can he/she/them report with recent mt76 bump reverted?

The weird thing is that iw scans just fine. And sometimes iwinfo does too, but on the next run it doesn't. And iw always does. With iwinfo it also always works on the ipq radios.

I can poke it some more tomorrow, but this may be a mt76 regression and iwinfo doing something stupid >(but we didn't touch the stupid part with our patches).

Source: https://github.com/openwrt/openwrt/issues/11902#issuecomment-1416870934.

I personally upgraded to the mastersnapshot from yesterday with my mt7621 + mt7915 + mt7975 device, which uses the mt76 driver (D-Link DAP x1860) and connect to it with my Intel AX200 Windows 10 client and it works fine so far (I wonder for how long :D). I do not experience the issues you describe with the Xiaomi AX3600.

When you are about to download a master-snapshot, have a look at the buildbots and check if your target has already been built with latest commit(s): https://buildbot.openwrt.org/master/images/#/grid

1 Like