Xiaomi ax3600 bricked

i renamed the file to all that and others names and i used over 10 ethernet cables but no luck with any tools tried on ubuntu but no luck too only thing that i didnt tried is uart serial

I ordred this on amazon it has 1.8v can you plz guide me on how to flash the fw using serial , thank you so much


It seems you have a soft-bricked router with open recovery paths through TFTP or UART. The methods are fairly generic and not specific to the AX3600. You'll find examples in other forum threads, the Wiki (other models have somewhat generic button-press and UART-driven TFTP recovery hints too) or via Google.

What I described above worked for me and so I've never needed to learn other things. Sorry I can't be of more help. Please do document your outcome here in any case - it'll help others.

Thank you so much you did help a lot , i will share my experience when i receive the adapter, can you post a link of a video plz

there's a bunch of TFTP related posts in the old AX3600 thread, you should probably start by reading those.

1 Like

There is no serial unbricking one

TFTP output can only be read/accessed through serial.

Yeah so after getting the requested file by serial connection i have to rename the fw to it and flash it using tftp64 program . Right?

Sound about right, or manually via uboot if console access works.

Can you please link me to the procedure of flashing via uboot , thank you a lot

You don't need it, you only need to see the file name, when it tries to do it, so you can name it accordingly.

And it's already there, in the thread you said you've read Adding OpenWrt support for Xiaomi AX3600 - #3691 by ajw107
But uboot access would require writable console, which I assume you don't have, so automagic tftp is your only easy way forward.

Tank you bro but this for linux and imna windows user

you should probably reread my last post.

I already renamed it to that and many other names like i already said but no luck , can you plz do it remotely for me i can buy you a coffee :grin:

Plz guys help me i bought the uart adapter and linked it to my serial port on the ax3600 following the schematics on it but when powering the device the led doesn't power and nothing happens on the putty programme i tried dozens of times the adapter is new all drivers are ok and the rate is at 115200 i dont know why nothing working for me !! , Could it be a hardware issue with the router? Plz guys help me plzzzz

Is the UART adapter 1.8V?
If not then the SoC got fried most likely.

It is a 1.8v bro and before doing anything i set it to that

I think you have the TX and RX reversed, usually you want to connect the adapter TX to router RX.

I already reversed them i did everything but nothing worked