Xiaomi ax3600 bricked

Hello guys
My brand new xiaomi ax3600 cn version got bricked i think due to current cut during automatic update!!! Now it has an orange amber light and when trying to press reset and power on after 8 or 10 seconds its start blinking for 2 or 3 second , i tried the repair tool and tiny pxe but nothing happened i think the uboot is messed up , so can ibunbrick it using a 1.8v uart adpater ? If yes can anyone provides help on how ? For info ibhave a ch340a programmer is this router have thos eight legs chips ? Tthank you so much

1 Like

you should probably check https://forum.openwrt.org/t/adding-openwrt-support-for-xiaomi-ax3600/

1 Like

I read all the comments before opening this thread , there is no explanation on how the unbrick this router via uart serial, im a noob and i would appreciate a video or tuttorial on how to do it , thank you so much

if no one's done it, there's not going to be a tutorial, is there ? catch 22 ....

you should still post in the thread, since it's where most of the AX3600 users would hang/read.

1 Like

There also is a device page on the wiki…

1 Like

As long as you see some flashing LED in response to pressing the button, I believe the TFTP method described on the OpenWRT wiki will work OK for you: https://openwrt.org/inbox/toh/xiaomi/xiaomi_ax3600

No need to use UART and crack the case open. As with many (most?) routers, it's the bootloader responding to the button press and running a TFTP client recovery process. This is almost unbrickable unless you've erased the bootloader.

Xiaomi has an automatic/guided TFTP server Windows tool for this which I've used multiple times on my AX3600 (http://www1.miwifi.com/miwifi_download.html). Chinese-only, but I've never had a problem clicking through. Look on YouTube for Mi recovery videos in English if necessary, or read the Wiki. You just feed it a firmware file (e.g. http://cdn.cnbj1.fds.api.mi-img.com/xiaoqiang/rom/r3600/miwifi_r3600_firmware_5da25_1.0.17.bin, from the Wiki), and choose your Ethernet interface from the list.

Timing is important. It might take a few goes. You can leave your PC in the TFTP-ready state throughout. You'll know it has worked OK once you see a pop-up TFTP transfer window on the PC for a few seconds. The LEDs on the AX3600 will then do something for a while, then something else (can't remember), after which you can power cycle and let a factory-fresh copy of the original firmware boot. Probably about 1 minute in total. Interrupting any of this process won't make things worse, but you might have to restart. The 1.017 firmware linked is a suitable starting point for opening SSH as described in the Wiki.

Edit: also, you can't use a CH-style programmer on this device in any case. The flash is raw parallel-bus NAND rather than SPI-bus NOR. BGA too, I think.

1 Like

Unfortunately the thread is closed if it wasn't i would never open a new one , thank you for your responses .

Thank you so much for your time , i already followed all of this and tried it moore than 50 times on windows 11 and 10 and two differents pc's and using tftp tiny pxe and xiaomi repair tool someone in the thread said that the device must blink 5times twice and mine blink only one so if i can do the serial uart thing i will im good at hardware but software im a little noob on routers and tftp . Thank you so much again


This will be a stupid question but... Did you connect your PC to witch port on the AX3600.
I also encountered the same problem and was able to repair using the Linux method.


.... and make sure the FW's disabled on the system hosting the TFTPd.

1 Like

I dont get what firmware are you talking about ?

Can you share it the procedure plz ?

Fw is in this case firewall.

1 Like

I did it and even uninstalled the antivirus but 'o success , can you plz link me to the linux procedure poz .thx

Now ip getting this !!!

Im getting thos now i triee woth tftp64 /32 too im out of options now !!! Plz help me

The log shows a DHCP client requesting an IP from PXE server. MAC address is 88-c3-97... - which is a Xiaomi device. I guess that means the AX3600 is attempting TFTP boot - great!

I don't know "Tiny PXE Server", but I'm not seeing a file request in the log. Maybe it doesn't show it? In any case, I doubt it's offering the correct filename to the router. From the OpenWRT Wiki, the AX3600 will request <filename>.bin, where filename is a hex encoding of the IP that you assigned it using DHCP.

It's up to you to ensure that your PXE server is offering a filename appropriate for the you assigned via DHCP.

I you are unsure how to diagnose and debug any of this, I suggest dropping back the Xiaomi tool again as it takes care of everything for you. Try it more times. Try varying your button press & release timing. Try waiting longer. I've done this recovery at least five times on three different units and generally took a few tries to get a successful trigger.

I tried the xiaomi repair tool over 50 times with differents combinisation and tried all the router ports 2 differents pc's with win7 and win10 , the assignedbip is i renamed the file to test.bin and put it in the tiny pxe folder , can you plz assist me via teamviewer if you can i'll be so gratefull

I can't help via teamviewer. I'll just again say that 'test.bin' is incorrect. In the OpenWRT Wiki the example has the router on, where it apparently requested C0A80B64.img. It's nice to use a TFTP server which shows the requests - so that you don't have to compute/guess.

Failing that, according to the Wiki what you need is (e.g.): = C0A81F64.img = C0A81F65.img
... = C0A81F6F.img (this is what you showed in the screenshot)

How can i use the tftp server to figure out which one is requested cause i tried the tftp64/32 app but nothing is showed in the log window