Xiaomi AX3200 seamless network like “mesh”

Hi
I have two Xiaomi AX3200 routers with openwrt. Please tell me how to configure seamless wireless network. I did it using stock Xiaomi firmware and it was pretty simple with two clicks. Routers were connected wirelessly.

How to configure the same with openwrt? WDS, 802.11 r/k/v? What setting should I make ?

configuring 802.11r should suffice.

I still use Dumb AP with linksys e8450 / Belkin RT3200 occasionaly client associates but no connectivity - #4 by frollic for my APs.

Just set same access point name and auth on all radios, most modern devices will seamlessly roam. For mid-aged ones you may need like usteer.

@brada4 @frollic
How exactly should i connect routters between each other wirelessly?

How exactrly i should configure it?

Well, i have like 80 wi-fii devices including new, old devices, smart home / iot devices, i would like to setup reliable solution

Read your IoT documentation. Especially if any of them supports any mesh network (hint : they dont)

from device perspective simple wireless network and mesh networks look the same, i mean that i need reliable network without surprices :slight_smile: looks like offtopic :slight_smile:

  1. Use WDS as your wireless backhaul. WDS is simple to setup no different than standard AP except the only difference is one of your AX3200 will be set to WDS AP and the other AX3200 will be set to WDS Client i.e. WDS is a peerless connection.

  2. Put the WDS AP and Client backhaul on the 5GHz radio and have the 2.4GHz radio serve the clients.

  3. The most important thing in your setup is the backhaul connection must be reliable and fast i.e. clear line of sight for the signal and proper channel selection (pingtools on android is a great tool). That means careful placement and adjusting the antennas. Once the antennas are adjusted place some putty on them to keep them from being shifted out of place.

1 Like

I'm trying to follow this article https://openwrt.org/docs/guide-user/network/wifi/atheroswds. I'm stuck on this:

The ip address command should display a new network interface whose name is in the form of: “wlan.staN”; where N is a number. This new interface must exist alongside the base “wlanN” wireless network interface. For example, if you get the “wlan.sta1” network interface, the base interface is “wlan1”.

Nevertheless i have
11: wl0-ap0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP group default qlen 1000 link/ether 8c:de:f9:bf:..... brd ff:ff:ff:ff:ff:ff
and
13: wl0-ap0.sta16: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UNKNOWN group default qlen 1000 link/ether 8c:de:f9:..... brd ff:ff:ff:ff:ff:ff inet6 fe80::8ede:f9ff......./64 scope link valid_lft forever preferred_lft forever
Is it ok?

Then

Note: The new wlan.staN interface will not be bridged by default with the originating WLAN interface if that interface is not itself part of a bridge. To correct this problem, you will need to create a new bridge interface in the wireless access point and associate only its WLAN interface to it.

So i created device br-lan2, if i attach to it wl0-ap0 or wl0-ap0.sta16 router freezes and i wait till reverting changes (i mean bad config)
image

What i do wrong?

Undo you settings!

  1. On access point 1 go to wireless and create WDS AP and add to bridge BR-LAN.
  2. On access point 2 go to wireless and create WDS Client and add to bridge BR-LAN. Make sure SSID, password, encryption is same as step 1.

Your backhaul is now complete! Wait for the access points to connect then SSH into one of the access points and you should be able to ping the other one.

1 Like

Let me clarify. Here's my wireless interfaces configuration and selected by default LAN as a network.
image
Here’s bridge device settings and there are not any WiFi interface
image

However, in interface settings i can select wireless network, but this doesn’t work for me, I need both (2,4 GHz and 5 GHz) bands and also i need LAN ethernet ports to be bridged.

So how to add WDS AP to bridge BR-LAN in my case?

if you go to the wireless page where you defined your SSID you will be able to select LAN which will bridge the wireless adapter to br-lan.

@papdee this?
image

yes. the LAN is the interface to your bridge br-lan device.

Roaming (802.11r)
The trick is that most manufacturers will sell you a proprietary "mesh" where if you buy other routers from their brand, they will inter-work easily. Actually, they're mostly just using open standards like 802.11r/s, but hiding the config for them in their interface.
For my network (once I'd read I didn't really need mesh, just roaming), I only needed 802.11r spread between a few OpenWRT boxes (set as dumb APs). If you can run an ethernet cable between the routers it would be best.
All you need is for the same SSID to be used and then under "WLAN Roaming" select "802.11r Fast Transition" and make sure the "Mobility" domain has the same 4 character hex string on each.
I found this video a really useful background to not only go through step by step, but also explain why.
Mesh (802.11s)
If running a cable between them is not possible, then you can use mesh though less overall WiFi bandwidth will be available for your devices as it will be used for backhaul between the routers. I didn't end up using mesh, but the same guy has loads of OpenWRT videos including mesh in his channel that might be worth a look.

I have recently solved a very similar challenge.

Having the VLANs for Home/IOT/Guest etc may take a bit more work, but it was worth doing properly. This is an excellent background on VLANs in OpenWRT. Most likely you could just copy his config and it would probably 90% fit your needs. However, it's also good to get the explanations and background info so you can apply it to your own needs better.

In my case, I was able to get a decent setup that did what I needed, improved my understanding of the tech and cost me a few weekends of messing about. I would recommend having a look at the videos and hope they can help you too.