Xiaomi AX1800 dumb AP and guest vlan/wifi

I hope I am posting in the right section.

I have 3 AX1800 that act as dumb APs, connected via wire to a central router with OpenWRT that serves all the routing functions and the DHCP. I separated the traffic in different VLANS (VLAN 1 and VLAN 3) one for regular traffic and one for guests. The problem is that if a client connects to the guest SSID, it does not get an IP address unless I create a dedicated DHCP for the guest network on each dumb AP (which I do not want, as there is the main router doing DHCP). If I add the dhcp config on each dumb AP, the guests client can connect, but I cannot get to the internet. I have exactly the same set up on another Xiaomi 4A OpenWRT dumb AP and it works flawlessly. I suspect it might have to do with the port allocations on AX1800 and switch config, as I believe I haven’t figured out the ports and interfaces correctly. Would anyone be able to help me out? Thanks

What I added to the config of the dumb APs. Everything else is standard config.

network:

config interface ‘guest_lan’
option proto ‘none’
option type ‘bridge’
option ifname ‘eth4.3’
option stp ‘1’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option vid ‘1’
option ports ‘2 3 4 5t’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option ports ‘5t 7t’
option vid ‘3’

wireless:

config wifi-iface
option device ‘wifi1’
option ifname ‘wl10’
option network ‘guest_lan’
option mode ‘ap’
option wpsdevicename ‘XiaoMiRouter’
option intop ‘1’
option macfilter ‘disabled’
option ssid ‘Guest_SSID’
option key ‘secure_password1234’
option disabled ‘0’
option encryption ‘psk2’
option hidden ‘0’
option bss_transition ‘1’
option ieee80211k ‘1’
option ieee80211v ‘1’
option ap_isolate ‘0’
option maxsta ’20'