Xiaomi AIoT AX3600 lower speed after bridging from modem

My ISP plan's rated speed is 650 Mbps. Whenever I get internet straight from the GPON terminal (Huawei OptiXstar HG8145X6), my speed test results reach an average of ~700 Mbps (Ethernet connection to PC). However, when I put the GPONT to bridge mode and use my router (Xiaomi AIoT AX3600) to connect to the internet, my speed test results only reach up to an average of ~550 Mbps (still connected via Ethernet).

I'm using OpenWrt Snapshot on the router (I followed the instruction for installation found here).

Here's how the network is configured in OpenWrt:

network.@device[0].ports='lan1' 'lan2' 'lan3'
network.lan.dns='' ''
network.wan.dns='' ''
network.wan6.dns='2606:4700:4700::1112' '2606:4700:4700::1002'

Is there anything else I should configure to achieve the same speed as when not bridged?

PS: I only know surface level networking stuff. So please be patient with me if I do not immediately understand some terms.

install and run htop via cli, check the CPU load while maxing out the connection.

Here's the result. The 0 at the upper left corner tops out when doing the speed test. How should I interpret this?

you're maxing out one of the cores, and I don't think the stock irqbalance works for the IPQ8071A platform yet.
you could try this one though, different router, same SoC.

Sorry, how exactly should I "try" it? I clicked on the link but don't understand how to execute the first step. I do know what the next 2 steps are (enabling and starting).

Also, if anything goes wrong and I want to revert to the previous configuration, I can simply restore a backed-up configuration via the web UI right?

And thank you for taking time on my issue.

EDIT: I checked the installed packages, it seems that there is no irqbalance installed on my OpenWrt instance. Should I try that first?

use winscp to connect to the router, and create the file with the content from the post.

then connect to the device using putty, enable and start it, using the two service commands.

no need, just do service disable and service stop, then delete the file.

knock yourself out, but AFAIK, it doesn't work.

I did the irqbalance-manual but still the same issue. The other cores aren't firing up.

There was no error posted when you tried starting it ?

Yes, there weren't any errors.

Btw, I did more testing.

On ethernet: Speed has increased by around 50 Mbps. But still not reaching same speed vs connected directly to ONT. Still only one core doing most of the work.

On wireless: When doing speed test from my smartphone, htop shows that all cores are being utilized (especially during upload). The speed however is very low relative to wireless via ONT (200+ Mbps vs 700+ Mbps). Not sure if this is a different issue altogether.

Update: I switched to the qualcommax/ipq807x firmware and did the whole irqbalance-manual thing again. Still the same results.

There was no error posted when you tried starting it ?

Sorry, my memory failed me earlier. At first, there was an error (Permission denied). But changing the permissions properties in WinSCP fixed it for me and I was able to enable and start it without issue.

This fixed it for me:

Luci --> Network --> Interfaces --> Global network options --> Enable "Packet Steering"
With irqbalance-manual enabled/active.

Wifi speeds also improved!

Thanks for leading me into the right direction (i.e. CPU bottleneck)!

Keep in mind that ipq807x has rather inefficient networking drivers for now (and it will take a long time for this to improve, if at all), as it's designed to be used with NSS offloading in mind (which will 'never' become available for OpenWrt), that and your need for the very CPU intensive PPPoE protocol does limit your maximum routing throughput quite considerably (and compared to ipq8072a+ running at 4*2.2 GHz, the ipq8071a SOC of your ax3600 is only clocked at 4*1.4 GHz, which doesn't help either). The values you're achieving are roughly in line with expectations, this is the most your ipq8071a device can do - and that won't improve anytime soon (as it would require really hard ethernet-/ switch driver development without any kind of hardware documentation being available).

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.