Xiaomi 4A router with OpenWrt forwarding

I successfully installed OpenWrt in Xiaomi 4A router following instructions from here.

The previous setup is to have the Xiaomi router get internet from wireless (from my main router), then provide via ethernet cable internet to a PC. Xiaomi router doesn't support IPv6 that's why I tried OpenWrt.

Now, OpenWrt is installed but I am not able to have the same subnet in my PC as my main router.

What I did after reset:

  • Network -> Wireless -> Scan both wlan24 and wlan5 for my wireless, found, added it. It has two new entries in "client" mode.
  • Network -> Interfaces -> LAN -> it has a static of and it assigns my PC that subnet, say (how does this get internet from my Wlan?).

When I put this static to and disable DHCP server, then the router is no more accessible, I have to reset it through the button.

Is the configuration I 'd want possible with openwrt?

Thanks a lot.

I found this one https://openwrt.org/docs/guide-user/network/wifi/relay_configuration
and configured the relay successfully.

Now it remains to make the wlan working...

You were using 'repeater' mode with Xiaomi stock firmware.

Unfortunately, OpenWrt does not offer true 'repeater' mode as offered by xiaomi stock firmware.

There is 'relayd'

Also, you should not connect both 2.4 and 5 GHz wlans to your main router simultaneously.

Thanks for your message. Yes I changed to connecting with wlan 5 to my main router and the 2.4 one is used as an access point, it works.

Im trying to see if I can work with ipv6.

No, you won't be able to use IPv6 if you're using relayd (and relayd is required based on your wireless uplink).

EDIT: looks like I was wrong here... read on for the OPs solution.

According to https://openwrt.org/docs/guide-user/network/wifi/relay_configuration there's some options for ipv6, I added a DHCP v6 interface which got an IPv6, now I 'm stuck at the "uci set dhcp.wan.interface=wwan", there is no dhcp.wan entry.

It worked.
I had to manually place to the dhcp configuration

config dhcp 'wan'
option interface 'wwan5'
option ra 'relay'
option ndp 'relay'
option master '1'
/etc/init.d/odhcpd restart

and it worked. IPv6 traffic is there.


The last post in this thread seems to indicate IPv6 success, but the rest of the thread says it won't work.

Cool! I've learned something!