Xiaomi 4, 4a, 3g and Fast Transition

Hi,
I've surrender trying to solve it myself and signed up here.
My configuration is xiaomi 4a gigabit as entry point from ISP with WiFi disabled. Xiaomi 3g and Xiaomi 4 connected to it by cable. I wanted to make fast transition network with it. Testing it with OnePlus 9 and audio streaming and voice/video calls. The problem is when phone changes AP with better signal, my connection drops for about 1-2 minutes and only after that time streams get back. If I get back to first AP and phone connects to it, stream gets back simultaneously. I understand that connection to new AP needs some time but don't think it should be that much.
My configs for both AP I expect to work with FT:

config wifi-device 'radio0'
      option type 'mac80211'
      option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
      option band '2g'
      option htmode 'HT20'
      option cell_density '0'
      option channel '1'

config wifi-iface 'default_radio0'
      option device 'radio0'
      option network 'lan'
      option mode 'ap'
      option ssid 'xxx'
      option key 'xxx'
      option dtim_period '3'
      option encryption 'psk2'
      option ft_over_ds '0'
      option time_advertisement '2'
      option time_zone 'GMT0'
      option ieee80211r '1'
      option ieee80211v '0'
      option ieee80211w '0'
      option log_level '3'
      option mobility_domain '1234'
      option ft_psk_generate_local '1'
      option wmm '0'
      option logger_syslog_level '1'
      option reassociation_deadline '15000'

config wifi-device 'radio1'
      option type 'mac80211'
      option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
      option band '5g'
      option cell_density '0'
      option htmode 'VHT40'
      option channel '36'

config wifi-iface 'default_radio1'
      option device 'radio1'
      option network 'lan'
      option mode 'ap'
      option ssid 'xxx'
      option key 'xxx'
      option dtim_period '3'
      option encryption 'psk2'
      option ft_over_ds '0'
      option time_advertisement '2'
      option time_zone 'GMT0'
      option ieee80211r '1'
      option ieee80211v '0'
      option ieee80211w '0'
      option log_level '3'
      option mobility_domain '1234'
      option ft_psk_generate_local '1'
      option wmm '0'
      option logger_syslog_level '1'
      option reassociation_deadline '15000'

In logs I see that FT occurs:

Thu Apr 13 11:28:48 2023 daemon.err hostapd: nl80211: kernel reports: key addition failed
Thu Apr 13 11:28:48 2023 daemon.debug hostapd: wlan1: STA 3e:xxxx:54:8a IEEE 802.11: binding station to interface 'wlan1'
Thu Apr 13 11:28:48 2023 daemon.debug hostapd: wlan1: STA 3e:xxxx:54:8a IEEE 802.11: authentication OK (FT)
Thu Apr 13 11:28:48 2023 daemon.debug hostapd: wlan1: STA 3e:xxxx:54:8a MLME: MLME-AUTHENTICATE.indication(3e:xxxx:54:8a, FT)
Thu Apr 13 11:28:48 2023 daemon.debug hostapd: wlan1: STA 3e:xxxx:54:8a IEEE 802.11: association OK (aid 1)
Thu Apr 13 11:28:48 2023 daemon.info hostapd: wlan1: STA 3e:xxxx:54:8a IEEE 802.11: associated (aid 1)
Thu Apr 13 11:28:48 2023 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 3e:xxxx:54:8a
Thu Apr 13 11:28:48 2023 daemon.debug hostapd: wlan1: STA 3e:xxxx:54:8a MLME: MLME-REASSOCIATE.indication(3e:xxxx:54:8a)
Thu Apr 13 11:28:48 2023 daemon.debug hostapd: wlan1: STA 3e:xxxx:54:8a IEEE 802.11: binding station to interface 'wlan1'
Thu Apr 13 11:28:48 2023 daemon.debug hostapd: wlan1: STA 3e:xxxx:54:8a WPA: event 6 notification
Thu Apr 13 11:28:48 2023 daemon.debug hostapd: wlan1: STA 3e:xxxx:54:8a WPA: FT authentication already completed - do not start 4-way handshake

I've made some experiments with 802.11k/v, generating key locally and setting reassociation_deadline to 15000 and 20000 with no luck.
Appreciating any help, thanks in advance!

1 Like

You can try DAWN.

1 Like

I've tried but not sure configured it right. Maybe next time will try again but for now I want to figure out why it doesn't work with FT.

I've also tested with iphone and it seems to be faster. About 10 seconds taken to restore online radio stream. And one more thing. Transitioning from one band to another within one AP works with minimal delay in online radio listening.

I'm very close to surrender and buy couple of keenetics. But still hoping to get some help. I've updated to 23.05-rc, reset wifi settings again with no luck. It seems like I'm missing some important option for session roaming or something like that since connection works fine. But online radio and wifi calls keep losing connection for 1-2 minutes which looks like timeout for session restart. Double checked dumb AP configuration, but everything seems fine. No idea what to check next or how to debug it

Which version have you tried before? There's still the DSA bug that could cause a behavior that is similar to what you've described. If you haven't tried a non-DSA build that might be worth a shot.

Ssh into a dmesg should give some pointers, what's doing DHCP on the network?

Have you tried moving all the way to snapshot, which country are you in, are all access points on 2.4ghz channel 1 and 5ghz channel 36?

Previously it was 22.03.3 and 22.03.4.
Reading description I'm not sure it is related problem. But I'm ready to test everything :slight_smile: How to get non-dsa build or is there any guides for that?

UPD: I've checked, no VLAN filtering is enabled for any of 3 routers. Looks like this DSA bug should not affect my configuration.

I'll try to check it. I've tested same channels for all AP's with no luck too.
DHCP is enabled only on the main router. Not getting what you mean by moving to snapshot. Could you explain please?

22.03 should be old enough to not use DSA yet.

Regarding docs DSA is used since 21.02

1 Like

if you are comfortable in the command line, moving to snapshot will put you on the latest firmware etc, and we could go through debugging what is causing the hold etc.

I'm ready to try :slight_smile:

Well, I've decided to try reset for 23 version with no success. After that I've downgraded both AP and ISP AP to 21 version. Configured it same way and everything works fine. No drops when roaming and fast transition works fine. The only difference between 21 and 23 config is NAT offloading. Without it set at ISP AP I had bad speed. With it enabled in 22 version I've got 500 mbps as it should be and kept it for 23. Probably it could affect roaming but for now I don't want to test anymore. Will keep it that way for now with 21 version.

1 Like