Xiaomi 3G (MIR3G) - Breed bootloader - Configure Dual boot OpenWrt / PandoraBox / Padvan

Got the xiaomi dev ssh firmware to boot but openwrt still has issues.
Here are the logs if interested (i'll look at them later)
Flashing via the steps then rebooting- https://pastebin.com/KE1P04n4
Normal reboot with debug level 4- https://pastebin.com/XDdjqLb1
Stops at "init done" everytime after kmod kernel modules are loaded then the device basically halts. Can get into failsafe mode of openwrt but since my isp is PPPoE, cant use it and inbuilt commands to download and upgrade via it.

Does this also work for xiaomi-r3 (mt7620a device) Router which should be the same hardware than xioami-mi-mini? There is an bootloader for the mini-device on hackpascal's site.

Mini - SPI flash
3 - NAND

but you can try...

Thank you very much, I'll try it next week when I am home again. But are you sure I can use the Breed of Mini? - How's the performance of your device with openwrt or padavan? - Actually I thougt about to just extend my wifi of my 7490 with wwan and use the mir3 as a client-bridge through wifi. - It means I hope to solve the 100Mbit/s issue of the wan/lan ports through higher wifi speed. Of course this requires finally a good driver support for MT76x2e under openwrt! - Any experiences with it?

I also thought about this breed: https://breed.hackpascal.net/

Hi @tr4usut, Do you able to fix your dead Lan Port? How do you fix it? am also facing a dead Lan port.
Im on lede/owrt with stock bootloader. Hope anyone can help, Thanks

Hello, Just wanted to update my current issues with dead LAN/Ethernet port.

My suspicion was true, It was a HW related issues in regard to power failure during boot. I may have get a bad power adapter unit or simply the stock power supply just insufficient to power up the router.

So I use another power adapter rated 12v2a (stock 12v1.5a) from my old router, and to my surprise the LAN back alive again. I immediately initiate for Stock Recovery just in case, boot up stock xiaomi firmware and did power cycle the router for like hundred times :laughing: everything went well, no more dead LAN.

For the sake of trying, for now im on Padavan with Breed on bootloader. So far it's really stable I would say, the wifi signal and throughput gain much improvement (Maybe because of a slight powerful adapter?:thinking: idk ) Might going to try Overclocked Padavan on this bigger power adapter.

Just waiting for the LAN to fail again (wish dnt happen again) Thanks

I messed up, instead of installing Breed I ended up following the tutorial and installed the rOOter OS.

So trying to figure out what I did. I ran into SSH and followed the steps

"Breed Download
wget--No-check-certificate https://breed.hackpascal.net/breed-mt7621-xiaomi-r3g.bin-O/tmp/breed-mt7621-xiaomi-r3g.bin

Important! Check MD5 sum and compare to https://breed.hackpascal.net/md5sum.txt 4
Md5sum/tmp/breed-mt7621-xiaomi-r3g.bin
If MD5 mismatch-do not flash (maybe file is broken, etc)

Flash Breed
MTD Write/tmp/breed-mt7621-xiaomi-r3g.bin Bootloader "

But I could not conclude because I had an error message something like MTD could not be written.

I tried to download the develop firmware, renamed it to Miwifi. bin, put on the USB stick and gave the boot again holding the reset to try to return the stock ROM.
It was just flashing the blue Led, and after a few minutes I took it. When I looked at the WiFi was like ROOter OS yet, but it did not respond more on the IP.

I tried to redo this attempt to return the stock ROM, but have not succeeded the LED gets flashing in blue color, and when I turn it is with the IP 192.168.1.1 but now without SSH, and without web interface.

Any suggestions what I can do to fix my mistake?

Before doing this nonsense, I had set up my PPoE and it keeps working, I had not configured the WiFi so the name continues as ROOter and I do not know what the password is.
However I do not have Web Access on IP 192.168.1.1, nor via SSH using Putty

Check with the support channels for ROOter and Breed, neither of which are supported by OpenWrt itself.

I ended up screwing up and installing rOOter, do you know how I can do to revert and install Breed?

I managed to retrieve the Web access and SSH, entering the recovery mode of OpenWRT

Upgrade to OpenWrt 18.06 via web interface, download and put Breed to /root
Flash Breed:

opkg update
opkg install kmod-mtd-rw
insmod mtd-rw i_want_a_brick=1
mtd unlock /dev/mtd0
mtd -r write /root/breed-mt7621-xiaomi-r3g.bin Bootloader
reboot

Now you can boot Breed (hold reset button and plug power) and flash stock firmware or Padavan firmware.

I got some erros.

  1. root@ROOter:~# opkg install kmod-mtd-rw

  2. Installing kmod-mtd-rw (4.14.63+git-20160214-1) to root...

  3. Downloading http://downloads.openwrt.org/releases/18.06.1/targets/ramips/mt7621/packages/kmod-mtd-rw_4.14.63%2Bgit-20160214-1_mipsel_24kc.ipk

  4. Collected errors:

    • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-mtd-rw:
    •  kernel (= 4.14.63-1-582c8de664525562eab4782d5d680421) *
      
    • opkg_install_cmd: Cannot install package kmod-mtd-rw.
  5. root@ROOter:~# insmod mtd-rw i_want_a_brick=1

  6. Failed to find mtd-rw. Maybe it is a built in module ?

  7. root@ROOter:~# mtd unlock /dev/mtd0

  8. Could not open mtd device: /dev/mtd0

  9. Could not open mtd device: /dev/mtd0

  10. root@ROOter:~# mtd -r write /root/breed-mt7621-xiaomi-r3g.bin Bootloader

  11. Could not open mtd device: Bootloader

  12. Can't open device for writing!

The full log as on Pastebin, because im a new member.
https://pastebin.com/KeqFRyY5

ROOter != OpenWrt -- you need to install from whatever repos ROOTer provides.

Neither ROOter nor Breed are parts of OpenWrt and need to be supported by their respective resources (which this is not).

1 Like

You repeating me the obvío doesn't help me at all... I did not go to the forum of Breed or rOOter get help, it was in this forum that I saw the tutorial and ended the following in the wrong way because my fault I admit.
I tried to get help on the topic of rOOter and I could not, and before being rOOter it is an OpenWRT firmware after all.

And now I am with OpenWRT, downloaded the OpenWrt-18.06.4-ramips-mt7621-mir3g-SQUASHFS-sysupgrade. Tar and I did the update by the WEB Interface and I repeated my steps according to the given orientation, but now I have the red LED.

Here's an attempt log to install Breed.
https://pastebin.com/sYFMtxsp

@dartraiden Thank you!
After some trys to reboot my root is working with Breed now.
<3

what can I get rid of this breed thing out of the router forever?

Flash this file to Bootloader via Breed.

MD5: efdd4d3fe0a5876243ac5a0e990134e4

Do not forget to delete autoboot.command option if it is present

1 Like

This one came with AA and can't upgrade to v18 directly, I had to update it only through breed after that I can update any openwrt. however, I don't like breed.

Thank you for your work! Where should I flash it to?

[    0.635764] Crashlog allocated RAM at address 0x3f00000                                                                      
[    0.659144] squashfs: version 4.0 (2009/01/31) Phillip Lougher                                                         
[    0.665850] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.                                            
[    0.680262] io scheduler noop registered                                                                            
[    0.684728] io scheduler deadline registered (default)                                                                                  
[    0.690982] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled                                                        
[    0.698779] console [ttyS0] disabled                                                                                                                       
[    0.723011] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11, base_baud = 1562500) is a 16550A                                                                                      
[    0.732826] console [ttyS0] enabled                                                                                      
[    0.740392] bootconsole [early0] disabled                                                                                     
[    0.753107] m25p80 spi0.0: found s25fl064k, expected m25p80                                                                                                                                               
[    0.758971] m25p80 spi0.0: s25fl064k (8192 Kbytes)                                                                                 
[    0.765605] 5 tp-link partitions found on MTD device spi0.0                                                   
[    0.771372] Creating 5 MTD partitions on "spi0.0":                                                 
[    0.776366] 0x000000000000-0x000000020000 : "u-boot"                                                              
[    0.783346] 0x000000020000-0x00000014c4c4 : "kernel"                                                                                          
[    0.790634] 0x00000014c4c4-0x0000007f0000 : "rootfs"                                                                               
[    0.797890] mtd: device 2 (rootfs) set to be root filesystem                                                                                          
[    0.803788] 1 squashfs-split partitions found on MTD device rootfs                                                                                                                                         
[    0.810261] 0x0000003d0000-0x0000007f0000 : "rootfs_data"                                                                                                                                                  
[    0.817881] 0x0000007f0000-0x000000800000 : "art"                                                                                                   
[    0.824778] 0x000000020000-0x0000007f0000 : "firmware"                                                                                                  
[    0.857797] libphy: ag71xx_mdio: probed
opkg update
opkg install kmod-mtd-rw
insmod mtd-rw i_want_a_brick=1
mtd unlock u-boot
mtd write mtdblock1.bin u-boot

I would recommend keep Breed, because through it you can flash any firmware (stock, padavan, openwrt, asuswrt). Even if openwrt stops bootung at all, you can debrick the router. With the stock bootloader in case of openwrt failure you have to get a soldering iron and use UART.

Thank you thank you.
I guess I should stick with breed.
One of things I complain is that everytime I reboot the router, it goes to breed whatsoever.
i have to autoboot command to reboot it with my firmware.
do you know about this issue?
Thank you again.

much oblidged dartraiden would you care to re-upload the original Uboot mtd1 partition? I would love to have that stored just in case, cuz I already have flashed breed.... thanks in advance, also thanks for clarifying the hexadecimals value for booting partitions, that really really helped me...