Xiaomi 3G (MIR3G) - Breed bootloader - Configure Dual boot OpenWrt / PandoraBox / Padvan

Tks very much. I will try to restore bootloader. I have straight cables. Again, tks you. :slight_smile:

How can I flash stock to one partition (to flash OpenWRT) and Padavan to another? The goal is to have a dual boot system: 1. Padavan 2. OpenWRT. And how do I select which system will be started?

How can I flash stock to one partition (to flash OpenWRT) and Padavan to another?

From Breed bootloader

And how do I select which system will be started?

From Breed bootloader.

0x200000 = partition 1
0x600000 = partition 2

But if you boot to Padavan, you loose stock settings and and vice versa - if you boot into Padavan and reboot to stock, all Padavan settings will be wiped.

2 Likes

Cool!!! - Thanks a lot!

Hi, can I know how to install Breed on Mi Wifi 3G?

From stock firmware?

  1. obtain SSH access. You can use graphical instruction from rOOter firmware (look at xiaomi.pdf inside archive)
  2. instead of flashing rOOter firmware flash Breed
  • download Breed
    wget --no-check-certificate https://breed.hackpascal.net/breed-mt7621-xiaomi-r3g.bin -O /tmp/breed-mt7621-xiaomi-r3g.bin

  • Important! check MD5 sum and compare to https://breed.hackpascal.net/md5sum.txt
    md5sum /tmp/breed-mt7621-xiaomi-r3g.bin
    if MD5 mismatch - do not flash (maybe file is broken, etc)

  • flash Breed
    mtd write /tmp/breed-mt7621-xiaomi-r3g.bin Bootloader

  • unplug power cable, hold reset button on back side, plug power cable. After the blue LED flashes, release the button and go to the http://192.168.1.1

Did anyone manage to get the stable builds to run on breed? I wasn't able to get it booting and via serial found it stopped after "init done" and then the router would go dead (temp) and had to turn off & back on again, tried to flash a merged kernel1+rootfs0 image from 4pda forums, only for it to result in erasing the default MAC addresses.
Now luckily had a backup of all MTD partitions from OpenWRT before I installed breed so got the bootloader back, but still can't get OpenWRT installed, resulting in the same error. I'd like to restore all the MTD partitions but I thought to ask for a method before trying it and maybe corrupting the u-boot itself.

I can either-

  1. Install breed, make a combined binary image from the backups and do full firmware flash via it such that breed won't install itself again, but the normal u-boot will be overwritten and if it fails then basically a near dead router unless soldering stuff, with SPI boot to try. another issue is how to combine the binary backups I have to a single image? I could try to make a new script from the merged binary script from 4pda, but I'd like assurance since it'll be the first try.
  2. Using the u-boot that is present now, restore all the partitions back. Not sure if I can via tftp or Kermit uart commands and how to flash it. I'll need full flash over read-only partitions as well since my MAC is gone & only there via backup.
  3. Using breed again but to first flash the other partitions if uboot doesn't allow a flash of read-only partitions, then restore the uboot and reboot.

OR
Get OpenWRT (snapshots?) to work/flash from breed and boot to connect. Then use breed to restore the MAC backups.

Restore to stock dev Xiaomi firmware with breed; get ssh access and dowload openwrt firmware to usb.
flash by these command:
mtd write / extdisks /sda1 /mir3g-squashfs-kernel1.bin kernel1
mtd write /extdisks/sda1/mir3g-squashfs-rootfs0.bin rootfs0
mtd of erase kernel0
reboot

Dont use command on openwrt homepage after install breed, it will not work

Did that in past but didn't work. Might've not done properly.
So flash the xiaomi dev on first partition 2 then partition 1 via breed, then boot normally and use mtd right?
I may have found the MAC i had by bdata & config backup i had using hex editor. So maybe that won't be needed to flash & can just set values by breed.

Also what do u mean by command won't work? The UART connection or the SSH? If it won't then what about snapshots cuz they require terminal & "opkg depends" & "opkg whatdepends" type commands won't be able to be used

Restore to stock and upgrade to Openwrt like instruction this page: https://telegra.ph/Xiaomi-Router-3G-proshivka-LEDE-11-23
It work for me.

2 Likes

Got the xiaomi dev ssh firmware to boot but openwrt still has issues.
Here are the logs if interested (i'll look at them later)
Flashing via the steps then rebooting- https://pastebin.com/KE1P04n4
Normal reboot with debug level 4- https://pastebin.com/XDdjqLb1
Stops at "init done" everytime after kmod kernel modules are loaded then the device basically halts. Can get into failsafe mode of openwrt but since my isp is PPPoE, cant use it and inbuilt commands to download and upgrade via it.

Does this also work for xiaomi-r3 (mt7620a device) Router which should be the same hardware than xioami-mi-mini? There is an bootloader for the mini-device on hackpascal's site.

Mini - SPI flash
3 - NAND

but you can try...

Thank you very much, I'll try it next week when I am home again. But are you sure I can use the Breed of Mini? - How's the performance of your device with openwrt or padavan? - Actually I thougt about to just extend my wifi of my 7490 with wwan and use the mir3 as a client-bridge through wifi. - It means I hope to solve the 100Mbit/s issue of the wan/lan ports through higher wifi speed. Of course this requires finally a good driver support for MT76x2e under openwrt! - Any experiences with it?

I also thought about this breed: https://breed.hackpascal.net/

Hi @tr4usut, Do you able to fix your dead Lan Port? How do you fix it? am also facing a dead Lan port.
Im on lede/owrt with stock bootloader. Hope anyone can help, Thanks

Hello, Just wanted to update my current issues with dead LAN/Ethernet port.

My suspicion was true, It was a HW related issues in regard to power failure during boot. I may have get a bad power adapter unit or simply the stock power supply just insufficient to power up the router.

So I use another power adapter rated 12v2a (stock 12v1.5a) from my old router, and to my surprise the LAN back alive again. I immediately initiate for Stock Recovery just in case, boot up stock xiaomi firmware and did power cycle the router for like hundred times :laughing: everything went well, no more dead LAN.

For the sake of trying, for now im on Padavan with Breed on bootloader. So far it's really stable I would say, the wifi signal and throughput gain much improvement (Maybe because of a slight powerful adapter?:thinking: idk ) Might going to try Overclocked Padavan on this bigger power adapter.

Just waiting for the LAN to fail again (wish dnt happen again) Thanks

I messed up, instead of installing Breed I ended up following the tutorial and installed the rOOter OS.

So trying to figure out what I did. I ran into SSH and followed the steps

"Breed Download
wget--No-check-certificate https://breed.hackpascal.net/breed-mt7621-xiaomi-r3g.bin-O/tmp/breed-mt7621-xiaomi-r3g.bin

Important! Check MD5 sum and compare to https://breed.hackpascal.net/md5sum.txt 4
Md5sum/tmp/breed-mt7621-xiaomi-r3g.bin
If MD5 mismatch-do not flash (maybe file is broken, etc)

Flash Breed
MTD Write/tmp/breed-mt7621-xiaomi-r3g.bin Bootloader "

But I could not conclude because I had an error message something like MTD could not be written.

I tried to download the develop firmware, renamed it to Miwifi. bin, put on the USB stick and gave the boot again holding the reset to try to return the stock ROM.
It was just flashing the blue Led, and after a few minutes I took it. When I looked at the WiFi was like ROOter OS yet, but it did not respond more on the IP.

I tried to redo this attempt to return the stock ROM, but have not succeeded the LED gets flashing in blue color, and when I turn it is with the IP 192.168.1.1 but now without SSH, and without web interface.

Any suggestions what I can do to fix my mistake?

Before doing this nonsense, I had set up my PPoE and it keeps working, I had not configured the WiFi so the name continues as ROOter and I do not know what the password is.
However I do not have Web Access on IP 192.168.1.1, nor via SSH using Putty

Check with the support channels for ROOter and Breed, neither of which are supported by OpenWrt itself.

I ended up screwing up and installing rOOter, do you know how I can do to revert and install Breed?

I managed to retrieve the Web access and SSH, entering the recovery mode of OpenWRT