"XHR request timed out" after saving settings in Luci [Firefox bug]


Apologies if this is offtopic (it kind of is), but I can trigger this behavior in Firefox only with LuCi. Without using LuCi firefox seems to work just fine.

I'm trying to edit dyndns settings (I'm using nsupdate). After trying to save settings, the save never finishes. After closing the subdialog for the dyndns script, I get a popup in LuCi window saying "XHR request timed out". I can see two Firefox threads pegged at 100% and I can not connect to anything with Firefox. But the router seems fine after this error - I can SSH into it, I use other network software without issues.

After closing Firefox there will be a firefox crash dialog after a while, but I could not connect to any site with Firefox even after restarting it! So Firefox was in an unusable state, even after a reboot. After refreshing (=clearing all history, cookies etc. with the Firefox's refresh feature) the issue still persists, though with the difference now I can connect to other sites after restarting Firefox. I still need to wait a while for the Firefox crash dialog to appear after closing it.

Now, to me this seems like Firefox bug, it should not break down this way in any case, and especially not repeatedly. Any ideas how to gather information on what is LuCi doing to trigger this bug in Firefox? What does the error message actually mean? Also, I would appreciate if anyone who might have faced something similar would share their endeavors with me =)

Ok, replying to myself:

I was trying to reproduce this one more time to get screenshots of the error dialog (to make clear what I mean) - but could not!

Not sure what was going on but unless this resurfaces, I believe this thread is kind of useless =). I will report if I actually can reproduce this.


I've seen it before.

There have been a few threads about it in the past.

1 Like

Hi OldNavyGuy,

Can you provide a link?

I did find some threads with the same error message, but those seem to be about the router actually hanging. This is not the case here. I believe there is something wrong with the LuCi unit for ddns specifically, and the Luci browser UI seems to fail here (only), router is still very much alive itself.

I just hit the "magnifying glass" icon at the top and used the exact error message as the search argument.

1 Like

You didn't mention the version of Firefox you're using, but I've seen reports that Firefox 96 is causing various "connectivity" issues.

I've been using it tonight doing config changes on 21.02.1 and haven't experienced any issues.

Issue sounds like the „Firefox HTTP 3 bug“ - https://news.ycombinator.com/item?id=29918052

Hi all and thanks,

as I can not reproduce this anymore, I'm going to mark this as [SOLVED]. FWIW I was (and am still) using Firefox 96.0.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.