X86 + UE300(RTL 8153) Gigabit USB issues

Hi guys
I was planning on using an old thinPC to setup an x86 router. I;ve connected the TP-Link EU300 to the 3.0 USB and Installed the recommended drivers(kmod-usb-rtl8152). I can see the ETH1 in the interface ho
however if I would try to set it up as LAN static / DHCP WAN - it just doesnt seem to work - packets are increasing by 1 or 2. N
I tried with the latest snapshot and stable version - both have the same issue.
lsusb -t

/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 5000M
    |__ Port 2: Dev 3, If 0, Class=Vendor Specific Class, Driver=r8152, 5000M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 480M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 3: Dev 3, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
        |__ Port 3: Dev 3, If 1, Class=Human Interface Device, Driver=usbhid, 1.5M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 1: Dev 3, If 0, Class=Vendor Specific Class, Driver=, 480M
root@OpenWrt:~#

I can provide more info if needed (I'm a beginner if it comes to OpenWRT so not sure what would be necessary).
Thanks!

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -4 addr ; ip link
> uci export network; \
> uci export dhcp; uci export firewall; \
> head -n -0 /etc/firewall.user; \
> ip -4 addr ; ip link
{
        "kernel": "4.14.195",
        "hostname": "OpenWrt",
        "system": "Intel(R) Celeron(R) CPU 1037U @ 1.80GHz",
        "model": "MICRO-STAR INTERNATIONAL CO., LTD MS-B06211",
        "board_name": "micro-star-international-co-ltd-ms-b06211",
        "release": {
                "distribution": "OpenWrt",
                "version": "19.07.4",
                "revision": "r11208-ce6496d796",
                "target": "x86/64",
                "description": "OpenWrt 19.07.4 r11208-ce6496d796"
        }
}
package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd4c:47e0:1afe::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        list dns '8.8.8.8'
        option gateway '192.168.0.1'
        option delegate '0'
        option ipaddr '192.168.0.159'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'TEST'
        option start '100'
        option leasetime '12h'
        option limit '150'
        option interface 'TEST'

package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan6 wan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qle                                                                                    n 1000
    inet 192.168.0.159/24 brd 192.168.0.255 scope global br-lan
       valid_lft forever preferred_lft forever
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-lan                                                                                     state UP qlen 1000
    link/ether d4:3d:7e:7a:d6:ae brd ff:ff:ff:ff:ff:ff
4: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP qlen                                                                                     1000
    link/ether d0:37:45:28:e0:1a brd ff:ff:ff:ff:ff:ff
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qle                                                                                    n 1000
    link/ether d4:3d:7e:7a:d6:ae brd ff:ff:ff:ff:ff:ff
root@OpenWrt:~#

Are you trying to connect the eth1 on the same network with eth0 by any chance?

I planned on connecting my WAN to the ETH1 and my local switch to ETH0 - when i connect the modem DHCP just stays without IP. Currently both are connected to my old router so I can have luci/internet access to the x86(new) router.

Both in the same network is not going to work.
Could you connect the eth0 to your local switch and eth1 to the old router lan?
Then connect your PC on the local switch, login with SSH and run again the commands.

PC - SWITCH - lan_RPi_wan - Router - internet

I did change it a bit since I cant touch the switch atm:

My PC -> ETH0(lan) -> ETH1(wan) -> modem

This configuration worked on the previous router (also on openwrt) - I'm able to get to the router but it still cant catch the IP from the ISP modem(other devices can)

ubus call system board;
{
        "kernel": "4.14.195",
        "hostname": "OpenWrt",
        "system": "Intel(R) Celeron(R) CPU 1037U @ 1.80GHz",
        "model": "MICRO-STAR INTERNATIONAL CO., LTD MS-B06211",
        "board_name": "micro-star-international-co-ltd-ms-b06211",
        "release": {
                "distribution": "OpenWrt",
                "version": "19.07.4",
                "revision": "r11208-ce6496d796",
                "target": "x86/64",
                "description": "OpenWrt 19.07.4 r11208-ce6496d796"
        }
}
root@OpenWrt:~# uci export network;
package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd4c:47e0:1afe::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        list dns '8.8.8.8'
        option delegate '0'
        option ipaddr '192.168.1.1'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

root@OpenWrt:~# uci export dhcp;
package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'TEST'
        option start '100'
        option leasetime '12h'
        option limit '150'
        option interface 'TEST'

root@OpenWrt:~# uci export firewall;
package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan6 wan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

root@OpenWrt:~# head -n -0 /etc/firewall.user;
# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
root@OpenWrt:~# ip -4 addr ; ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
6: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-lan state UP qlen 1000
    link/ether d4:3d:7e:7a:d6:ae brd ff:ff:ff:ff:ff:ff
4: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP qlen 1000
    link/ether d0:37:45:28:e0:1a brd ff:ff:ff:ff:ff:ff
6: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether d4:3d:7e:7a:d6:ae brd ff:ff:ff:ff:ff:ff
root@OpenWrt:~#

I hope the modem is not giving IPs in the same subnet 192.168.1.X as the OpenWrt LAN interface is.
One more thing, is the USB port you have connected the dongle really USB3 or could it be USB2?

modem gives IP on 10.x.x.x. (on the secondary router) - usb is on 3.0 according to what I see in the logs - my broadband is 500/50 and I wanted to run SQM with layered cake. On 2.0 I can't get more then 200mbps

Is the dongle working fine on your PC?
Are you able to install tcpdump on the OpenWrt? Maybe temporarily connect it over the eth0 interface to the modem.
Then run this to see what is going on:
tcpdump -i eth1 -evn

If I use 2.0 it gets the proper ip - tcpdump from 2.0

tcpdump: listening on eth1, link-type EN10MB (Ethernet), capture size 262144 bytes
14:42:05.611391 d0:37:45:28:e0:1a > 00:00:5e:00:01:0a, ethertype IPv4 (0x0800), length 2049: (tos 0x0, ttl 127, id 13171, offset 0, flags [DF], proto TCP (6), length 2035)
    10.110.74.72.9061 > 139.59.210.197.443: Flags [P.], cksum 0xba9c (incorrect -> 0x4bd6), seq 4198346409:4198348404, ack 3741515707, win 1023, length 1995
14:42:05.632029 00:00:5e:00:01:0a > d0:37:45:28:e0:1a, ethertype IPv4 (0x0800), length 60: (tos 0x0, ttl 55, id 13542, offset 0, flags [DF], proto TCP (6), length 40)
    139.59.210.197.443 > 10.110.74.72.9061: Flags [.], cksum 0x44af (correct), ack 1995, win 989, length 0
14:42:05.649275 00:00:5e:00:01:0a > d0:37:45:28:e0:1a, ethertype IPv4 (0x0800), length 721: (tos 0x0, ttl 55, id 13543, offset 0, flags [DF], proto TCP (6), length 707)
    139.59.210.197.443 > 10.110.74.72.9061: Flags [P.], cksum 0x7b44 (correct), seq 1:668, ack 1995, win 989, length 667
14:42:05.690158 d0:37:45:28:e0:1a > 00:00:5e:00:01:0a, ethertype IPv4 (0x0800), length 54: (tos 0x0, ttl 127, id 13173, offset 0, flags [DF], proto TCP (6), length 40)
    10.110.74.72.9061 > 139.59.210.197.443: Flags [.], cksum 0x41f4 (correct), ack 668, win 1021, length 0
14:42:06.719383 d0:37:45:28:e0:1a > 00:00:5e:00:01:0a, ethertype IPv4 (0x0800), length 58: (tos 0x0, ttl 127, id 61683, offset 0, flags [none], proto UDP (17), length 44)
    10.110.74.72.51714 > 192.168.0.209.8612: UDP, length 16
14:42:07.056580 00:00:5e:00:01:0a > d0:37:45:28:e0:1a, ethertype IPv4 (0x0800), length 413: (tos 0x0, ttl 54, id 4748, offset 0, flags [DF], proto TCP (6), length 399)
    66.203.125.12.443 > 10.110.74.72.9094: Flags [P.], cksum 0xad77 (correct), seq 1195519700:1195520059, ack 3489776361, win 42161, length 359
14:42:07.057106 d0:37:45:28:e0:1a > 00:00:5e:00:01:0a, ethertype IPv4 (0x0800), length 397: (tos 0x0, ttl 127, id 14903, offset 0, flags [DF], proto TCP (6), length 383)
    10.110.74.72.9094 > 66.203.125.12.443: Flags [P.], cksum 0x0e6b (correct), seq 1:344, ack 359, win 64240, length 343
14:42:07.081481 00:00:5e:00:01:0a > d0:37:45:28:e0:1a, ethertype IPv4 (0x0800), length 60: (tos 0x0, ttl 54, id 4749, offset 0, flags [DF], proto TCP (6), length 40)
    66.203.125.12.443 > 10.110.74.72.9094: Flags [.], cksum 0xc594 (correct), ack 344, win 42161, length 0
14:42:07.611552 d0:37:45:28:e0:1a > 00:00:5e:00:01:0a, ethertype IPv4 (0x0800), length 1817: (tos 0x0, ttl 127, id 13174, offset 0, flags [DF], proto TCP (6), length 1803)
    10.110.74.72.9061 > 139.59.210.197.443: Flags [P.], cksum 0xb9b4 (incorrect -> 0x6b82), seq 1995:3758, ack 668, win 1021, length 1763
14:42:07.611572 d0:37:45:28:e0:1a > 00:00:5e:00:01:0a, ethertype IPv4 (0x0800), length 1833: (tos 0x0, ttl 127, id 13176, offset 0, flags [DF], proto TCP (6), length 1819)
    10.110.74.72.9089 > 139.59.210.197.443: Flags [P.], cksum 0xb9c4 (incorrect -> 0x69eb), seq 2652091810:2652093589, ack 3650931132, win 1022, length 1779
14:42:07.612488 d0:37:45:28:e0:1a > 00:00:5e:00:01:0a, ethertype IPv4 (0x0800), length 1831: (tos 0x0, ttl 127, id 13178, offset 0, flags [DF], proto TCP (6), length 1817)
    10.110.74.72.9069 > 139.59.210.197.443: Flags [P.], cksum 0xb9c2 (incorrect -> 0x1af9), seq 1785385088:1785386865, ack 1801176532, win 1026, length 1777
14:42:07.630742 00:00:5e:00:01:0a > d0:37:45:28:e0:1a, ethertype IPv4 (0x0800), length 60: (tos 0x0, ttl 55, id 43900, offset 0, flags [DF], proto TCP (6), length 40)
    139.59.210.197.443 > 10.110.74.72.9089: Flags [.], cksum 0xd6a3 (correct), ack 1779, win 827, length 0
14:42:07.630956 d0:37:45:28:e0:1a > 00:00:5e:00:01:0a, ethertype IPv4 (0x0800), length 310: (tos 0x0, ttl 127, id 13180, offset 0, flags [DF], proto TCP (6), length 296)
    10.110.74.72.9089 > 139.59.210.197.443: Flags [P.], cksum 0x8b93 (correct), seq 1779:2035, ack 1, win 1022, length 256
14:42:07.631719 00:00:5e:00:01:0a > d0:37:45:28:e0:1a, ethertype IPv4 (0x0800), length 60: (tos 0x0, ttl 55, id 11912, offset 0, flags [DF], proto TCP (6), length 40)
    139.59.210.197.443 > 10.110.74.72.9069: Flags [.], cksum 0x63c0 (correct), ack 1777, win 297, length 0
14:42:07.631744 00:00:5e:00:01:0a > d0:37:45:28:e0:1a, ethertype IPv4 (0x0800), length 60: (tos 0x0, ttl 55, id 13544, offset 0, flags [DF], proto TCP (6), length 40)
    139.59.210.197.443 > 10.110.74.72.9061: Flags [.], cksum 0x3b16 (correct), ack 3758, win 1016, length 0
14:42:07.631950 d0:37:45:28:e0:1a > 00:00:5e:00:01:0a, ethertype IPv4 (0x0800), length 310: (tos 0x0, ttl 127, id 13181, offset 0, flags [DF], proto TCP (6), length 296)
    10.110.74.72.9069 > 139.59.210.197.443: Flags [P.], cksum 0xd71e (correct), seq 1777:2033, ack 1, win 1026, length 256
14:42:07.631968 d0:37:45:28:e0:1a > 00:00:5e:00:01:0a, ethertype IPv4 (0x0800), length 310: (tos 0x0, ttl 127, id 13182, offset 0, flags [DF], proto TCP (6), length 296)
    10.110.74.72.9061 > 139.59.210.197.443: Flags [P.], cksum 0x2d3a (correct), seq 3758:4014, ack 668, win 1021, length 256
14:42:07.688811 00:00:5e:00:01:0a > d0:37:45:28:e0:1a, ethertype IPv4 (0x0800), length 725: (tos 0x0, ttl 55, id 11913, offset 0, flags [DF], proto TCP (6), length 711)
    139.59.210.197.443 > 10.110.74.72.9069: Flags [P.], cksum 0x0070 (correct), seq 1:672, ack 2033, win 319, length 671
14:42:07.695741 00:00:5e:00:01:0a > d0:37:45:28:e0:1a, ethertype IPv4 (0x0800), length 60: (tos 0x0, ttl 55, id 43901, offset 0, flags [DF], proto TCP (6), length 40)
    139.59.210.197.443 > 10.110.74.72.9089: Flags [.], cksum 0xd58c (correct), ack 2035, win 850, length 0
14:42:07.696953 00:00:5e:00:01:0a > d0:37:45:28:e0:1a, ethertype IPv4 (0x0800), length 60: (tos 0x0, ttl 55, id 13545, offset 0, flags [DF], proto TCP (6), length 40)
    139.59.210.197.443 > 10.110.74.72.9061: Flags [.], cksum 0x39ff (correct), ack 4014, win 1039, length 0
14:42:07.698182 00:00:5e:00:01:0a > d0:37:45:28:e0:1a, ethertype IPv4 (0x0800), length 725: (tos 0x0, ttl 55, id 43902, offset 0, flags [DF], proto TCP (6), length 711)
    139.59.210.197.443 > 10.110.74.72.9089: Flags [P.], cksum 0xf2e1 (correct), seq 1:672, ack 2035, win 850, length 671
14:42:07.701181 00:00:5e:00:01:0a > d0:37:45:28:e0:1a, ethertype IPv4 (0x0800), length 725: (tos 0x0, ttl 55, id 13546, offset 0, flags [DF], proto TCP (6), length 711)
    139.59.210.197.443 > 10.110.74.72.9061: Flags [P.], cksum 0x646f (correct), seq 668:1339, ack 4014, win 1039, length 671
14:42:07.729650 d0:37:45:28:e0:1a > 00:00:5e:00:01:0a, ethertype IPv4 (0x0800), length 54: (tos 0x0, ttl 127, id 13183, offset 0, flags [DF], proto TCP (6), length 40)
    10.110.74.72.9069 > 139.59.210.197.443: Flags [.], cksum 0x5d4b (correct), ack 672, win 1023, length 0
14:42:07.738556 d0:37:45:28:e0:1a > 00:00:5e:00:01:0a, ethertype IPv4 (0x0800), length 54: (tos 0x0, ttl 127, id 13184, offset 0, flags [DF], proto TCP (6), length 40)
    10.110.74.72.9089 > 139.59.210.197.443: Flags [.], cksum 0xd23d (correct), ack 672, win 1026, length 0
14:42:07.742472 d0:37:45:28:e0:1a > 00:00:5e:00:01:0a, ethertype IPv4 (0x0800), length 54: (tos 0x0, ttl 127, id 13185, offset 0, flags [DF], proto TCP (6), length 40)
    10.110.74.72.9061 > 139.59.210.197.443: Flags [.], cksum 0x376d (correct), ack 1339, win 1026, length 0

TCP Dump from 3.0

tcpdump: listening on eth1, link-type EN10MB (Ethernet), capture size 262144 bytes
14:42:26.982009 d0:37:45:28:e0:1a > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 130: (hlim 1, next-header Options (0) payload length: 76) fe80::d237:45ff:fe28:e01a > ff02::16: HBH (rtalert: 0x0000) (padn) [icmp6 sum ok] ICMP6, multicast listener report v2, 3 group record(s) [gaddr ff02::1:ff00:0 to_ex, 0 source(s)] [gaddr ff02::1:ff28:e01a to_ex, 0 source(s)] [gaddr ff02::2 to_ex, 0 source(s)]
14:42:27.142003 d0:37:45:28:e0:1a > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 90: (hlim 1, next-header Options (0) payload length: 36) fe80::d237:45ff:fe28:e01a > ff02::16: HBH (rtalert: 0x0000) (padn) [icmp6 sum ok] ICMP6, multicast listener report v2, 1 group record(s) [gaddr ff02::1:ff00:0 to_ex, 0 source(s)]
14:42:28.102017 d0:37:45:28:e0:1a > ff:ff:ff:ff:ff:ff, ethertype IPv4 (0x0800), length 342: (tos 0x0, ttl 64, id 0, offset 0, flags [none], proto UDP (17), length 328)
    0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from d0:37:45:28:e0:1a, length 300, xid 0x72c4696b, secs 4, Flags [none]
          Client-Ethernet-Address d0:37:45:28:e0:1a
          Vendor-rfc1048 Extensions
            Magic Cookie 0x63825363
            DHCP-Message Option 53, length 1: Discover
            MSZ Option 57, length 2: 576
            Parameter-Request Option 55, length 8:
              Subnet-Mask, Default-Gateway, Domain-Name-Server, Hostname
              Domain-Name, BR, NTP, Classless-Static-Route
            Vendor-Class Option 60, length 12: "udhcp 1.30.1"
            Hostname Option 12, length 7: "OpenWrt"
14:42:31.192017 d0:37:45:28:e0:1a > ff:ff:ff:ff:ff:ff, ethertype IPv4 (0x0800), length 342: (tos 0x0, ttl 64, id 0, offset 0, flags [none], proto UDP (17), length 328)
    0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from d0:37:45:28:e0:1a, length 300, xid 0x72c4696b, secs 7, Flags [none]
          Client-Ethernet-Address d0:37:45:28:e0:1a
          Vendor-rfc1048 Extensions
            Magic Cookie 0x63825363
            DHCP-Message Option 53, length 1: Discover
            MSZ Option 57, length 2: 576
            Parameter-Request Option 55, length 8:
              Subnet-Mask, Default-Gateway, Domain-Name-Server, Hostname
              Domain-Name, BR, NTP, Classless-Static-Route
            Vendor-Class Option 60, length 12: "udhcp 1.30.1"
            Hostname Option 12, length 7: "OpenWrt"
14:42:34.271996 d0:37:45:28:e0:1a > ff:ff:ff:ff:ff:ff, ethertype IPv4 (0x0800), length 342: (tos 0x0, ttl 64, id 0, offset 0, flags [none], proto UDP (17), length 328)
    0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from d0:37:45:28:e0:1a, length 300, xid 0x72c4696b, secs 10, Flags [none]
          Client-Ethernet-Address d0:37:45:28:e0:1a
          Vendor-rfc1048 Extensions
            Magic Cookie 0x63825363
            DHCP-Message Option 53, length 1: Discover
            MSZ Option 57, length 2: 576
            Parameter-Request Option 55, length 8:
              Subnet-Mask, Default-Gateway, Domain-Name-Server, Hostname
              Domain-Name, BR, NTP, Classless-Static-Route
            Vendor-Class Option 60, length 12: "udhcp 1.30.1"
            Hostname Option 12, length 7: "OpenWrt"

Do you mean a usb2 to ethernet dongle or usb2 port?

sorry, I've connected the USB dongle(3.0) to USB 2.0 port

And if you connect it to a usb3 port on another device does it work fine?
Is there another usb3 port on the thinPC you are using as router to try?

1 Like

It does work on my W10. I have 2 usb 3.0 on that thinPC and both react the same
Also now I'm gettting in Putty that clearly indicates something going wrong with that port/dongle

ERROR Transfer event TRB DMA ptr not part of current TD ep_index 2 comp_code 13
[  277.193551] xhci_hcd 0000:03:00.0: Looking for event-dma 00000000d60161f0 trb-start 00000000d6016200 trb-end 00000000d6016210 seg-start 00000000d6016000 seg-end 00000000d6016ff0
[  284.954252] xhci_hcd 0000:03:00.0: ERROR Transfer event TRB DMA ptr not part of current TD ep_index 2 comp_code 13
[  284.954834] xhci_hcd 0000:03:00.0: Looking for event-dma 00000000d6016210 trb-start 00000000d6016220 trb-end 00000000d6016220 seg-start 00000000d6016000 seg-end 00000000d6016ff0
[  574.682146] xhci_hcd 0000:03:00.0: ERROR Transfer event TRB DMA ptr not part of current TD ep_index 2 comp_code 13
[  574.682727] xhci_hcd 0000:03:00.0: Looking for event-dma 00000000d6016400 trb-start 00000000d6016410 trb-end 00000000d6016410 seg-start 00000000d6016000 seg-end 00000000d6016ff0
[  636.244347] xhci_hcd 0000:03:00.0: ERROR Transfer event TRB DMA ptr not part of current TD ep_index 2 comp_code 13
[  636.244929] xhci_hcd 0000:03:00.0: Looking for event-dma 00000000d6016480 trb-start 00000000d6016490 trb-end 00000000d6016490 seg-start 00000000d6016000 seg-end 00000000d6016ff0
[  656.919839] xhci_hcd 0000:03:00.0: ERROR Transfer event TRB DMA ptr not part of current TD ep_index 2 comp_code 13
[  656.920423] xhci_hcd 0000:03:00.0: Looking for event-dma 00000000d60164c0 trb-start 00000000d60164d0 trb-end 00000000d60164d0 seg-start 00000000d6016000 seg-end 00000000d6016ff0
[  727.043352] xhci_hcd 0000:03:00.0: ERROR Transfer event TRB DMA ptr not part of current TD ep_index 2 comp_code 13
[  727.043939] xhci_hcd 0000:03:00.0: Looking for event-dma 00000000d6016570 trb-start 00000000d6016580 trb-end 00000000d6016580 seg-start 00000000d6016000 seg-end 00000000d6016ff0
[  912.258003] xhci_hcd 0000:03:00.0: ERROR Transfer event TRB DMA ptr not part of current TD ep_index 2 comp_code 13
[  912.258583] xhci_hcd 0000:03:00.0: Looking for event-dma 00000000d6016660 trb-start 00000000d6016670 trb-end 00000000d6016670 seg-start 00000000d6016000 seg-end 00000000d6016ff0
[  998.912340] xhci_hcd 0000:03:00.0: ERROR Transfer event TRB DMA ptr not part of current TD ep_index 2 comp_code 13
[  998.912923] xhci_hcd 0000:03:00.0: Looking for event-dma 00000000d60166d0 trb-start 00000000d60166e0 trb-end 00000000d60166e0 seg-start 00000000d6016000 seg-end 00000000d6016ff0

Maybe something is wrong with the usb3 controller of the thinPC then. If you had another usb3 device you could verify that.

The SSD that runs on 3.0 works fine...I would say a driver issues;/

r8152 works fine on my usb3 dongle. Which version are you running?

opkg list-installed | grep 8152
kmod-usb-net-rtl8152 - 5.4.61-1
kmod-usb-net-rtl8152 - 4.14.195-1

Maybe you could try a snapshot version to see if the problem persists? Careful as snapshot is not coming with Luci preinstalled.
Take a backup of the configuration to be able to roll back. After installing the snapshot apply only the necessary configuration to start the usb3 and test.